1. Are you ready for the Galaxy S20? Here is everything we know so far!

Trouble updating to 2.1

Discussion in 'Android Devices' started by davidov92, Aug 11, 2010.

  1. davidov92

    davidov92 Newbie
    Thread Starter

    OK, so I have a Samsung Galaxy Spica i5700. Came with Android 1.5 and now I want to update it to the official 2.1

    So, I've got NPS working, update started, everything working as a charm, but then at the third step, installation, it stayed quite a bit at 0% and then it said it didn't succeed and that I need to do an emergency backup / reset (can't remember what it's called) (so I did what it asked me to do Vol Down + Cam + Power but nothing happened, and started up the phone again, and it was all the same)

    OK, so what I want to know is : how can I fix this ? How can I update with NPS without getting the error, since I don't want to risk flashing it and losing warranty.

  2. Anden1986

    Anden1986 Lurker

    Had the same problem :( What I did was:

    1. Removed memorycard and sim-card from phone
    2. Did a hard reset (with phone off push volume down, answer call and power at the same time - in that order!)
    3. Connected to PC again and ran the install :)

    Hope this helps! Otherwise let me know...
  3. davidov92

    davidov92 Newbie
    Thread Starter

    Nope. I can't hard reset. Pressing them down in that order but nothing happens apart from the button's usual functions...

    Hard resetting can be done from the settings right ? But that will result in deletion of all apps etc. etc. Since that will probably happen, I have to ask : Google maps, and all that, those come with 2.1 or can be downloaded, right ?

    Also, any way to do a backup to PC of everything I have on my phone, since I might mess this one up.

    I also think there's some sort of special firmware on it, since it shows an SFR logo and some SFR apps (SFR I guess is some French operator, since everything is in French). Could that be a problem, and will that be removed by hard resetting ?
  4. Poopyfist

    Poopyfist Newbie

    I had the same thing happen, got the update started and it downloaded, but then it just got stuck installing at 0%. I had forgotten to take my sim card out and I got a phone call right before it got started, I think that may have been a factor - were you using your phone at all during the update?

    In any case, I tried it once more later on (again forgetting to take out the sim card) and it worked perfectly with no problems :cool:

    I'd give it another go if I were you.
  5. Poopyfist

    Poopyfist Newbie

    Oh, also I believe to perform a hard reset you're supposed to push volume down + CAMERA button + phone on

    edit - this is how you switch to recovery mode actually
  6. davidov92

    davidov92 Newbie
    Thread Starter

    Nope, still not working.

    No hard reset, install still stuck at 0.
  7. mug2k

    mug2k Newbie

    Are you getting stuck in download mode ?. e.g. phone off, then pressing vol down, camera and power ?. I get stuck there, its supposed to start installing some drivers but mine never does and I get notifications on my pc saying the drivers didn't install properly.

    When my phone is turned on for normal use the drivers are in device managr and appear as they are supposed to.

    Its a pain because I've tried this about 4 times now and it always fails the same way and I've got to go through monotony of reinstalling all my apps again :(
  8. davidov92

    davidov92 Newbie
    Thread Starter

    Nope haven't tried it in DL mode...

    Any risks of trying it this way ?
  9. mug2k

    mug2k Newbie

    I thought thats how your supposed to do it :thinking: :eek:

    Maybe I'm trying to do it some different way from everyone else. Which guide are you using ?.
  10. davidov92

    davidov92 Newbie
    Thread Starter

    Guide ? What guide ? If I would've found any I wouldn't have came here. All I found were "flashing"/"rooting" guides. Which is NOT what I want to do because it voids warranty.
  11. mug2k

    mug2k Newbie

  12. davidov92

    davidov92 Newbie
    Thread Starter

    Ah, yeah, that's flashing it. Not trying it yet. Too scared of a potential screw-up...
  13. mug2k

    mug2k Newbie

    I was the same but got sicking of waiting for t-mobile, I doubt their will ever be an official update from them.
  14. Poopyfist

    Poopyfist Newbie

    Are you using the latest version of NPS?
  15. mug2k

    mug2k Newbie

    yep, downloaded from the samsung website.
  16. davidov92

    davidov92 Newbie
    Thread Starter

    Yes. Installed from the drivers CD, and updated.
  17. Poopyfist

    Poopyfist Newbie

    The first thing I would try entering is *2767*3855# into the dialpad to do a hard reset, remove the sim card, sd card and then try to update on NPS again.

    Another thing to try would be a factory reset (this is what worked for me) but be sure to backup all your stuff before you try that. There is an option under settings for the factory reset. Oh, and when I factory reset my phone, it switched the language to czech and it was a bit difficult to switch it back to english. Be sure you know exactly how to change languages before you do the factory reset.
  18. Crash27

    Crash27 Android Enthusiast

    I got it to work finally, I had to restart my phone and the update 5 times before it started to install, but it finally did and is running great now. All I need now is to figure out how to use animated wallpapers LOL

Samsung Galaxy Spica Forum

The Samsung Galaxy Spica release date was November 2009. Features and Specs include a 3.2" inch screen, 3MP camera, GB RAM, processor, and 1500mAh battery.

November 2009
Release Date

Share This Page