1. Are you ready for the Galaxy S20? Here is everything we know so far!

Trouble with Updating Firmware and other stuff - Galaxy S

Discussion in 'Android Devices' started by Allypopz, Jul 7, 2013.

  1. Allypopz

    Allypopz Lurker
    Thread Starter

    Hi

    I got my sister's 2 year old Samsung Galaxy S2 off her last week and have been battling ever since.

    I need to unlock it. It's currently with Orange UK. I tried following a couple of guides about rooting it, and got completely confused when it came to kernels and there was a whole list of different numbers and I had no idea what to do.

    So I went with GSM Liberty and got an unlock code which didn't work. After waiting a day, my case being escalated and them not bothering to respond, I gave up and got a refund.

    Am now looking again before I take it into town and get someone to do it for me. I realise that I need to update my firmware as it appears, I'm guessing from the number it currently is, is very out of date. My sister's not tech savvy at all so won't have done anything except use it. I am, but admit when it comes to this, I am very out of my depth and have never had an Android before.

    I have Kies but I get a message saying that Kies is unable to update my firmware, so have done a number of searches to tell me how to do it without Kies. I'm guessing from what I've read here and elsewhere that Kies is pretty rubbish, but have seen a number of other pieces of software, but am unsure which are okay and which may be dodgy.

    I read through the Dummies guide to updating firmware on this forum and couldn't find my CSC code anywhere on it so guessed I shouldn't go any further.

    Please can anybody help?

    Below is all the information I think you may need, but let me know if you need anything else.

    PDA: I9000BVJS4
    Phone: I9000BVJP4
    CSC: I9000ORAJS4
    Build Info: 2011 . 02
    Firmware: 2.2.1
    Build number: FROYO.BVJS4

    I'm using Mac OSX, Lion 10.7.5
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Unforgiven

    Unforgiven ...eschew obfuscation...
    Moderator

    I moved this to the S2 International All Things Root forum as the folks here will be better equipped to answer your questions.:)
     
    Allypopz and Mikestony like this.
  3. kelis32

    kelis32 Android Enthusiast

    Unforgiven and Slug like this.
  4. Slug

    Slug Check six!
    VIP Member

    Thanks for the quick heads-up on the model number, Kelis. It looks like SuperOneClick is the way to go with the 2.2.1 firmware.
     
    Unforgiven likes this.
  5. Unforgiven

    Unforgiven ...eschew obfuscation...
    Moderator

    Yes, thank kelis. Based on your knowledge I was able to get this where it belonged.:)
     
  6. Allypopz

    Allypopz Lurker
    Thread Starter

    Sorry - I'm a bit confused with 'His phone is a Galaxy S' and the thing about SuperOneClick???

    In the meantime, I am having a look at the link provided!

    Edit: Oh I see - SuperOneClick is on that link. I'm a bit confused with terminology about reflashing bootloaders ... but am ploughing on through! :(
     
  7. Allypopz

    Allypopz Lurker
    Thread Starter

    Hi. I, and my husband (who is way more technical than me) have spent hours trying to sort this, but have gotten more and more confused and the things we have tried don't work so have had to admit defeat. I'm going to have to take it into my town centre and just pay to get it unlocked there. Perhaps the firmware, if I need it, will upgrade then.



    Thanks for your help anyway.
     

Samsung Galaxy S Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...