1. Are you ready for the Galaxy S20? Here is everything we know so far!

Trying to get a2sd working on Evil Eris 3.0

Discussion in 'Android Devices' started by iAndroiid, Jul 27, 2010.

  1. iAndroiid

    iAndroiid Android Enthusiast
    Thread Starter

    Trying to get a2sd working and tried multiple times and can't seem to get it to work. Here are the steps I took. If anyone has the correct way or steps to get this working i'd love to get a2sd working on evil eris 3.0.

    1. flash evil eris 3.0 to my phone (EvilEris3.0 zip)
    2. flash kernel update (ee3kernel-signed zip)
    3. after doing kernel update w/o rebooting; partitioned the sd card; then clicked select sd:ext2 to ext3
    3. downloaded a2sd and placed it onto the sd card (dtapps2sd-2.7.5-pf4a signed zip folder)
    4. flashed a2sd (dtapps2sd-2.7.5-pf4a-signed zip folder)
    5. rebooted
    6. waited for the phone to turn on but it just stays black. for 20+ minutes and nothing happens.

    Today, I recently flashed evil eris 3.0 rom back onto the phone and would like to start out from scratch and have someone post up a guide that works since the one on xda doesn't work and every other page i've found in google can not get a2sd working on my evil eris 3.0. Please help me find a solution to get a2sd working on evil eris 3.0.

    1. Download the Forums for Android™ app!


  2. iAndroiid

    iAndroiid Android Enthusiast
    Thread Starter

    Trying this right now.

    1. a. flash evil eris 3.0 (made sure it booted up and it works properly)
    b. rebooted to make sure it worked properly which it did
    c. shut down the phone
    d. start up phone wish up arrow volume + power key

    2. a. partition sd card
    b. swap size 32mb
    c. ext2-size 512mb
    d. then ran select sd:ext2 to ext3 which updraged ext2 to ext3...
    e. then rebooted

    3. took a2sd-2.7-update3r1-signed zipped folder from desktop and extracted folder contents so it was no longer a zipped folder
    4. moved a2sd-2.7-update3r1-signed folder to sd card
    5. downloaded astro file manager from android market
    6. uninstalled vendor.apk? that was in .apk file in a2sd-2.7-update3r1-signed folder
    a. i guess it was installed already?
    b. then went back into it and upgraded it was the only option b/c uninstall didn't work
    c. clicked back on vending.apk
    d. then clicked launch
    e. then the market opened up
    f. asked if i accepeted terms and use so i clicked "accept"

    7. what should i do next?
  3. OfTheDamned

    OfTheDamned The Friendly Undead

    At this point you have a2sd installed and the EE3.0 rom running correct?

    I would restart the phone and see if a2sd is working. If it is, you should see a big difference in the available internal memory. If it is not, then you should the same amount of memory you had before restart. If it is not working then try flashing the EE3.0/a2sd update and see if it works upon start. If it does not, then I will start looking for the SDK script that should get it running.
  4. iAndroiid

    iAndroiid Android Enthusiast
    Thread Starter

    ok, on the first reboot there was double of most my app's. like 2-messages, 2 mails, that was in the icon folder where all my app's are. like to the left of the phone if i open up "all programs". this is on the actual phone. i then rebooted again after that and now there is only 1 of each program and icon. however the memory is stilll at 76.64mb

    should i run the ee3.0 update (ee3kernel-signed zip folder)
    flash the ee3kernel-signed zip folder?

    i'm about to flash this zipped folder ee3kernel-signed

    after that i will post up if the phone boots.

    *edit: i flashed the ee3kernel-signed zip folder

    my available space is now 85.16mb. so something worked correct? i went from 76.64mb to 85.16mb. will my free space keep going up or what should i do next?

  5. iAndroiid

    iAndroiid Android Enthusiast
    Thread Starter

    Also i downloaded an app and my internal memory went down. Am i supposed to flash a2sd zipped folder? Ididnt flash it because last time I tried it the phone bricked
  6. OfTheDamned

    OfTheDamned The Friendly Undead

    Do you have the Android SDK installed on your computer?
  7. iAndroiid

    iAndroiid Android Enthusiast
    Thread Starter

    No, should I? Is there a certain version? link please
  8. OfTheDamned

    OfTheDamned The Friendly Undead

  9. iAndroiid

    iAndroiid Android Enthusiast
    Thread Starter

  10. OfTheDamned

    OfTheDamned The Friendly Undead

    Ok, download the SDK and install it to the C drive.

    On your phone, go to Settings > Applications > Development and check USB debugging (it may be on by default. Then plug the phone into the USB cable and let the computer find it. If it has any trouble finding it download HTC sync from here and install it. This will give you necessary drivers.

    Once you everything set up and the phone is connected (don't mount it) go to start > run on your desktop. In run type in

    This should bring up a dos window. In here type in
    be sure to leave a space between cd a C:

    Now type in
    which should give you a # symbol

    Type in
    which will tell you what is working and what isn't

    You can then type in
    to get a list of commands

    You should see something like
    That is what you want to use.
  11. DDustiNN

    DDustiNN Android Enthusiast

    Getting a2sd to work on Evil Eris was just way too much of a hassle and I couldn't figure it out for some reason. I tried White Widow and it worked right out of the box (so to speak ;)) and seems much easier to manage. I have since switched to CELB 2.8 and it's the same setup.

    If you can live without Sense, I recommend giving either of those ROMs a shot. I actually like them a lot better than any of the Sense-based ones I tried.
  12. iAndroiid

    iAndroiid Android Enthusiast
    Thread Starter


    this is what i get when i try to run the sdk setup\

    nvm, i went to force downloads and am waiting for it to update/download.
  13. xx_bishop_xx

    xx_bishop_xx Android Expert

    ^^ in "settings" have you tried placing a checkmark in "Force https://....."?
  14. iAndroiid

    iAndroiid Android Enthusiast
    Thread Starter

    i just did but it's taking forever to update archives. like over 10min+ so far
  15. iAndroiid

    iAndroiid Android Enthusiast
    Thread Starter

    did everything you said and this is what i get...
  16. OfTheDamned

    OfTheDamned The Friendly Undead

    You need to find the location of the Android-sdk-windows folder then. If it isn't on C then it may be in documents.
  17. xx_bishop_xx

    xx_bishop_xx Android Expert

    Should be "android-sdk-windows" rather than "anroid-sdk-windows". There is a "d" in "android". Well, 2 "d's" total.

    *Edit* Unless you really titled the folder that.
  18. OfTheDamned

    OfTheDamned The Friendly Undead

    That would do it too. Typos will kill you when doing commands
  19. iAndroiid

    iAndroiid Android Enthusiast
    Thread Starter

    i changed the typing and it still doesn't work. anyone want to remote into the laptop i'm using here at work and figure this shit out? using showmypc.com?

    here's what happens when i click on sdk setup


    it keeps downloading a bunch of stuff.
  20. xx_bishop_xx

    xx_bishop_xx Android Expert

    What method did you use to root? If you used alprazolam's method in surgeon's write-up, this should all have been done already. I would imagine.

    I can also see in this last post that your SDK folder is on your desktop and titled "android-sdk-_r06-windows...etc".
  21. iAndroiid

    iAndroiid Android Enthusiast
    Thread Starter

  22. iAndroiid

    iAndroiid Android Enthusiast
    Thread Starter

    so the one on the desktop is...

    inside that folder is....
  23. xx_bishop_xx

    xx_bishop_xx Android Expert

    If you feel your SDK is not set up correctly, look through the first post starting with "Pre-requisite:Android SDK".

  24. iAndroiid

    iAndroiid Android Enthusiast
    Thread Starter

  25. xx_bishop_xx

    xx_bishop_xx Android Expert

    In order for the commands that OTD gave you to work, it must match where you have the SDK installed. Or change the command. If you're struggling, I would recommend copying the contents android-sdk-windows file from the desktop folder into a new folder called c:\android-sdk-windows.

    Or flash WhiteWidow4.6 and partition your card. The app2sd works fine for me.



HTC Droid Eris Forum

The HTC Droid Eris release date was November 2009. Features and Specs include a 3.2" inch screen, 5MP camera, 288GB RAM, MSM7600 processor, and 1300mAh battery.

November 2009
Release Date

Share This Page