1. Download our Official Android App: Forums for Android!

Root trying to root - usb debugging?

Discussion in 'Android Devices' started by jr1125, Oct 5, 2010.

  1. jr1125

    jr1125 Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    308
    Joined:
    Aug 17, 2010

    Aug 17, 2010
    308
    8
    36

    Advertisement

  2. jr1125

    jr1125 Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    308
    Joined:
    Aug 17, 2010

    Aug 17, 2010
    308
    8
    36
    ive even uninstalled and installed moto drivers and updated them.

    plugged in phone in pc mode..let it verify device. activate usb debug, let it to its thing but still nothing/
     
  3. jdk33

    jdk33 Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    211
    Joined:
    Jul 16, 2010

    Jul 16, 2010
    211
    37
    43
    Flo Rida
    Put it in charge only, follow the instructions on installing adb. Once you're in the adb tools directory, run "adb devices" and see if your Droid X shows up as a connected device. If so then you've succeeded in getting adb to recognize your device.
     
  4. jr1125

    jr1125 Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    308
    Joined:
    Aug 17, 2010

    Aug 17, 2010
    308
    8
    36
    im in the tools directory and there is no adb devices
     
  5. mach330

    mach330 Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    127
    Joined:
    Dec 16, 2009

    Dec 16, 2009
    127
    5
    36
    The OC
    i just did this a couple of days ago. i had pretty much the same type of problems on not recognizing the device. in the instructions i saw someone said put it in charge mode, or even some other modes. what worked for me is the sync mode, then it recognize the device. try all the different connections. regardless, usb debugging is always on. one of the modes should work for you.

    edit: this is the link i used that worked for me except i didn't use pc mode. i used windows sync mode i believe. or whatever the other mode is.

    http://www.droid-life.com/2010/08/26/droid2-rooting-method-works-for-droidx-running-froyo/
     
  6. mach330

    mach330 Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    127
    Joined:
    Dec 16, 2009

    Dec 16, 2009
    127
    5
    36
    The OC
    he mean once you installed adb, you can type "adb devices" on cmd prompt and you should see your device. if device is not found, then you probably need to change the connection mode to something else. try all the settings.
     
  7. jr1125

    jr1125 Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    308
    Joined:
    Aug 17, 2010

    Aug 17, 2010
    308
    8
    36
    when i go to run...cmd]

    and type that it says adb not recognized is not a internal or external command or whatveer
     
  8. jr1125

    jr1125 Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    308
    Joined:
    Aug 17, 2010

    Aug 17, 2010
    308
    8
    36
    cd data/local/tmp - when i get to that part it says system cannot find specified path
     
  9. yawdapaah

    yawdapaah Android Expert
    Rank:
    None
    Points:
    113
    Posts:
    900
    Joined:
    Aug 20, 2009

    Aug 20, 2009
    900
    288
    113
    EE
    NJ
    OK. First, you need to add the location of your SDK to your system environment.
    I've added "C:\androidsdk\tools" to the "PATH" system variable. So I can use the adb commands no matter which directory I'm in. The simpler solution is to change directory in command prompt to your tools folder (in adroidsdk), put all your rooting files in there and perform the operations from within that folder.

    If you're on XP, right click My computer => properties => Advanced tab => Environment variables (at the bottom) => look in the "system variables" section for 'PATH' => click edit => APPEND your sdk folder to the list of directories. Use a semicolon between each directory.
    If you're on windows 7 it's even easier; right click Computer => properties => Advanced system settings on the left side.
    If you're on anything else, you're done and can't root. Ever!

    jk. Someone else will have that answer.

    Mine looks like this:

    '...whatever was there before'; c:\androidsdk\tools

    Next issue.
    I'm assuming you've installed the adb interface drivers (you will see ADB Interface in Device Manager) since it shows up in USB mode.
    When you're in PC mode (which you must be in to root), you WON'T see the debugging icon in the notification bar. It won't show up.
    After you're done with the first problem, you need to run ADB DEVICES in command prompt. If your devices is connected, you'll see a bunch of numbers with the word device next to them.
    You should be good to go from there.

    Ask if you have any other issues.
    GL :D
     
  10. jr1125

    jr1125 Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    308
    Joined:
    Aug 17, 2010

    Aug 17, 2010
    308
    8
    36
    ended up figuring it out. am now rooted.. :)
     
  11. jr1125

    jr1125 Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    308
    Joined:
    Aug 17, 2010

    Aug 17, 2010
    308
    8
    36
    now that im rooted. the super user ninja guy, when i click on him is anything suppose to happen cuz it brings me to a black screen for that icon.
     
  12. mach330

    mach330 Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    127
    Joined:
    Dec 16, 2009

    Dec 16, 2009
    127
    5
    36
    The OC
    nah..it's just gonna have the list of rooted apps you have that's enabled. if you have no rooted apps, then you'll see nothing. having the ninja just means you're rooted (kind of). my bro's wife had it, but lost root still. which is why i did the method above to root her back.
     
  13. gcalig

    gcalig Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Oct 5, 2010

    Oct 5, 2010
    4
    0
    5
    I have tried anything and everything and can not re-root my Verizon Droid X 2.2. Anyone in Pittsburgh able to help in person?
     
  14. jdk33

    jdk33 Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    211
    Joined:
    Jul 16, 2010

    Jul 16, 2010
    211
    37
    43
    Flo Rida
    Can't help in person but I can help here. What problems are you having? I ran into a few things that were different between the 2.2 leak and the OTA so I may be able to help.
     
  15. Outlaw71

    Outlaw71 Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    2,482
    Joined:
    Aug 31, 2010


    Hmmm... somehow I did it without being in PC mode. When I was following the directions it said to put it in PC mode, and that USB Debugging HAD to be in the notification bar. But when I switched it over to PC mode, USB Debugging disappeared from my notification bar. Still, I figured I knew it was on, so I tried it... didn't work. So then I tried it in USB/Mass storage mode... didn't work. Then I tried it in Charge Only mode... didn't work, when I tried it in Windows Media Sync mode.... it worked.
     
  16. gcalig

    gcalig Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Oct 5, 2010

    Oct 5, 2010
    4
    0
    5
    I have the official 2.2 OTA. I have tried every mode. Somehow it either does not find my device or something about permissions.
     
  17. jdk33

    jdk33 Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    211
    Joined:
    Jul 16, 2010

    Jul 16, 2010
    211
    37
    43
    Flo Rida
    Something about permissions is too vague. Can you either copy/paste it or transpose it?


    Also, are you sure you have USB debugging turned on?
     
  18. gcalig

    gcalig Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Oct 5, 2010

    Oct 5, 2010
    4
    0
    5
    Unable to copy and paste.
     
  19. yawdapaah

    yawdapaah Android Expert
    Rank:
    None
    Points:
    113
    Posts:
    900
    Joined:
    Aug 20, 2009

    Aug 20, 2009
    900
    288
    113
    EE
    NJ
    Strange. I've always rooted in PC mode. I did 2.1 and 2.2 that way. USB debugging doesn't show up in PC mode for me but it shows up in USB mode. Next time I need to root, I'll try it in another mode.
     
  20. kg2128

    kg2128 Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    197
    Joined:
    Jul 2, 2010

    Jul 2, 2010
    197
    34
    43
    For some reason the latest motorola driver was causing the problem for me when I tried to do it using the easyroot method. When you put your phone in pc mode and you connect it to your computer a cd drive will show up with motorola drivers, install the driver from that "cd" that is the original driver. Also some people said they rooted in pc mode even without the debugging icon showing up, if you think everything was setup correctly give it a shot.
     
  21. Pasukun

    Pasukun Lurker
    Rank:
    None
    Points:
    5
    Posts:
    8
    Joined:
    Sep 20, 2010

    Sep 20, 2010
    8
    0
    5
    You need to connect to PC in PC mode with USB debugging turned on to root the phone again, but if you have installed MotoConnect driver from 2.1 version, it will not recongnize the Droid X 2.2 in PC mode w/ USB debugging turned on.

    To resolve that, you need to download latest MotoConnect driver.
    You can download it from below.
    http://www.motorola.com/consumers/v/index.jsp?vgnextoid=bda09ec8009a0210VgnVCM1000008806b00aRCRD

    After that, you should be able to connect using PC mode with USB debugging turned on.

    Hope that helps.
     
  22. gcalig

    gcalig Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Oct 5, 2010

    Oct 5, 2010
    4
    0
    5
    I have Motoconnect 4.7.1. I am so lost now. I have no idea if it is my drivers or if I messed up installing everything.

    If anyone is in Pittsburgh, please let me know.
     

Share This Page

Loading...