1. Check out our companion app, Forums for Android! Download from Google Play

Root trying to understand what went wrong with last rooting attempt

Discussion in 'Android Devices' started by TheBird, Jul 5, 2010.

  1. TheBird

    TheBird New Member
    Thread Starter

    Jul 5, 2010
    (apologies in advance for making you scale this wall of text)

    before i begin, i'd like to mention that i have successfully hacked/jailbroken/unlocked/modded several other pieces of hardware before in my life, and i am an experienced linux user so i was easily able to work with the android terminal and i am at least partially familiar with how this phone's OS would work given that it is structured off unix. now, onto my problem:

    the actual rooting process itself worked fine. everything worked perfectly after it was over.

    the problems only started when i (tried to) install busybox

    the guide i used had me make a subdirectory in /system and install busybox from there. it would hang when i tried pushing the file in via adb, so i had to try again a few times for it to actually complete the transfer. the program itself ended up not working (access denied after "busybox --install" even through i was root). i tried another guide with the same result. the third guide i tried had me install it from /data. it worked, and all the new commands were functional.

    being too lazy to tell my terminal emulator to add /data/busybox to my $PATH variable whenever i used it, i simply decided to copy the files (commands) that were installed by busybox into a directory already listed in $PATH

    this is when all hell broke loose

    i was given an "out of space" error halfway through the operation despite having more than enough space left on the phone (it had almost no apps installed)

    the terminal emulator then crashed and when i tried to start it back up, it just printed the default initial command (it appends /data/local/bin to your $PATH) and then some jibberish and wouldn't let me type anything (there was no prompt and no text appeared when i tried typing)

    at this point, i was also completely unable to get adb to recognize the device anymore (it still showed up as an external storage, however)

    i exited terminal emulator again and was about to reboot my phone when i noticed that i was disconnected from my wi-fi network (it had never given me problems before). i tried reconnecting but it stated that it could not get an ip address. i checked the DHCP list on my wireless router and my droid was listed. i couldn't ping it from my computer, however.

    upon rebooting, i continued to have the same problems, so i decided to just reset it to factory defaults (i really didn't have any data on the phone as i just recently bought it). i did, but when re-configuring it (where it asks you for your gmail account), i noticed that i STILL could not connect to my wireless network.

    i tried everything but couldn't get it fixed, until i found this post here that helped me get the original firmware back on:
    Android Central Forums - View Single Post - Motorola Droid 2.0.1 Rooting FAQ's

    after going through the activation procedure, the phone worked just fine

    i don't think the rooting itself had anything to do with this problem, as the phone worked fine for hours after i rooted it. i only experienced problems after the botched busybox install. i also noticed in the sticky that installing busybox had a higher risk rating than rooting the phone. from my understanding busybox is simply a collection of common unix/linux commands that can be installed on systems that lack them. i can't imagine how it would lead to this.

    anyway, i'm going to try rooting the phone again, but before i do, i'd greatly appreciate any input from you guys as to what happened and how i can prevent it from happening again (any help tips you guys would have for a newbie would also be great, especially since i want to start developing for this OS)


  2. drumtrucker

    drumtrucker Well-Known Member

    Nov 11, 2009
    truck driver
    in my big-truck
    I am really noob to ROMing, but did discover Titanium Back Up which provides a single click install or update of BB.
  3. bp328i

    bp328i Well-Known Member

    Mar 28, 2010
    Most of the ROM's out now already have BusyBox installed (I can't think of one that does not), and like ^drumtrucker^ said you can install Titanium Backup and it has a one click BusyBox install.

    Rooting a Droid is nothing like it was back in Dec/Jan, now all you have to do is RSD Lite SPRecovery, put a custom ROM (renamed to update) on your SDCard reboot into recovery and load it up.

Share This Page