1. Are you ready for the Galaxy S20? Here is everything we know so far!

Root TuneIn Radio help

Discussion in 'Android Devices' started by YoungGun, Jul 13, 2013.

  1. YoungGun

    YoungGun Member
    Thread Starter

    So I have used TuneIn radio for ever with never any issues. Now all of the sudden, when I open the app, it just randomly closes (well more like sudden just back out of it. if audio plays, it still plays then the only way to get it to stop is force closing it) few seconds later.

    Heres some error I see in System Tuner log:
    I have reinstalled, cleared data, rebooted, all of that and nothing fixes it.
    The only thing I did was dirty flash from CM10.1 beta4 to the most recent stable build of CM10.1
    Have not had any other apps have this issue. This is an app I use every day, so was seeing if I can get some input with out wiping everything and reflashing just for this one app..
    What would make it "back out" all on its own just a matter of seconds after opening?
     

    Advertisement

  2. Yoinx

    Yoinx Android Expert

    It's trying to find a driver that doesn't exist and crashes.

    I'd uninstall the app via something like titanium backup then reinstall the app tbh.
     
  3. Neph81

    Neph81 Android Expert

    YoungGun likes this.
  4. YoungGun

    YoungGun Member
    Thread Starter

    So I went to CM jira and they tell me its just missing that .so file.
    I have tried reinstalling, removing with uninstaller apps, even installing my downloading the .apk to pc transfer to phone then install. For whatever reason its not installing that libtunein.oem.so file. Odd..

    Can anyone lend me that file if they have it on their phone so I can try manually placing it in the folder?
     
  5. Neph81

    Neph81 Android Expert

    The app itself should be linking to the /data directory where the file actually is. There are really only 3 things you could try that would make sense at this point.

    1) Backup and factory reset and install again, seeing if that fixes it.

    2) Go back down to your previous nandoid and see if your problem still exists (you did backup before upgrading, right?)

    3) chat with the tunein devs.

    If 1 doesn't fix your problem, but 2 does, then either i'd need more logs to look at or the dev will need to put a fix in place.
     
  6. sosaudio1

    sosaudio1 Android Enthusiast

    I did a search on mine to see if that lib had been installed so I could get it to you and it doesn't exist. There is a .dec.so and a .mms.so but not an oem.so.

    So far mine is working. Strange things are afoot.
     
Loading...
Tags:

Share This Page

Loading...