1. Download our Official Android App: Forums for Android!

Turbo very slow and laggy

Discussion in 'Android Devices' started by coulterjosh, May 24, 2016.

  1. coulterjosh

    coulterjosh Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    58
    Posts:
    196
    Joined:
    Jan 13, 2014

    Jan 13, 2014
    196
    14
    58
    Has anyone else been experiencing a very slow and laggy turbo. I am about to chuck this phone and just buy something else. I have cleared the cache, deleted new apps, restarted the phone hundreds of times, downloaded the cm cleaner but nothing has or is working. Since I have had this phone since it came out everything has been great but for about the last month it is running terribly slow. Even right now the stock keyboard is lagging while typing this message. I am running 23.21.49.en.us
     

    Advertisement

  2. Thom

    Thom  
    VIP Member
    Rank:
     #21
    Points:
    1,318
    Posts:
    12,016
    Joined:
    Feb 16, 2011

    Feb 16, 2011
    12,016
    4,978
    1,318
    Male
    Software Developer
    Keene, NH USA
    To make sure we are on the same page ...

    Did you Wipe Cache P{partition and then still had the problem.

    Did you then run in Safe Mode and still had the problem when in Safe Mode?

    ... Thom
     
  3. coulterjosh

    coulterjosh Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    58
    Posts:
    196
    Joined:
    Jan 13, 2014

    Jan 13, 2014
    196
    14
    58
  4. Thom

    Thom  
    VIP Member
    Rank:
     #21
    Points:
    1,318
    Posts:
    12,016
    Joined:
    Feb 16, 2011

    Feb 16, 2011
    12,016
    4,978
    1,318
    Male
    Software Developer
    Keene, NH USA
    If that means you had the same problem after a Wipe Cache Partitions when immediately brought up in Safe Mode then the next step is a Factory Data Reset.

    If you have the same problem after a Factory Data Reset with no apps added, a replacement is needed.

    ... Thom
     

Share This Page

Loading...