Turn off USB Storage Message


I plug my phone into my computer at my office to charge sometimes. All has been fine, until yesterday. I now get a message when I go to use my camera "Turn off USB storage before using camera". I also get this message when I go to view my Gallery - "SD card is being used as a mass storage device". I did not change any settings on my phone and cannot get this to go away. I called my AT&T dealer as well and he was unable to access my phone remotely. When I would click on the link he sent me, it would give the same error. He suggested I back it up, then wipe my phone hoping that would correct the problem. Last night when I tried to backup my phone it said I had no pictures or videos when in fact I have over 400 pics on my phone. Any idea what happened or how I can get this fixed? Please help.

I have a Samsung Galaxy II Skyrocket.


Extreme Android User
When the SD card is connected to the computer so that you can view the files on it from the computer, the SD card isn't available to the phone to read from it or write to it.

You evidently have the SD card as the destination for your camera (and the source for the Gallery) and you have your phone set to use the SD card as storage when it's plugged into the computer. There are two solutions (other than switching things every time you plug or unplug the cable):

1) Change the settings of the camera and Gallery to use internal storage.

2) Change the phone's settings to charge the phone when it's plugged into the computer (or to ask whether to charge it or use it as storage).
@Rukbat - I'm having a similar problem, and would like further explanation if you can on how to actually do the 2 steps you suggested. I can not seem to find a setting to tell my Skyrocket to connect the USB so I can see my files. It charges, but neither the SD nor internal memory will not connect via USB.

My internal memory is basically full, so my camera has defaulted to the SD card. This seems to be the crux of the matter, because I also can not start the Gallery app - it says "Not Enough Memory. Delete some items." But, I can not get it to connect via USB, and I can not pull up the gallery to delete/move the files.