Help Turn on Predictive Text - Razr Maxx - Ice Cream Sandwich

I was recently switched to Android 4.0.4 on my Razr Maxx.

One of the (many) things that has been changed is that the predictive text has either been turned off or gone away. Any way of getting that back?



Sorry I forgot to tell you how to turn it on, open up a text message, then open up settings by tapping the gear icon, select Motorola input settings. Once you get there you will see it about mid screen.

Oh also scroll down to advance settings and make sure its turned on in there also.

Hope that helps have a great day