Two 2.3 Features I Miss in ICS


I just bought the TMo Note on Sunday, so I'm still learning a lot.

Been using the original Galaxy S with 2.3 up until now.

I'm not interested in rooting.

Two features I liked on the S that seem annoying on the ICS Note.

USB Mounting
On my S, I plugged in the USB, and it gave me three options -

  • Kies (Firmware Update)
  • Media Player
  • Mass Storage
I always used Mass Storage. And when I clicked on that, it brought up the android dude and the message "USB COnnected"... With a button to hit to "Connect USB storage". And, when I did that, of course, the phone was mounted as a hard drive on my Windows laptop.

On the Note, it's a lot weirder. To me.

I plug in, it automatically connects as a "Media Device (MTP)"; I can select "Camera (PTP)". But neither mounts as a drive (although in Win Explorer I can see flies). No, if I want to mount, I have to go to Settings->More->USB Utilities->Connect storage to PC. Then I have to plug it in. THEN I can select "Connect USB Storage".

Surely there's a widget out there that will make it more friendly - so I can just plug in and mount. Why would they make something MORE complex over time??

Data network Mode
On the Galaxy S, if you long-pressed the power button, it gave four options: Silent, Data network mode, Flight mode, and Restart.

"Data network mode" turned off the 3G antenna. If you were set for Wi-Fi, you still got wi-fi. Phone and SMS still worked fine.

On the Note, I have to Settings->More->scroll to Mobile networks->Use packet data.

Surely there's a widget out there that will make it more friendly - I can just push it and turn the 4G antenna on and off. Why would they make someting MORE complex over time?

I've Googled the Play store, and can't find anything that seems to work. So I'll take your suggestions.



Well-Known Member
Uninstall the Samsung Desktop Software and Kies. Install JUST the Samsung Note drivers for your OS and you will be fine. Had the same issue a while ago and this is what worked for me.

There is a widget called "3G on/off". Look around the store and you should be able to locate it.

Advances usually means something that was straight forwarded just got tougher. Esp in the case of Android Development.


Android Enthusiast
I've never had to select mode on my device, It just connected and I was able to use it. If kies was not installed I could use it for storage. It took me a while to find just the drivers.

Recently however, I was back at my folk's and both Win7 and XP machines that had never seen a Samsung before both detected it as a storage device.


Thread starter
Thanks. I was logging on to get Elixir advice. I seemed to solve the 4G riddle, but not USB. I will try some of the other suggestions.

Elixir seemed a little inelegant the way I tried it - I have a shortcut button now on my homescreen for "4G"; I hit that, and then the widget button appears, and THEN I can turn it on and off.

As it stands, I can plug it in and use Windows Explorer to "see" files as a media device, but I can't map a drive, nor can I use Documents to Go.