1. Are you ready for the Galaxy S20? Here is everything we know so far!

TWRP doesn't recognize my phone...

Discussion in 'Android Lounge' started by DroidRick, Nov 23, 2019.

  1. DroidRick

    DroidRick Android Enthusiast
    Thread Starter

    I am in the process of trying to replace the current ROM Android 7.1 (has been wiped I believe) with the original Android 5 Lollipop on my Lava Pixel 2.

    Ideally there would be a TWRP .zip file with the original ROM that I could just Install, but all the ROMs I've found for TWRP are upgrade ROMS.

    In the process of messing around with TWRP, deleting cache etc etc. it seems I have deleted the last ROM I had installed.

    My goal today was to install any ROM, then abandon TWRP and use the computer+phone method of installing my original ROM.

    So I tried to install Marshmellow+Volte .zip and this is what
    TWRP said : "this package is for "lava6735p_sp31_lte" devices
    this is a "iris860".

    But my phone is NOT an Iris860 !!!
    It is a Lava Pixel 2 !

    Any guidance on how to fix this problem?
    TWRP does not know what phone it is installed on now and consequently
    balks at installing a .zip file.

    Edit: I just tried to install the Android 7.1 .zip file again (previous installation that disappeared)
    and TWRP is cooperating now and installing it.
    But I can see what the problem is now.
    At the beginning of the installation it says:
    Device: Lava Iris 860 !!

    Still looking for guidance to fix this. Thanks!

     

    Advertisement

    #1 DroidRick, Nov 23, 2019
    Last edited: Nov 23, 2019
  2. Best Answer:
    Post #15 by DroidRick, Nov 23, 2019 (2 points)
  3. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    what rom are you trying to flash? do you have a link? was it made for your phone specifically? did you make a nandroid backup?
     
    #2 ocnbrze, Nov 23, 2019
    Last edited: Nov 23, 2019
    MrJavi likes this.
  4. DroidRick

    DroidRick Android Enthusiast
    Thread Starter

    Thanks for helping out!
    I am making progress.

    I was trying to flash lava pixel v2 marshmallow+volte update.zip.
    Yes it was made for my phone specifically.

    Since posting I figured out part of the problem.
    I don't think it was TWRP that couldn't recognize the phone.
    The ROM files have a script and TWRP was simply showing the script!

    I went back to another .zip file (Android 7.1) and this time it installed the ROM
    despite it saying the phone is an Iris 860.
    When I installed a couple of bug fixes that accompany the ROM file, it got the phone name right!

    Still having other issues though. Will post about them soon.
     
    MrJavi and ocnbrze like this.
  5. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    Once successful, please make sure to do a nandroid backup.
     
    MrJavi likes this.
  6. DroidRick

    DroidRick Android Enthusiast
    Thread Starter

    OK, I'm not quite there yet.

    Here's where I'm at now.
    I can install an Android 7.1 ROM.
    And two bug fix files. And GAPPS.
    Now it doesn't matter whether I Wipe cache, Dalchik etc. or not (before or after the install)

    After I do all that and try to boot it goes right back to TWRP's boot menu!
    In other words a boot loop. :(

    And, I was able to install this very ROM yesterday successfully, so I know it works on my phone!
     
  7. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    Do you have a link for the rom?
     
    MrJavi likes this.
  8. DroidRick

    DroidRick Android Enthusiast
    Thread Starter

    MrJavi and ocnbrze like this.
  9. DroidRick

    DroidRick Android Enthusiast
    Thread Starter

    You talked about making a nandroid backup.

    I just had an idea.

    I am working on a second phone. It is identical to my first phone (that works with my Lollipop ROM).
    Would it be possible to make a nandroid backup of my first phone and then flash it into the second phone?

    If so I'd appreciate hearing how to do this?
     
  10. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    are you wiping cache, dalvik cache, and data and then flashing the rom? or are you wiping after? it needs to be right before you flash the rom

    as long as the phone is the same exact model, i believe it should work.....never done it myself, but i here that is should work provided you have the same exact phone.
     
    MrJavi likes this.
  11. DroidRick

    DroidRick Android Enthusiast
    Thread Starter

    I tried wiping before and also after flashing. It didn't help for either one.

    As I was messing around just now at the main menu I clicked on Restore.
    Lo and behold I had two backups I had made!
    One as recently as March 2019.

    So right now it is in the process of restoring it.

    I hope it will boot up properly after its done!
    I'll keep you posted...
     
  12. DroidRick

    DroidRick Android Enthusiast
    Thread Starter


    Aw fudge!
    So I restored the ROM as I said above.
    It said the restore was a success.

    Then selected re-boot, but it's not going into the phone system.
    It's just looping right back to the TWRP main menu. :(

    Any advice from here?
     
  13. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    did you wipe before doing a nandroid restore? if so what are you wiping?

    edit: and it will depend on what you are wiping after flashing a rom. if you wipe data then that will wipe the rom as well. you can wipe dalvik cache and cache, just not data AFTER flashing a rom.
     
    MrJavi likes this.
  14. DroidRick

    DroidRick Android Enthusiast
    Thread Starter

    Thanks there are many possibilities here.
    I'll talk about a few.
    I just have this feeling that none of them will work, but we'll see.

    Latest:
    I Wiped:
    Dalv, Sys, Cache, Data
    Then Restored:
    Boot, Sys, Cache, Data
    Then tried to re-boot

    No go. Back to TWRP menu.
     
    ocnbrze likes this.
  15. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    hmmmmmm that is odd. and by the way i meant system not data. this is where the roms sits. sorry been drinking beers and bbqing all day. i do not think straight when i have a full belly of beer and food....LOL

    so let's forget about having root. we need a bootable phone. i would suggest you try to flash the current firmware and see if you can get the phone to boot up. this will unroot the phone. you can then re root once you have a working phone again.

    (disclaimer: i have no idea really about your phone. i do not have it. I'm just going about what i know about android and rooting in general.)

    now if you have tried this and nothing........., then it sounds like you might have something damaged with your system partition and you might be sol.
     
    MrJavi likes this.
  16. DroidRick

    DroidRick Android Enthusiast
    Thread Starter

    Thanks again for helping. :)

    I've got good news!
    She's up and running once again.

    Here's what I did.
    I made a fresh backup of Phone 1 (working) and Restored it to Phone 2.
    I first had to get TWRP working on Phone 1 (got the TWRP menu to show up).
    Then Phone 2 accepted this restore file!

    Yippee. Of course then I had to restore the IMEI to Phone 2. But I knew how to do that.
    So all is good once again. :)
     
    ocnbrze likes this.
  17. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    nice!!!!!!!!!!!!!!!!!!!!

    thanx for posting your solution. glad it worked out for you.
     
    MrJavi likes this.
Loading...

Share This Page

Loading...