1. Are you ready for the Galaxy S20? Here is everything we know so far!

Root UD Froyo eXtreme 8.0.0 (FRF22D

Discussion in 'Android Devices' started by inssane, Sep 2, 2010.

?

Poll closed due to new release for this ROM

  1. 5 Star ROM Rating: Elite

    79 vote(s)
    66.4%
  2. 4 Star ROM Rating: Outstanding

    24 vote(s)
    20.2%
  3. 3 Star ROM Rating: Average

    7 vote(s)
    5.9%
  4. 2 Star ROM Rating: Not Ready for Primetime

    3 vote(s)
    2.5%
  5. 1 Star ROM Rating: Not Usable

    6 vote(s)
    5.0%
  1. GirLuvsDroid

    GirLuvsDroid Android Expert

    The easiest way to make an update.zip file for loading an app in /system/app (the "cheater's method") is as follows:
    -On your PC, take one of the theme files compatible with UD8.0, right click on it and open it as an archive using 7zip or WinRar (don't ever unzip this file!)
    -Inside the zip archive, you'll see 2 folders: META-INF and system
    -Don't touch the META-INF folder
    -Open the system folder and delete the framework folder
    -Open the app folder and delete all the apps in there, then drag the stock Phone.apk you're getting into that app folder
    -Close the zip archive and rename it something descriptive.

    Now you have your update.zip!
     

    Advertisement

    kujayhawks77 and publicanimal like this.
  2. publicanimal

    publicanimal Android Enthusiast

    Thanks, that's easy enough! Just need to track down the stock Phone.apk now. If I have to reflash an old ROM to do it I will, but not tonight. :D
     
  3. GirLuvsDroid

    GirLuvsDroid Android Expert

    You don't need to reflash an old ROM -- just pull the Phone.apk from an old ROM zip file and drag it into the update.zip file you're making.
     
  4. bsems1000

    bsems1000 Android Enthusiast

    I just ran a 228 update.... Running stock kernel from UD8. No problems.
     
  5. publicanimal

    publicanimal Android Enthusiast

    Yeah someone else pointed that out and I don't know why I didn't think of it.

    Here's the problem I ran into though... none of the official system updates have the stock Phone.apk file. I checked the 2.1 update and both 2.2 updates and it wasn't there. It must have been the same .apk since the Droid was released. So I still need the stock Phone.apk.

    It just occurred to me that I could probably get it from Bugless Beast. Checking that now.
     
  6. kujayhawks77

    kujayhawks77 Well-Known Member

    Let me know if you have any luck. I tried a couple of roms and experimented and made my phone do some really odd stuff. Good thing for clockwork and backups.
     
  7. publicanimal

    publicanimal Android Enthusiast

    No, it's weird. I've flashed two .zip files derived from UD8 themes using GirlLuvsDroid's method above. One of them was using the Phone.apk from a UD8 Smoked Glass theme and the other was using the Phone.apk from Bugless Beast V0.4.

    After flashing both if I dialed *228 I was able to see the keypad, so that's half the battle. But what was weird was in both cases phone I click the phone icon to make a phone call, I'm still seeing the modified UD8 Phone.apk! Frustrating to say the least. Somehow UD8 is overriding the changes I'm attempting to make.
     
  8. burntorangefan

    burntorangefan Android Enthusiast

    Dude, that's hilarious. Have you seen all the posts from GirlsLuv on this forum? No offense meant, truly, but that made me laugh out loud.
     
  9. kujayhawks77

    kujayhawks77 Well-Known Member

    I tried revolution theme (which I must of did something weird because setcpu freaked out on me and so did superuser) then tried the phone.apk out of LFY (first 1.4 then 1.6) and came up with the same problem as you *228 works but no stock dialer which after you mentioned it is what I really want. Its not a dealbreaker but I'm not fond of the layout on the custom phone app.

    Something else I noticed that was odd is that whenever I try and install the stock phone app in ud settings I get the error we discussed then for some reason my last missed call will reappear in my notifications.
     
  10. publicanimal

    publicanimal Android Enthusiast

    Same here, it's definitely not a dealbreaker. It's a minor annoyance, but I just like the stock dialer and I'm not that fond of the modified dialer.

    Weird! That didn't happen to me, but that could be because I haven't missed any calls lately.
     
  11. markc2

    markc2 Well-Known Member

    Yes I made reference to that in a later post, you missed it I guess.

     
  12. messenger13

    messenger13 Android Expert

    Maybe you just have too much Frozen Yogurt stuck in your DROID. [​IMG] [​IMG]
     
  13. bsems1000

    bsems1000 Android Enthusiast

    Does anyone have the link for the UD8 system scripts that I could run within Terminal Emulator?
     
  14. GirLuvsDroid

    GirLuvsDroid Android Expert

    Wow, that's SO funny! (NOT! :D) Especially since the BBv0.5 betas have run absolutely flawlessly.
     
  15. usawrestling

    usawrestling Newbie

    Hey, just installed, still waiting to pass judgement. Quick question. Chose the mario bootimation off the bat just to see what it is like. When I try to select any other now, it is always set to Mario. Does anybody have a fix?

    Having the same problem with changing fonts too... :(

    Thanks!
     
  16. Gunner

    Gunner Android Enthusiast

    He's not using stock, since that only goes up to 800Mhz. I'd say I'm getting decent battery life running the stock kernel, but nothing phenomenal. With average (moderate) use I'm getting 18 hrs tops. With heavier use...streaming audio, some video recording, photos, web surfing...I'm getting maybe half that.

    (I think he might have posted in the wrong forum, since he lists his device as a Samsung)
     
    YankeeDudeL likes this.
  17. kujayhawks77

    kujayhawks77 Well-Known Member

    Well I was up until about 4 (which made getting up for work murder) and tried every rom I could find and had absolutely no luck. I think you are right in whatever was done in the rom seems to override any changes I make.
     
  18. gobirds895

    gobirds895 Well-Known Member

    This Rom's been great so far. But I've run intoa snag installing apps from the market. They get stuck in installing mode. I had apps installed to external in UD settings, then changed it to automatic after, but neither worked. is there a general market fix for this, or is it a UD Rom issue on my phone? how can I get apps to install? And preferably keep UD EXTREME 8....
     
  19. The_Chief

    The_Chief Accept no imitations!
    VIP Member

    Can't be a UD8 issue, as I have no problem with loading apps from the Market. Have you tried rebooting?
     
  20. djkeller3

    djkeller3 Android Enthusiast

    I really want to run this ROM. I've flashed it twice, ran it both times for a bit once I downloaded and installed my apps. The problem is that if I reboot (the first time was after a Titanium Backup restore) and the second time was after a nandroid backup), it loops over and over again at the UD image. Considering all I did was allow my apps to download and install using the stock kernel, I don't see that there's anything I did to cause the problem. Apparently, my Droid does not like this ROM?

    Edit: Just restored the nandroid I made prior to the boot-loop occurrence, only to experience another - you guessed it - boot-loop. Any ideas? Anyone?
     
  21. esmith818

    esmith818 Android Enthusiast

    If I use the power button to turn the sound off, the sound turns off correctly, but the vibrate icon pops up in notification bar even if vibrate is not enabled.

    Also, if you then "wake" the phone, the rotary dial shows the sound "on" icon even though sound is still off.
     
  22. kujayhawks77

    kujayhawks77 Well-Known Member

    Is this happening with all your apps or certain ones? You might be experiencing a bug that is froyo related that google knows about that. I have read of people experiencing this in several different roms. I have experienced it several times with this rom and LFY 1.6.
     
  23. kujayhawks77

    kujayhawks77 Well-Known Member

    go to Settings > Sound > Vibrate> Only when not in Silent mode

    That is how I fixed the icon in the notification bar, it now will show the silent icon when using the power button to turn sound off.

    As to the sound on icon on the lock screen I'm unsure of as I haven't been able to recreate the error.
     
  24. kujayhawks77

    kujayhawks77 Well-Known Member

    For what its worth my brother finally let me root his droid and I loaded up UD8 and he was getting FCs all over the place (he was convinced I killed his phone) then I installed the P3 Sapphire 1.2LV kernel and he has only had one FC since. You probably thought of this but I thought I'd throw it out there.
     
  25. digdug1

    digdug1 Android Expert

    Did you wipe and format data cache system and boot? Thiis solved that problem for me. Perhaps also try a medium voltage kernal.
     
Loading...

Share This Page

Loading...