1. Check out our companion app, Forums for Android! Download from Google Play

Support Um, my phone just died

Discussion in 'Android Devices' started by True Blue, Apr 15, 2010.

  1. True Blue

    True Blue Member
    Thread Starter
    16

    Apr 14, 2010
    24
    2
    16
    Soo my son was watching Sprint tv and the battery died. Or so I thought. The phone died it seems. I have taken battery out and put it back in, but it is not charging or doing anything. No indicator it's charging, won't turn on, even after leaving it on the charger for a few minutes. Also tried my son's phone charger and no response. Tried different sockets in the house too lol. WTF????
     

    Advertisement

  2. latinmaxima

    latinmaxima Well-Known Member
    113

    Oct 15, 2009
    835
    111
    113
    Customer Service/ Quality Assurance Supervisor
    Richmond ,KY
    Wow Scary! After the battery pull can you boot to recovery? Vol Down Call and End Button? Makes sure it isn't plugged in?
     
  3. True Blue

    True Blue Member
    Thread Starter
    16

    Apr 14, 2010
    24
    2
    16
    Ok so now 20 minutes later it is magically charging. Weird. Explain that one?! lol
     
  4. dreze88

    dreze88 Well-Known Member
    43

    Jan 16, 2010
    231
    33
    43
    Maryland
    I've read in other threads/forums that this happens to this phone for some odd reason. The most certain thing is that who knows. haha At least your back.
     
  5. ramiss

    ramiss Well-Known Member
    53

    Nov 28, 2009
    180
    55
    53
    Batteries that are hot should not be charged until they cool down. Perhaps the Moment has a feature to wait until the proper temperature is met.
     
  6. Flipper

    Flipper Guest
    58

    Nov 4, 2009
    136
    19
    58
    OC, California
    Since placing 2.1 on the phone, that has happened to me twice where I thought my phone was dead.

    I ended up pulling the battery and let it sit for a while (not intentionally but hoping that the phone would come back to life by wishing for it :rolleyes:) and SHAZAM, it turned back on.

    Real weird...
     
  7. ajac09

    53

    Apr 3, 2010
    228
    67
    53
    wonder if the battery was so discharged that it needed a precharge before it charged seen it happen on my old mogul before.
     
  8. True Blue

    True Blue Member
    Thread Starter
    16

    Apr 14, 2010
    24
    2
    16
    I thought that too, but then noticed when my son plugged it back in for me he didn't actually plug it in all the way so it didn't start charging til I fixed it. If this is going to be an issue I'm not sure how I feel about that. Reminds me of my mom's hairdryer that shuts off when it gets hot and I am halfway through my hair.
     
  9. ajac09

    53

    Apr 3, 2010
    228
    67
    53
    sounds like an over heating thing then. Makes me wonder if the stuff around the processor failed and cauused the processor to overheat. Id get a replacement via sprint its under warranty and tell them what happened. Happened once will happen again. Replace it asap before your out of warranty or something big happens.
     

Share This Page

Loading...