1. Are you ready for the Galaxy S20? Here is everything we know so far!


Discussion in 'Android Devices' started by amaranojr, Feb 16, 2011.

  1. amaranojr

    amaranojr Lurker
    Thread Starter

    heres what just happened to me. earlier i went into SETTINGS>ABOUT PHONE>NETWORK and under MOBILE NETWORK TYPE it read HSDPA.

    about an hour ago, my internet completely stopped working. this happened when i first bought the phone because by accident they took me off my unlimited data plan and for the time being they put me on the $25 one that entitles me to 2gb...and it started to work. it worked fine up until about an hour ago.

    i called att and they dont know why my internet connection stopped working but they got it back up and also put me back under my $30 unlimited plan.

    the thing is though that now when i check my phones network settings, it now says UMTS. is this slower than HSDPA? what is the difference between the 2? i dont really notice much of a difference, if anything it is a little faster but it could just be in my head. any help or info on this?


  2. emuneee

    emuneee Android Enthusiast

    UMTS is regular 3G. I has a max download speed of 384Kbps (0.38Mbps). HSPDA is 3.75G and has a download speed (in AT&T's case) of 14.4Mbps. UMTS is waaaay slower.
  3. stancrazy

    stancrazy Well-Known Member

    1. Ensure that the device can make and receive calls before proceeding.
    2. Power off the device by pressing and holding the Power Button and then selecting Power Off
    3. Remove the SIM cover; verify that the SIM is securely and correctly installed in the device.
    4. Replace the battery/battery cover and power the device on.
    5. Verify coverage; check the signal icon at the top of the screen. If less than two bars of signal, go to another location and try again.
    6. Make sure that Airplane mode isn’t turned on by, pressing and holding the Power button. You should see text saying “Airplane Mode is OFF” under Airplane Mode.
    7. Ensure that the Data Connection on the phone is active by going to

Share This Page