1. Download our Official Android App: Forums for Android!

Support Unable to charge non supported battery - see user manual (stock battery!)

Discussion in 'Android Devices' started by FLAWLESSVW, Sep 4, 2011.

  1. FLAWLESSVW

    FLAWLESSVW Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    43
    Posts:
    185
    Joined:
    Jun 18, 2011

    Jun 18, 2011
    185
    30
    43
    Male
    Business Intelligence Analyst, SQL Developer
    Cleveland, OH
    Occasionally when (or shortly after) I plug my phone in, it pops an error message "Unable to charge non supported battery - see user manual" and stops charging.

    This is the STOCK Samsung battery that came with the phone and the stock charger. It doesn't happen all the time, but when it gets in a mood I have to #&%$ with it to get it to charge and it's mildly irritating. I just don't want it to lead to bigger problems later.

    Anyone else?
     

    Advertisement

  2. Topken

    Topken Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    206
    Joined:
    Jun 21, 2011

    Jun 21, 2011
    206
    18
    38
    It happens to me as well if I take the battery out while the phone is on then pop it back on and plug it in. Once I shut the device down and pop the battery out then back in it fixes the error. So if if it happens that way for you then its the way its designed.
     
  3. FLAWLESSVW

    FLAWLESSVW Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    43
    Posts:
    185
    Joined:
    Jun 18, 2011

    Jun 18, 2011
    185
    30
    43
    Male
    Business Intelligence Analyst, SQL Developer
    Cleveland, OH
    Nope. I rarely take my battery out. this is just normal plugging it I'm to charge, then a few minutes later it sounds an alert with the pop up. Has been happening since I got the phone, about 2x/week or so, even before rooting or anything. strange..
     
  4. alekia

    alekia Member
    Rank:
    None
    Points:
    16
    Posts:
    43
    Joined:
    Aug 21, 2011

    Aug 21, 2011
    43
    4
    16
    Minnesota
    My phone is messing up and shutting itself down and force closing far too often, I'm sending it back to Samsung for repair. My phone has never said this message about an unsupported battery though, however. I'd be sending it to Samsung for that alone. Once it starts doing one weird thing, it's bound to do something else down the line.
     
  5. NFCO

    NFCO Lurker
    Rank:
    None
    Points:
    6
    Posts:
    1
    Joined:
    Mar 23, 2012

    Mar 23, 2012
    1
    1
    6
    I've been getting this same exact error. I've had the phone for 3 months, never remove the battery, and just a few weeks ago I plugged it in and it beeped and gave me this message. It's been doing it ever since.

    I called tech support and went through their list of things to try- turn phone off and on, remove and reinsert battery, perform factory reset. None of that worked so they had me send it in. Two weeks later I receive my phone back with the exact same error! Literally the moment I unwrapped it from the packaging and plugged it in I got that battery error. In the paperwork that was sent along with it it says they replaced a component, and updated my software, and that the problem was resolved. Since the problem was obviously not resolved I called them again.

    First level tech support could do nothing. He forwarded me to advanced tech support, who apparently are the guys fixing the phones because he did not like the fact that I was asking him how it's possible that they could not have discovered this problem before sending it, and got a little testy. He told me my only option was to now send JUST the battery (I had previously sent phone, battery, and charger as per tech supports instructions so they could perform thorough diagnostic testing), because the facility where they repair batteries is not the same as the facility where they test phones. Ok...I said that it is unreasonable to expect me to be without my phone for another two weeks. He said that's my only option. When I mentioned ARBITRATION (remember that one), he forwarded me to "executive customer relations." That person was at least polite, and offered to send me a new battery, though he could not expedite shipping and it would take another week. (!!!)

    So now I am awaiting the arrival of my new battery. If that does not work I will be initiating arbitration with the goal of recouping the cost of my phone.

    I will update when that happens.
     
    MyndCTRL likes this.
  6. MyndCTRL

    MyndCTRL Well-Known Member
    Rank:
    None
    Points:
    63
    Posts:
    176
    Joined:
    Mar 23, 2012

    Mar 23, 2012
    176
    39
    63
    Computer Tech
    Rio Grande, NJ
    My phone does the same exact thing. I'm real interested to learn what the problem would be. Keep us updated please!
     
  7. kevincott

    kevincott Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    1,267
    Joined:
    Jul 12, 2011

    Jul 12, 2011
    1,267
    296
    163
    Chicago, IL
    I believe there are 3 different USB volts/watts, are you sure you are using the correct cable?

    Are you running an older computer that may NOT fully support USB 2.0?
     
  8. MyndCTRL

    MyndCTRL Well-Known Member
    Rank:
    None
    Points:
    63
    Posts:
    176
    Joined:
    Mar 23, 2012

    Mar 23, 2012
    176
    39
    63
    Computer Tech
    Rio Grande, NJ
    I didn't know about the volts/watts. I'm positive im using the correct cable. It's the cable that came with the phone. It also happens when I plug my phone into the wall charger as well
     
  9. jackbquick123

    jackbquick123 Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    212
    Joined:
    Oct 1, 2011

    Oct 1, 2011
    212
    19
    38
    I know this is gonna sound crazy but had the same problem when I first got this phone. I could even toss my phone in the car seat next to me and it would reboot. I would get the same message and it is a stock battery. I checked it out and my battery wasn't fitting very tight and I could push it in a little tighter and the alarm message would go away. I took a small bit of paper and folded it and wedge it between the battery and phone and haven't had any more problems and that been 7 months ago. It was just a bad connection. I know it wont help everyone but hope it helps some.
     
  10. MyndCTRL

    MyndCTRL Well-Known Member
    Rank:
    None
    Points:
    63
    Posts:
    176
    Joined:
    Mar 23, 2012

    Mar 23, 2012
    176
    39
    63
    Computer Tech
    Rio Grande, NJ
    @jackbequick

    When I opened the back up my battery has a snug fit. It is just a tiny bit loose but you obviously need room to take the battery out so I'm not sure what it is. I think it does have to deal with volts / Watts in my case so I might just try and buy a charger manufactured for the prevail

    Sent from my SPH-M820 using Tapatalk 2 Beta-2
     
  11. SParker40

    SParker40 Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    101
    Joined:
    Jan 15, 2012

    Jan 15, 2012
    101
    13
    38
    Self Employed
    Bristol Tennessee
    The same thing has happened to me a bunch of times and I have figured it to be that when I use the home charger and Im texting and the phone is sideways it happens. Im thinking that it is because Im putting too much pressure on the jack itself and it might be coming loose needing to be soldered or something. Anyone else having this problem with a home charger?
     
  12. wetbiker7

    wetbiker7 Android Expert
    Rank:
    None
    Points:
    333
    Posts:
    7,475
    Joined:
    Jun 27, 2011

    Jun 27, 2011
    7,475
    3,426
    333
    Male
    USN Vet. / Certified Drug and Alcohol Abuse Counse
    So-Cal
    I found that I get the error when switching from my wall charger to my car charger. In my case, rebooting while attached to the charger fixes the issue every time.:D
     
  13. soloha

    soloha Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    May 9, 2012

    May 9, 2012
    1
    0
    5
    ^^^^ THIS

    Thanks man. Totally fixed it!
     
  14. androidguy1991

    Rank:
    None
    Points:
    33
    Posts:
    72
    Joined:
    May 13, 2012

    May 13, 2012
    72
    59
    33
    Hello I am sorta new to the prevail and I am having the same issue with batter being non supported? I have 3 OEM batteries from samsung and all 3 will not work charge at all? I have rebooted with the charger plugged in and I've also tried other usb cables plugging it into the wall and different PC's. If I download a custom rom will it fix this issue? If not I will have to exchange it out...

    Edit:
    I got it to change. I had to remove the battery then plug it in without the battery, Then put the battery back inside then it started charging. Now usb is not being recognized at all in my PC's..

    Edit:
    I had to reboot my PC and now everything is working..
     
  15. ElGrouch

    ElGrouch Lurker
    Rank:
    None
    Points:
    6
    Posts:
    1
    Joined:
    Jun 12, 2012

    Jun 12, 2012
    1
    1
    6
    Before buying a new battery or otherwise spending money, try cleaning the battery contacts inside the phone by buffing them with a corner of a folded up US dollar bill (the paper is just rough enough). It worked for me, much to my cheap-skate delight.
     
    wetbiker7 likes this.
  16. verchad

    verchad Lurker
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Feb 8, 2012

    Feb 8, 2012
    6
    0
    5
    Boring
    Illinois
    We have 2 prevails and 4 additional batteries (non-samsung). I have periodically had the charging message come up on the non stock ones. Usually I just load it into a non stock wall charger I bought, charge it then put it into the phone when needed.

    Now, we also have a few different car charger cords and I seem to have more of an issue with non stock batteries and using the non stock cords when the batteries are low. Either telling me it can't charge or making the phone go crazy - starting up different apps on it's own.
     
  17. tcamp58

    tcamp58 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Apr 20, 2014

    Apr 20, 2014
    3
    0
    5
    I have a samsung android never had a problem.. Battery was going so ordered new battery, exactly the same but when I go to plug in charger, I get the message unable to charge unsupported battery... Is there something I have to do to the battery before I install it? I just put it in and it will not charge with the charger that came with the phone or any other charger we have... Any sugguestions??? Please?
     

Share This Page

Loading...