1. Are you ready for the Galaxy S20? Here is everything we know so far!

Unable to Install New Apps

Discussion in 'Android Devices' started by memar, Apr 17, 2012.

  1. memar

    memar Newbie
    Thread Starter

    Hey guys, so this is a problem that is driving me crazy!

    Recently flashed new rom - Harmonia 2. I started using Titanium Backup to restore apps, but eventually got to a point where I would get the message "____app not installed".

    I made sure to move apps to the SD card, same problem. When I go to Google Play market and download apps, I get "error, insufficient space on device" message. I even tried downloading app files and copying them to SD card, in which case I get "package file invalid."

    I have plenty of space on internal and external. I've tried doing a factory reset/wipe, cleared cache and dalvik.

    Any suggestions?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. memar

    memar Newbie
    Thread Starter

    Update: Followed these instructions I found on this thread:

    # cd /cache
    # mv download download.old
    # mkdir -p /sdcard/cache/download
    # ln -s /sdcard/cache/download download


    Now market will download app, but when it goes to install, I still get "package file invalid". Tried wiping data.
     
  3. MacFett

    MacFett Android Expert

    Open your file manager navigate to etc/init.d/ and if you see the file 01mvdalvik move it to /mnt/sdcard/ then clear the cache and data for Play and reboot into recovery. Wipe your dalvik and cache in recovery and then reboot.

    You will have much less internal memory after this. The script you moved (if it is there) tells the OS to move the dalvik to the system partition instead of the user partition. This causes problems with Play sometimes.
     
  4. memar

    memar Newbie
    Thread Starter

    That did the trick! Thank you so much!
     
  5. sammyz

    sammyz LG Whiz Kid

    .......I hate that error, happens on every phone....
     

LG Optimus V Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...