1. Download our Official Android App: Forums for Android!

Support Unable to mount SD cards on PC

Discussion in 'Android Devices' started by zopper, Sep 26, 2010.

  1. zopper

    zopper Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    48
    Joined:
    Sep 6, 2010

    Sep 6, 2010
    48
    3
    16
    Hi,
    I just tried to mount the SGS discs on the laptop over the supplied USB cable.
    I set the SGS to act as a Mass Storage device.

    The logs show that the discs came up:
    [ 1429.718638] Initializing USB Mass Storage driver...
    [ 1429.718771] scsi4 : SCSI emulation for USB Mass Storage devices
    [ 1429.718868] usbcore: registered new interface driver usb-storage
    [ 1429.718871] USB Mass Storage support registered.
    [ 1429.722071] usb-storage: device found at 9
    [ 1429.722075] usb-storage: waiting for device to settle before scanning
    [ 1434.721329] usb-storage: device scan complete
    [ 1434.728691] scsi 4:0:0:0: Direct-Access SAMSUNG GT-I9000 Card 0000 PQ: 0 ANSI: 2
    [ 1434.736683] scsi 4:0:0:1: Direct-Access SAMSUNG GT-I9000 0000 PQ: 0 ANSI: 2
    [ 1434.737322] sd 4:0:0:0: Attached scsi generic sg2 type 0
    [ 1434.740150] sd 4:0:0:1: Attached scsi generic sg3 type 0
    [ 1434.747295] sd 4:0:0:0: [sdb] Attached SCSI removable disk
    [ 1434.749182] sd 4:0:0:1: [sdc] Attached SCSI removable disk


    However, the discs are not there:
    # fdisk /dev/sdc

    Unable to open /dev/sdc
    # fdisk /dev/sdb

    Unable to open /dev/sdb


    A bit strange. Are the SGS mass storage devices really these, or some thing else that require drivers?
    Regards.
     

    Advertisement

  2. zopper

    zopper Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    48
    Joined:
    Sep 6, 2010

    Sep 6, 2010
    48
    3
    16
    Found out what one has to do...


    1) On the phone, go to Settings->Applications->USB Settings and select the "Mass Storage" Options.*


    2) Go back to Settings->Applications->Development and select "Stay Awake"


    3) Plug in your USB cable to the phone and computer. The phone will say "USB Connected in the status bar at the top, and a USB symbol will appear.


    4) Drag down the notification bar from the top and hit the "USB Connected: Select to copy files to/from your computer"


    5) You get a new window with "USB Connected: You have connected your phone to your Computer via USB. Select "Mount" if you want to copy files between your computer and your phone's SD card." Select MOUNT.
     
    tinux and _Ash_ like this.
  3. _Ash_

    _Ash_ Newbie
    Rank:
    None
    Points:
    36
    Posts:
    23
    Joined:
    Aug 8, 2010

    Aug 8, 2010
    23
    2
    36
    Been getting annoyed with KIES when I simply want to copy some files to the card. This worked great.
     
  4. tinux

    tinux Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Sep 27, 2010

    Sep 27, 2010
    1
    0
    5
    Wow it took me hours trying to get it to work. you saved my life ,Many thanks Brov God bless you
     

Share This Page

Loading...