1. Are you ready for the Galaxy S20? Here is everything we know so far!

Unable to root - please help

Discussion in 'Android Devices' started by andyknights, Feb 10, 2011.

  1. andyknights

    andyknights Well-Known Member
    Thread Starter

    Hi

    Having discussed this briefly with SURoot - decided we needed to post to get some opinions on the issue I am having.

    I've tried to root using the unrevoked guide that SURoot points to in his Rooting link in his sig and I've also tried using the Rooting for Dummies step by step guide.

    Clearly I am more than a dummy (!) because I'm still not rooted....

    Desire, software build 2.29.405.5
    PVT1
    HBOOT 0.93

    Using Win7 on my laptop (x64).

    Uninstalled HTC Sync from phone and laptop (but kept drivers), installed unrevoked (latest version), installed HBOOT drivers such that in device manager you can see the Andriod Bootloader interface under Android phone, cleared memory a touch (because that was a reason for one of the various errors I had along the way, I found after some digging). Then finally kept getting an error on unrevoked...waiting for device, etc

    I did actually get to a point a couple of times where it said it was a triumph, but then failed later on (problems unlocking NAND flash, I recall - no idea what this means of course...) and it turns out it was not a triumph.

    Tried the whole caboodle again from scratch today, but using the dummies guide, which recommended data reset (which I did, although I was scared to do so !) and all I can get from unrevoked now is either waiting for device, or communications unexpectedly interrupted. But nothing more. Ah, just got a new type of error message from unrevoked (Device "" not supported at this time...)

    I'm at my wits end. I've done a partial reinstall of several applications and data so that I can at least use my phone whilst I try to sort this out (with a lot of help from some very friendly, very lovely people...), I'm just worried with my constant (unintelligent) tinkering to try to solve the issue, I might do some proper damage...

    Please help me, if you can. Sorry if the above is too rambling and not helpful enough, but I'm just trying to convey as much information as possible.

    Many many thanks, in advance, for any help you can provide.

    Andy
     


  2. SUroot

    SUroot Extreme Android User

  3. Rastaman-FB

    Rastaman-FB Extreme Android User

    download unrevoked 3.21 and dont use 3.3 or 3.32, they dont seem to work very well
     
    MarmiteX1 likes this.
  4. andyknights

    andyknights Well-Known Member
    Thread Starter

    Thanks Rasta - will try this, and I'll google for previous unrevoked versions - but just to be clear - the process will remain exactly the same?

    I thought I had to use the latest version because of how new my software was, but not to worry - will do as you say, and revert back.
     
  5. SUroot

    SUroot Extreme Android User

    Alternative versions of unrevoked are linked in the FAQ in my sig also. I think under the PVT4 bit maybe?

    Edit> Yep

    http://downloads.unrevoked.com/recovery/3.21/reflash_package.exe
     
  6. Rastaman-FB

    Rastaman-FB Extreme Android User

    response likes this.
  7. andyknights

    andyknights Well-Known Member
    Thread Starter

    Sorry - as I said - I must be worse than a dummy/noob. All the links keep pointing me to the standard unrevoked page and I can't seem to dload previous versions?

    Any tips?

    EDIT - thanks - you beat me to it.

    Yes - I didn't think my software would be all that new either!!
     
  8. andyknights

    andyknights Well-Known Member
    Thread Starter

    Ok - dloaded and restarted laptop.

    Got USB debuggin on, got Charge only on and 'ask me' turned off, got virus protection on laptop off.

    Had phone already connected and it says "Waiting for device. PLug phone in...", etc.

    If I take lead out it says...

    "Communications with phone unexpectedly interrupted. Try again.".

    In Help, About (in unrevoked) it says version 3.21.

    Ok, plugged it in and out a few times, and then unrevoked kickstarts...

    now it says waiting for bootloader, make sure driver is installed. And my phone is on the HBOOT screen...
    .
     
  9. SUroot

    SUroot Extreme Android User

  10. andyknights

    andyknights Well-Known Member
    Thread Starter

    Yes I have.

    Will do so now.
     
  11. andyknights

    andyknights Well-Known Member
    Thread Starter

    Have already performed this step in other 'attempts' - but now, in device manager it has a wee excalamation mark under the icon for Andriod Bootloader Interface,,,

    So updating drivers for those I have on the laptop, it says that I have the most current drivers...

    Says the device cannot start?
     
  12. SUroot

    SUroot Extreme Android User

    Try uninstalling that device in dev mgr and start again with the drivers from scratch.
     
  13. Rastaman-FB

    Rastaman-FB Extreme Android User

    when you click update drivers click manual and select the hboot drivers you downloaded from unrevoked website
     
    andyknights likes this.
  14. andyknights

    andyknights Well-Known Member
    Thread Starter

    Updated drivers, no little exclamation mark, but I'm getting communications with phone unexpectedly interrupted....
     
  15. barefootpilot

    barefootpilot Well-Known Member

    Would it be worth trying the linux version, as nothing else seems to be working?
     
  16. SUroot

    SUroot Extreme Android User

    What about your little unplugging and replugging trick. Is that working now?

    I wonder if there is a fault with the USB device itself? Are you using the same USB port on the PC? Could you try another?
     
  17. PureLoneWolf

    PureLoneWolf Well-Known Member

    I had a very similar problem when I first tried to root. For me, the issue was that MediaMonkey was trying to use the device, even though it was not in HDD mode.

    I would double check that there aren't any apps open that could be trying to use it...media players are a good example.

    You never know, it might help :)
     
  18. andyknights

    andyknights Well-Known Member
    Thread Starter

    I have tried the unplugging trick - to no avail.

    Thanks, PureLoneWolf, I keep restarting the laptop - and I don't think I've got any such apps open...

    On looking in device manager now, it doesn't say bootloader, it says Android USB Devices - My HTC - is this wrong??

    Should I update the drivers and put the others in? Sometimes it says this, other times it says the bootloader interface? This is when I an using a diff USB port on the laptop.

    Is this the problem?
     
  19. SUroot

    SUroot Extreme Android User

    I think the device in device manager will differ depending in what state your phone is connected.
     
  20. andyknights

    andyknights Well-Known Member
    Thread Starter

    Ok - but will the state it's in depend on how unrevoked will work?

    I'm sorry, I didn't understand how the post about doing it using Linux will work? I don't have Linux..
     
  21. SUroot

    SUroot Extreme Android User

    Well what I mean is when the device is connected in hboot, you will see hboot in the dev manager, otherwise you should see what you reported above.

    You can downlaod linux and run it in a virtual machine. Long winded though.
     
    andyknights likes this.
  22. andyknights

    andyknights Well-Known Member
    Thread Starter

    Ran unrevoked again using the different USB port and it started! Then stopped again at the ensure the drivers are installed - but now it's started again and we're on 'waiting for reboot'....

    OMG it says rebooting into recovery....

    OMGOMG it says done!!

    Now I'm scared...I think it's worked....
     
  23. andyknights

    andyknights Well-Known Member
    Thread Starter

    I have a new app, it's called superuser permissions.....

    I don't know how we managed to get it all done, and what of all the steps contributed to getting it working, but I thank you all so much!

    It's so great to have such a helpful and generous community of fellow users...

    now I have no idea what to do next!!

    apart from at least trying to get my desire back to how it looked before i factory reset it!!
     
  24. Rastaman-FB

    Rastaman-FB Extreme Android User

    it will be using a different port so it reinstalls the drivers coupled with using unrevoked 3.21

    1st thing to do is to boot to recovery (voldown + power, select recovery with voldown and press power)
    select backup restore and make a backup of the rom in its current state
    if it fails to boot after the 1st backup just go back into recovery and restore the backup you just made

    now you can look about for various things like adfree for advert blocking and titanium backup to back up apps you like (non sense) and the data that goes with them.

    if you feel like breaking free you can try flashing roms
     
    andyknights likes this.
  25. andyknights

    andyknights Well-Known Member
    Thread Starter

    Thanks Rasta

    I've done this, as you said - and the screen just goes black.

    Oh ok, I've got it, now I can use the trackpad, not the power key, to select. Doh.

    Just putting this in case other people are using this thread for help later on.

    this is just a backup of the ROM, yes?
     
    SUroot likes this.

HTC Desire Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...
Similar Threads - Unable root please
  1. StarFlutter
    Replies:
    4
    Views:
    327
  2. Rajkumar Wadi
    Replies:
    4
    Views:
    191
  3. X50_user
    Replies:
    8
    Views:
    403
  4. AKA001
    Replies:
    0
    Views:
    728
  5. Kevil
    Replies:
    0
    Views:
    495
  6. Landon Robinson
    Replies:
    1
    Views:
    538
  7. Westindieman
    Replies:
    3
    Views:
    547
  8. Hadiqa Javaid
    Replies:
    17
    Views:
    3,193
  9. sylarr
    Replies:
    1
    Views:
    437
  10. syed ramish
    Replies:
    3
    Views:
    589

Share This Page

Loading...