1. Are you ready for the Galaxy S20? Here is everything we know so far!

Unable to subscribe to text alerts

Discussion in 'Android Devices' started by NCzerniak83, Jun 23, 2017.

  1. NCzerniak83

    NCzerniak83 Newbie
    Thread Starter

    I was setting up text alerts for my pharmacy so when my prescriptions are ready it texts me. But when I was sending the first text, a warning popped up saying something about text costs may apply or something. It popped up while I was typing so I accidentally pressed something and now when I try to send a text to (for example Facebook at 36626) or an alert for any of my services, it said "failed to send. Retry"

    How do I go back to the sms settings with coins on the screen and it asking me to select something regarding the fact that these text costs may apply?

    Thanks
     



    1. Download the Forums for Android™ app!


      Download

       
  2. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    You could go to menu>settings>apps>[your messaging app]>permissions and make sure it has the correct permissions turned on. You could also try try menu>settings>apps and then tapping on the menu (three dots) and select reset app preferences. Not sure, but that might reset ALL your app preferences so you'd have to re-accept permissions again the next time you open each app.
     
    NCzerniak83 likes this.
  3. Clementine_3

    Clementine_3 Extreme Android User
    VIP Member

    And...short-code texts don't always work. I have some that work on Verizon (using Textra) and some that don't, some work on Google Voice and some don't, some work on both and some work on neither.

    Do clear the permissions (and maybe cache) and see what happens.
     
    NCzerniak83 likes this.
  4. NCzerniak83

    NCzerniak83 Newbie
    Thread Starter

    I reset all app preferences and it still says message not sent.
     
  5. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

  6. NCzerniak83

    NCzerniak83 Newbie
    Thread Starter

    This is the setting i accidentally hit 'Never Allow' in my stock Messaging app.  How do I switched it to Always Allow?
     

    Attached Files:

  7. NCzerniak83

    NCzerniak83 Newbie
    Thread Starter

    I tried System  Applications by the way, and can't find the option to unselect 'Never Allow' and to select 'Always Allow' instead. 😞
     
  8. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    Try this. Go to menu>settings>apps>[your messaging app]>defaults and select clear defaults.
     
  9. NCzerniak83

    NCzerniak83 Newbie
    Thread Starter

    No luck. 😧
     
  10. NCzerniak83

    NCzerniak83 Newbie
    Thread Starter

    I figured it out!  Thanks to a Google search, someone else had the same issue and posted the fix.  When you go to System Settings, then Applications, you select 'Show System Apps' and select 'Message Service' and then in 'Send Premium Text Message' are the options to Always Allow etc.  Thanks for your time, everyone!
     

    Attached Files:

    Clementine_3 likes this.

Samsung Galaxy Express Forum

The Samsung Galaxy Express release date was November 2012. Features and Specs include a 4.5" inch screen, 5MP camera, 1GB RAM, Snapdragon S4 Plus processor, and 2000mAh battery.

November 2012
Release Date
0
Reviews
Loading...

Share This Page

Loading...