1. Are you ready for the Galaxy S20? Here is everything we know so far!

Unable to type uppercase characters in web forms

Discussion in 'Android Devices' started by cjablonski, Jan 6, 2013.

  1. cjablonski

    cjablonski Newbie
    Thread Starter

    Hey everyone, I've noticed this pretty much from day one with this phone but it's only now starting to bug me more and more. On the web (tried on both Chrome and the standard), when entering text into any form, be it a search field or password field, only lowercase characters seem to work with the physical keyboard. The shift key essentially does nothing. Symbols are broken too.

    Makes it very difficult to enter passwords. The workarounds are to use the onscreen keyboard or to copy and paste text from elsewhere. It's still a pain.

    Has anyone else noticed this? Does anyone have a solution?

    1. Download the Forums for Android™ app!


  2. RazoE

    RazoE Well-Known Member

    Are you using the standard keyboard, or something along the lines of Swiftkey? I love swiftkey as a virtual keyboard but it ruins the physical keyboard experience by not auto unchecking alt or shift keys which leads to lots of frustration.

    Another thing, are you rooted or stock? Do you have the KIES update installed? Also, have you tried double tapping the shift key? Which key do you use the right one or the left one?

    If all else fails, factory reset and see if it still does it, if so it may be a hardware problem.
    spoxy likes this.
  3. cjablonski

    cjablonski Newbie
    Thread Starter

    This is the physical keyboard, I am rooted, the KIES update has been installed.

    It ONLY happens in web forms. This includes password/username boxes, search boxes, message inputs like this one. If I go up to the address bar, for example, the physical keyboard works fine.

    Yes, it is a bizarre problem. I will try factory reset.

    EDIT: Wow, factory reset seems to be working!

    But only in the stock browser. This is STILL broken in Chrome. Crazy.
  4. GutBomb

    GutBomb Lurker

    It's not really broken, it's just different. Hold down the shift key and then hit a letter key, just like on a computer. It works. Same with alt. I don't know why chrome works this way when all other apps work the standard way, but that's how you can get upper case letters in chrome.
    cjablonski likes this.
  5. cjablonski

    cjablonski Newbie
    Thread Starter

    That is messed up.

Samsung Galaxy S Relay 4G Forum

The Samsung Galaxy S Relay 4G release date was September 2012. Features and Specs include a 4.0" inch screen, 5MP camera, 1GB RAM, Snapdragon S4 Plus processor, and 1800mAh battery.

September 2012
Release Date

Share This Page