1. Check out our companion app, Forums for Android! Download from Google Play

Root UNABLE to unlock HTC Evo 4G running 2.3.5 software?

Discussion in 'Android Devices' started by EternalSuper1, Apr 7, 2012.

  1. EternalSuper1

    EternalSuper1 Member
    Thread Starter
    26

    Apr 7, 2012
    7
    1
    26
    Hi. I'm unable to unlock my HTC Evo 4G running 2.3.5 with H-boot 2.18 following the HTC dev method. I have all the fastboot files in one folder; that is fastboot.exe, adb.exe, AdbWinApi.dll, Unlock_code.bin (I spelled them exactly the way I saved them in the folder). Whenever I run "fastboot flash unlocktoken Unlock_code.bin" at the cmd prompt, the screen freezes at "sending 'unlocktoken' (0 KB)..." and when I unplug the phone from the computer, I get the error message at the cmd prompt, "FAILED (status read failed (Too many links))." Everything else works until that point. Please help, I want to get my phone unlocked so as to root it however I have no clue why it would give this message.

    Thanks in advance

    EternalS1
     

    Advertisement

  2. argedion

    argedion The TechnoFrog
    853

    Jun 20, 2011
    6,360
    6,288
    853
    The Infernal Swamp
    We have an Evo 4G Section of the Forum that has an All things Root Sub Forum. The people in there are very good at helping with this kind of thing. I personally have not used that Root Method so I Unfortunately will be of little help I can ask if you have tried Rebooting the Computer and Starting it again? And I'll get a mod to move this over to the correct forum for you.
     
    ocnbrze and Rxpert83 like this.
  3. Rush

    Rush {<>}~{<>}
    1,043

    Jan 31, 2011
    18,743
    3,162
    1,043
    Male
    Entrepreneur / Business Owner - Freelance Writer
    Loganville, GA
    Welcome to Android Forums.

    Just wanted to let you know I moved your thread to hopefully get it some better responses. :)
     
  4. bigbear6708

    bigbear6708 Well-Known Member
    68

    Feb 11, 2012
    470
    224
    68
    just did this method with my wifes phone tonight. let me see if I can remember the process, as I dont have the email with the later on directions..

    are you unzipping the sdk file and taking the .exe out of there? or did you download them from the root guide? (only do one or the other). If you are taking them from the sdk file, try downloading again, then unzipping again. the first time I did this with my phone (2 months ago) I had to unzip a second time to do it right. luckily today, I still had the files handy for my wifes.

    are you running the cmd prompt at the android folder and not just a standard command prompt?

    those are 2 things to look at off the top of my head.
     
    ocnbrze likes this.
  5. Rxpert83

    Rxpert83 Dr. Feelgood
    1,853

    Aug 30, 2011
    17,931
    13,136
    1,853
    Male
    Graduate Student
    MN
    You can always do the TACORoot method if HTC dev fails. However, seeing how it was HTC that released HTC dev I'm thinking they go their own method down :p


    Taco ROOT just looks fun
     
  6. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    1,823

    May 13, 2010
    23,596
    14,436
    1,823
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    how long are you waiting? if it is a few minutes then i would wait longer. give it like 10-15 min before you decide to do anything.
     
  7. EternalSuper1

    EternalSuper1 Member
    Thread Starter
    26

    Apr 7, 2012
    7
    1
    26
    Thanks for the replies, guys. Yeah, I've deleted and unzipped the SDK file a couple of times plus used the uninstaller to unzip it. The issue I'm having is when I attempt to flash the Unlock_code.bin the HTCDEV site generates. Everything else before that works and that includes "fastboot oem get_identifier_token" to get my token. I've checked and there are no extra spaces when I'm pasting into the CMD prompt. Now, I run CMD from the Start Menu Search box and yes, I run the "fastboot flash unlocktoken Unlock_code.bin" from the android folder c:\Android>. Any other suggestions? I've waited for 20 min and it's still hung on

    C:\Android>fastboot flash unlocktoken Unlock_code.bin
    sending 'unlocktoken' (0 KB)...
     
  8. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    1,823

    May 13, 2010
    23,596
    14,436
    1,823
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    have you tried and redownload the unlock.bin file? try that and see if that helps.
     
  9. EternalSuper1

    EternalSuper1 Member
    Thread Starter
    26

    Apr 7, 2012
    7
    1
    26
    Thanks once again guys. I went through the whole process again on another computer and it worked. Seems like there was some driver conflict on my old gateway laptop. Go figure, maybe it's a sign that I need to get a new laptop. Well, my phone's all unlocked now which reared another issue. I'm unable to log on to my previous account associated to my Android phone and I'm unable to access apps in my SD card. It's like it was reset to the factory default. Any suggestions? Will I be able to access my SD card info and log on to my account once I completely root my phone?
     
  10. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    1,823

    May 13, 2010
    23,596
    14,436
    1,823
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    what is exactly is happening when you try to sync with your google account?

    and when you move you apps to the sd card, they are not fully moved. only part of the app is moved to the card. the other part of the app still stays on the phone. and unfortunately when you unlock the bootloader your phone gets wiped. so you will only part of the app that is on your sd card and the rest is now gone as they were wiped during the unlocking process. basically you will have start all over with your apps.
     
  11. EternalSuper1

    EternalSuper1 Member
    Thread Starter
    26

    Apr 7, 2012
    7
    1
    26
    Hi. Hope everyone had a good weekend. Thankfully I figured out the problem behind accessing my gmail account on my device. I turned off 2-step verification for my google account and that did the trick. The log on, setup, and syncing on the android device worked. 1 down, 1 more to go.

    I need to figure out why my phone does not read my SD Card. The funny thing is when I plug it to the laptop via USB, it reads it just fine. It's when I attempt to access it through the phone. I formatted the SD Card, I've used the "fastboot oem enableqxdm 0" command and still nothing. The only I haven't attempted yet is using another SD card. Is there a software fix for this? I'm not sure what other options I have.

    Thanks as always,

    EternalS1
     
  12. Granite1

    Granite1 Zercron Encrusted Tweezer
    833

    Dec 27, 2010
    7,159
    7,180
    833
    Male
    Highway Construction Inspection
    Pittsburgh, PA
    If your card has been formatted and its still having issues, I would take it out and try to remount it physically. If it still acts screwey, I would try another card.
     
    ocnbrze likes this.
  13. EternalSuper1

    EternalSuper1 Member
    Thread Starter
    26

    Apr 7, 2012
    7
    1
    26
    Thanks G1 :). Any suggestions on good SD Cards? Are the SanDisk or Kingston any good in your opinion? I have a 8Gigger so I'm looking to move up to 16.

    Thanks.
     
  14. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    1,823

    May 13, 2010
    23,596
    14,436
    1,823
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    Granite1 and EternalSuper1 like this.
  15. EternalSuper1

    EternalSuper1 Member
    Thread Starter
    26

    Apr 7, 2012
    7
    1
    26
    Thanks, I appreciate the help :)
     
    ocnbrze likes this.
Tags:

Share This Page

Loading...