1. Are you ready for the Galaxy S20? Here is everything we know so far!

Unable to upgrade firmware via Kies

Discussion in 'Android Devices' started by jmnathan, Feb 8, 2011.

  1. jmnathan

    jmnathan Newbie
    Thread Starter

    I have been prompted to update the firmware on my Samsung Galaxy S from CSC:JP5 to CSC:JP6. I have tried numerous times, but on each attempt the upgrade is disconnected with the following error message: "Firmware upgrade stopped because GT-I9000 has been disconnected. Please check the connection and try again." I am not touching the handset to disconnect it; in fact, the handset still seems to think it is connected.

    Has anyone else had this issue? I have tried it on two different PCs (XP and Vista) and have had the same experience on both. It

    1. Download the Forums for Android™ app!


  2. deanos24

    deanos24 Lurker

    I have the exact same problem. I've tried restarting my laptop, uninstalling kies, uninstalling drivers and so forth, but nothing has worked as of yet. If you find a solution, please PM me
  3. I also faced the same problem you can check my previous post also. If you got the correct way to update then please let me know. Thanks in advance.
  4. Space Indaver

    Space Indaver Lurker

    Good to know it's not just me, and you're all fairly recent posters, so I'm assuming it's something to do with either the latest Kies or the latest firmware; some bug or other making it crash just before the process starts.

    This is the only place on the net I've seen this problem being discussed so far, I've spent all day overcoming each hurdle to try and get this update done, bah. Might try to find a rom rather than getting Samsung's version.

    Mine's rooted by the way, but I've literally done nothing more than root it and install OCLF.
  5. jmnathan

    jmnathan Newbie
    Thread Starter

    I'm considering rolling back my version of Kies, having only just udated it, but seeing as the firmware upgrade was only offered once Kies had been upgraded, I'm assuming any roll back would just mean I don't have it offered once again. I'd be very interested to hear from anyone who has been able to successfully upgrade.

    My phone is not rooted and I am unable to as it is a work phone.
  6. Space Indaver

    Space Indaver Lurker

    Just had a look and it was only yesterday that the latest version of Kies came out. I only just got a USB cable for my phone after losing the original one, really bad timing I suppose.

    Should we be directing complaints in any specific direction at Samsung to get them to fix it quickly d'you think?
  7. NGK

    NGK Lurker

    I am in United Kindom and have just got a Samsung S with a T-Mobile phone contract.
    As per the instruction book downloaded the Kies software from the Samsung website to my Microsoft Vista PC. When connecting the telephone it said new firmware was available and so I pushed the update button (see zip file).
    It showed an increasing percentage complete and then at the end said "FirmwareUpdate has stopped working" on the PC. RePlugged phone in again to PC and pushed update and with 5 seconds message appeared on PC screen (see JPG file).

    So uninstalled Kies, switched off Norton virus checker, reloaded Kies and exactly same sequence of error messages as before.

    Help would be appreciated.

    Attached Files:

  8. cathwood

    cathwood Lurker

    I had a similar problem.

    Actually the whole think froze at 40% and I had to disconnect the phone. Re-booted and everything was OK. Then I re-connected to kies, which said "Failed to upgrade software" and asked if I wanted to run firmware recovery. I went through this process but was unable to recover the firmware as from the recovery screen on my phone I could not persuade kies to connect to the phone.

    Did a factory re-set and re-installed kies. Now kies does not come up with the error message above but it does say "This version of the device cannot be upgraded". The settings on my phone say I have version 2.2. I am not clear wether the device cannot be upgraded because something has broken or for some other reason.
  9. jmnathan

    jmnathan Newbie
    Thread Starter

    So I tried again and left it running, when I came back it appeared to have updated (no error message), but I don't know what I'm looking for on the phone!
  10. BobBarrie

    BobBarrie Lurker

    I have same problem. The update only came to South Africa today. So now what must I wait a couple of days and try again?
  11. I had similar problems and finally got it working. What seemed to work for me was a 2-step approach:

    1. Make sure Kies is most-recent version installed. Follow their guide to uninstalling/reinstalling as apparently it can be flakey.

    2. Disable ANY custom launcher app you have installed. I installed "home Switcher" and use that to switch back to twLauncher

    After doing that (especially #2) I was able to install the update. Kies is the worst piece of garbage software I have ever run into in my opinion... and am shocked that a major mnfctr like Samsung would have such a piece of software integral to their cell phones. I'm buying HTC next time simply because of Kies!
  12. cooljools

    cooljools Lurker

    I'm having the same problem, just recently. Samsung tech support no use. I can just about connect to Kies but it won't let me do anything useful.
  13. NGK

    NGK Lurker

    One thing I have noticed is that it will update the firmware in the phone, If my laptop uses wifi as the internet connetion, but it does not work if I am using the t-mobile dongle to connect to the internet.
  14. XxThanexX

    XxThanexX Lurker

    So all you have to do is remove your sim card and the update will preform. Well, it worked for me,
  15. FlipModeOC

    FlipModeOC Newbie

    It seems that updating your firmware with the official Samsung firmware is as risky as flashing a new ROM ;)

    Did the SIM card workaround work for anyone else?
  16. droid416

    droid416 Member

    What's new in this firmware upgrade?
  17. jagan999

    jagan999 Lurker

    I have used this forum extensively and benefited immensely from the wisdom of several Android users. I am a BIG fan of Android and registered today to share my two cents of experiences to benefit the larger Android community.
  18. jagan999

    jagan999 Lurker

    I had a very frustrating two days trying to use Kies to update my Samsung Galaxy S in India from FROYO to GINGERBREAD. This update is now available for India users but for some reason, Kies kept on crashing with a message "Firmware update has stopped working"...I researched the web at length and then tried the following...Good news is that the firmware got updated after these steps in less than 30 mins...And now I enjoy the benefits of Gingerbread with no issues...
    Hope this helps you folks...
    Good luck!

    1. Step 1 - Thanks to Ram for this post Ram's Pensieve
    2. Ensure only the default TouchWiz launcher is INSTALLED on your mobile. UNINSTALL all other launchers. I am a big fan of GO Launcher Ex but found that UNINSTALLING all other launchers did the trick. First, I only enabled the default TWLauncher but kept GO Launcher Ex installed.
    3. Connect your Galaxy S first in Mass Storage mode after launching Kies
    4. Then disconnect your Samsung Galaxy S
    5. Reconnect your Galaxy S then in Kies mode
    6. Let Kies do the trick and upgrade your firmware from Froyo to GingerBread
  19. rickyrayjay

    rickyrayjay Lurker

    I am in US. Had same problem. Had to install updated samsung drivers from my cell carriers website. There was a link in the "troubleshooting" area to get them downloaded on computer. Then I had to reboot phone while I had it connected to computer via USB in order for computer to recognise that the phone wanted to now use those new drivers and it worked flawlessly after that. I fought with it for a month until I figured it out but I'm glad I was persistent. Newest gingerbread update is great and does indeed fix many performance glitches. I've only been using it for a week so far but its much smoother with less force closing and no reloading stock home launcher randomly thus far. Good luck, its worth it tho.
  20. swap.blue

    swap.blue Newbie

    jst turn off the wifi when you connect via kies
  21. renuka1982

    renuka1982 Lurker


    I followed the steps that Jagan999 suggest. But still its not working. I am in India.
    Kies download upgrade components but unable to install it on phone. It just keep giving message problem occured while upgrading.
    Please suggest any solution.

Samsung Galaxy S Forum

Features and specs are not yet known.

Release Date
Similar Threads - Unable upgrade firmware
  1. jhall68w
  2. Ajrox22
  3. MarcoGalaxyA10
  4. FaustBottomText
  5. xarzu
  6. GlitchedFolx
  7. aj4yourhelp
  8. Ian Preddy
  9. Magixsword
  10. kumaranil13k

Share This Page