1. Are you ready for the Galaxy S20? Here is everything we know so far!

Universal Eris Root for Dummies!

Discussion in 'Android Devices' started by erisuser1, Jul 20, 2010.

  1. scary alien

    scary alien not really so scary
    Moderator

    kamots, eu1, for what its worth:

    Here's a post from bftb0 over at XDA discussing Amon_RA and trackball issues: xda-developers - View Single Post - [FYI]Brick your phone with out Bricking your phone hmm !

    Here's the text: "Amon_RA runs adbd by default, so you can push/pull files to the SD card no matter what OS (even none) is loaded, and the trackball isn't needed for that.

    You can also run nandroid-mobile.sh with Amon_RA booted from the command line (from an adb shell) to either backup or restore prior backups. This does not require the use of the trackball; nor does it have any dependency on "USB drivers".

    I think that many other entries in the Amon_RA recovery are implemented as scripts, so probably many things you think you can't do (because of a broken trackball) are indeed possible using an adb shell.

    It is possible that your trackball assembly got so bolluxed up that it was also responsible for the loss of USB connectivity; in that case none of this matters.

    Bottom line, though - even though it won't fix a trackball problem, is that if you have either the 1.49.2000 S-OFF bootloader running on the phone, or Amon_RA, you can "unbrick" from the state you described.

    If USB is gone because of a mechanical/electrical issue, things are a bit more grim than that.

    bftb0"

    I don't know if the above is applicable and/or will take care of this or be helpful with the issues mentioned.

    Also, there's a reference in a g1/Dream version of Amon_RA's reciovery to using the CALL-ANSWER key in Amon_RA to select in case you can't do a trackball press (but I don't know if this is supported in the Eris version). This is discussed in this thread: NEW ! Amon RA Recovery v1.6.2 for the g1/dream(12/13) [Archive] - Android Forums

    I've also read that plugging-in your USB cable and gently jiggling it might make you be able to select / move from item-to-item in Amon_RA's recovery menu (i.e., because of the proximity of the USB port to the trackball).

    Good luck!
     


  2. erisuser1

    erisuser1 Android Expert
    Thread Starter


    The result this produces is identical to the manual method. It is provided for people who have trouble with PC drivers, command lines, etc. The only thing which is unique about it currently is the fact that you can achieve root without using a PC and the Android SDK tools & driver

    It takes longer to read the instructions than it takes to perform them. That said, it does take a while to configure a new ROM from scratch, so I would wait if I were you.

    Some ROMs will auto-configure A2SD/APPS2SD if they detect a partitioned SD card. If both of your cards are unpartitioned, it should not matter. It is possible that it matters only if you load a ROM that automatically configures A2SD.

    eu1
     
  3. erisuser1

    erisuser1 Android Expert
    Thread Starter

    scary alien,

    Thanks for pitching in and helping.

    I literally need to run out the door right now, and will be AFK until at least next Monday - fun stuff to do IRL. If any one else wants to pitch in and help out with questions, I would be grateful.

    That quote from bftb0 (over on XDA) seems correct, but it applies to Nandroid backups - I'm not sure if there are command line ways to initiate ROM installs from the command line.

    I'll have to review the Android sources for recovery.c to see if /sbin/recovery can be invoked from the (Amon_RA) command line to install a ROM from the SD - if it is possible, it might need to be renamed "update.zip" first.

    But you are correct that there is a non-trackball possibility... with some amount of work. (And, it also involves the PC, so... ugh).

    eu1
     
  4. erisuser1

    erisuser1 Android Expert
    Thread Starter

    If you downloaded it using the web browser, it is in the /sdcard/downloads folder... and that is why Amon_RA does not find it, because it only looks in the root folder ("/sdcard") of the SD card.

    You can move it to the root folder the same method that was used to move the "gscript.zip" file to the root folder. (Just don't "unzip" it, only move it!)

    You can safely reboot your phone and use the normal OS anytime you want after "part2" is done to do things like this. Just go back to the Amon_RA recovery the same way (power down phone, power back up with Vol-Up & End) once you have the ROM file in place.

    eu1


    OK, now I need to bail (15:54 Zulu 2010.07.21) - see you folks next week.
     
    Almac likes this.
  5. kamots

    kamots Well-Known Member

    thank you I will have to ttyry the trackball jiggle thing and see if it helps. I dont think ma trackball is completely broken, because it wourk everywhere else and I can still mout sd card to comp through usb so thankfully things arnt that bad for me yet lol i do appreciate the help thou and will try this.
     
  6. Almac

    Almac Lurker

    erisuser1 thanks I got it rooted with my new Rom and am up and running!!
     
  7. kamots

    kamots Well-Known Member

    ok question is this since I was able to get my phone to look like image 31, am I rooted now? and just not able to do a nand back u, wipe , or flash a rom because of my track ball? cause i was going to go home and try the computer method after work and see if that works. but if the phone is already rooted I wont waste my time.
     
  8. scary alien

    scary alien not really so scary
    Moderator

    You mean the image that says "congratulations, you have root!"? :D

    No, not rooted yet, if you see image #31 then you just installed a custom recovery partition installed--you just can't flash a custom ROM because of your trackball issues.

    You don't actually get root until you install a custom, rooted ROM (i.e., that has the su program and/or Superuser.apk installed).

    To test if/when you phone has root capability, download "Android Terminal Emulator" (free from the Market) and type "su". When/if you do indeed see a "#" prompt, then you have root! :)
     
    kamots likes this.
  9. kamots

    kamots Well-Known Member

    ok soooo I downloaded this but when I type su it says permission denied im not meant to root this phone im thinkin
    lol
     
  10. bigbohizzle

    bigbohizzle Newbie

    If you do this can you go back to stock? Is there an easy way to do this?
     
  11. scary alien

    scary alien not really so scary
    Moderator

    kamots, I'll admit that I'm a little late to this particular new root method party, lol (I rooted the "old" / original way). I have read through this thread and the companion threads here and over on XDA. But I'm not in position to download the gscript.zip file to examine the scripts in detail at the moment.

    I think I remember reading that even wag3slav3's and jcase's methods sometimes took more than one try to get it to "stick". So perhaps someone who has actually done this and needed to run it more than once can verify or share their experience?

    You can always do the "su" thing to see when/if you have root.

    edit: you'll only see the "#" (root) prompt after flashing a custom rooted ROM.
     
    kamots likes this.
  12. Hypo Luxa

    Hypo Luxa Android Enthusiast

    Ummmm.. I can't power up into recovery! I have tried a dozen times with Vol+ and End to no avail. just does a normal boot
     
  13. Papadroid

    Papadroid Android Expert

    I know it's a little confusing but you actually don't have root yet. This process only gives you the ability to obtain root through one of two methods:

    1. Flashing a rom with root
    2. Flashing engtools.zip that jcase provided which gives your current stock rom root

    Unfortunately since you are having issues using recovery because of the trackball, this is preventing you from doing one of the methods above.
     
    kamots and scary alien like this.
  14. scary alien

    scary alien not really so scary
    Moderator

    Ah, Papadroid, thanks! I sort of assumed that these root scripts (at least part 1) did the engtools.zip thing behind the scenes...(which is why I really want to look at them to verify this--I can't do the download here at work :().
     
  15. Hypo Luxa

    Hypo Luxa Android Enthusiast

    When I do Vol- and End I get the typical white recovery screen. I tried this with 80% battery life and also the first two parts with the scripts worked perfectly even to the point where it says 'Congrats you have root' but alas, I cannot get to the black recovery screen for nothing
     
  16. skapooj

    skapooj Newbie

    Disclaimer: Im not especially techy, so you'll have to excuse me, but I am eager to learn. Heres the issue. I am making it all the way to the last step and only have the gscript.zip and pb00img.zip as options (just like Almac), but I instead downloaded the rom on my Mac and placed the whole PlainJaneT2_V2 in the root of the SD card folder. The only part I don't understand about the instructions (and I imagine is what is tripping me up) is in the introduction:

    "1) Did you choose a ROM, download it to your SD card, and check the MD5 signature/file length on the copy of the file on your SD card?"

    I downloaded the large ROM file, and copied the whole folder onto the root of my SD card, but it simply says PLainJaneT2_V2 and Im not sure how to check for the MD5?

    If I have the same problem as Almac, I am sorry for the double post, but I didnt download the ROM on my phones browser like he did.
     
  17. Papadroid

    Papadroid Android Expert

    Make sure that you are holding both buttons until it takes you into recovery. If it still doesn't work then try the power/end and call buttons, this should take you to a menu where you can either go to fastboot or recovery, I think. Sorry I'm not as familiar with the Eris as I am with my device, I'm just going off of memory from rooting my wife's eris.
     
  18. Papadroid

    Papadroid Android Expert

    I think Macs have a reputation for opening zip files. If it is a folder and not a zip you are not going to be able to install and recovery won't recognize it. You have to download and make sure that it remains a zip file, if this is indeed your problem.
     
  19. skapooj

    skapooj Newbie

    I think I remember having this same problem when I would try to install one of the new leaks. It became a folder instead of the desired .zip. Now to remember how I kept those files as .zips! I have to figure this out fast because this stock HTC is not awesome.
     
  20. Hypo Luxa

    Hypo Luxa Android Enthusiast

    holding Call & End & + got me into the old recovery :(

    Holding End and Vol+ and not letting go had no effect.. ended up booting as normal despite my holding both buttons the whole time

    feeling like a dummy at the moment :(
     
  21. skapooj

    skapooj Newbie

    could I simply just compress the folder into a .zip and delete the folder from my sd card? Is it just that simple?
     
  22. Papadroid

    Papadroid Android Expert

    I'm not too positive but I think that may be a bad idea, and even if you did try this you don't want to compress you want to store as an option when zipping the folder. Are you unable to download and save the file as a zip? I wish I could help you with that but I don't use a mac.
     
    skapooj likes this.
  23. Papadroid

    Papadroid Android Expert

    Unfortunately I don't have an eris in my hands to help you but it doesn't make sense to me that you get the old recovery. I would maybe try again from the beginning.
     
  24. scary alien

    scary alien not really so scary
    Moderator

    kamots, Papadroid,

    Okay, I downloaded the gscript.zip file to my DX and reviewed the root_part1.sh and root_part2.sh scripts.

    From what I can tell, all root_part1.sh does is allow you to install a custom recovery partiton by changing its security (using wag3slav3's mid.txt exploit). This allows you to run root_part2.sh to be able to flash/install Amon_RA's custom recovery. At the end of root_part2.sh, it un-installs (restores, really) the mid.txt exploit back.

    edit: okay, now that I'm looking at the contents of engtools.zip, I see it contains the superuser.apk and a replacement su command. I guess I don't really understand how the mid.txt link exploit actually gains you root (or rather, what it does to allow you to install the custom recovery image). Still looking...:)...back soon...

    2nd edit: okay, I got it! Papadroid is absolutely right! You do need to install a custom ROM and/or the engtools.zip in order to get root access.

    The way the mid.txt exploit works is to soft link the recovery partition (/dev/mtd/mtd1) to a file (/data/local/rights/mid.txt) that already has full access ("a=rwx") permissions. This is what allows you to overwrite the recovery partition with a custom recovery and subsequently allow you to install a root (custom) ROM. :D
     
    kamots likes this.
  25. Papadroid

    Papadroid Android Expert

    You definitely sound more knowledgable than myself on this but wouldn't he still neeed superuser permissons app?
     
    kamots likes this.

HTC Droid Eris Forum

The HTC Droid Eris release date was November 2009. Features and Specs include a 3.2" inch screen, 5MP camera, 288GB RAM, MSM7600 processor, and 1300mAh battery.

November 2009
Release Date
0
Reviews
Loading...

Share This Page

Loading...