1. Are you ready for the Galaxy S20? Here is everything we know so far!

Universal Eris Root for Dummies!

Discussion in 'Android Devices' started by erisuser1, Jul 20, 2010.

  1. varkie

    varkie Android Enthusiast

    I actually unrooted my phone by flashing the RUU, then installed the 7-17 update and used this to root the phone again and it took only a mtter of minutes to do it. Thanks guys this is fantastic work.

    I didn't flash a rom though just the engineering tools to get superuser, then I flashed the overclocking kernel.
     


  2. skapooj

    skapooj Newbie

    @ Papadroid: I figured out how to download the file as a .zip. Once the download finishes, I will be trying the process again. Thanks a lot for your help!
     
  3. rick311

    rick311 Android Enthusiast

    so if i rooted this way, how can i Unroot?
     
  4. scary alien

    scary alien not really so scary
    Moderator

    Well, I think that's just an app that allows you to control (selectively grant superuser permission to) new applications that are launched. Plus, its a really cool little app :D [you've obviously already need to have root to use this app...otherwise, rooting would be really easy :eek:]

    I think kamots could be our tester and re-do the root_part1.sh part like the thread says, then type "su" in via Android Terminal Emulator to see if he gets the "#" prompt which should show that he's rooted or not.

    [edit: nope, this won't give him root, just the ability to install a custom recovery; the engtools.zip contains both the superuser.apk app and the su command; the su command is what gives you root and the superuser.apk helps you manage access to root]
     
    kamots likes this.
  5. Papadroid

    Papadroid Android Expert

    Please don't think that I'm arguing, I'm actually trying to understand and learn as much as I can, but everything I've ever done on my phone including terminal emulator has needed the superuser app to give permission otherwise it's denied.
     
    kamots likes this.
  6. scary alien

    scary alien not really so scary
    Moderator

    Papadroid, not at all a problem...:)

    I could be waaay off (really hope I'm not or I have a few posts to edit and redact).

    I think the superuser app is just a safety measure so that you can selectively grant which apps you want to have root access to scary (if you will :D) capabilities on your phone. Notice that you can tell it to remember the setting for the future so it won't ask / prompt you again for apps you trust. This ends-up being a whitelist for apps that you trust and a blacklist for ones you don't want to run. This app is also typically installed on the custom ROMs we install, but, by then, of course, we are already rooted.

    I don't have my Eris with me and its already rooted...I'm not yet brave or knowledgable enough like eu1 to un-root it and test a lot of this stuff! :eek:

    P.S., my Android Terminal Emulator has never been asked for permission from the superuser app...I don't remember if I told it to remember and whitelisted it or what a long time ago or not... [edit: I believe that I must have whitelisted it]
     
  7. cnp112

    cnp112 Lurker

    Any help will be greatly appreciated...

    I was wondering if I wanted to use KAOSFROYO V24 as the custom ROM that I want to install going through the process outlined by EU1, would I run into problems???

    I guess I am really asking for a breakdown of what the MD5 signature is and how do I know if KAOSFROYO V24 is compatible.

    btw---this is an amazing write up EU1---thanks...

    " 1) Did you choose a ROM, download it to your SD card, and check the MD5
    signature/file length on the copy of the file on your SD card? "
     
  8. kamots

    kamots Well-Known Member

    Sweet! Then that means that one method is still available. Last question,and I will leave you guys alone. Would my phone blown up if I un installed the gscript and everything, re downloaded and started from scratch.? I know that amon ra is already on my phone, but will also need installation write over it. Ok so it seems like I have a few options. 1 installation the engtools.zip however I don't know how, and i'm not familiar with it. 2nd start fresh with new install and hope for the best 3rd wait to see if anyone has had this problem and what they did to fix it. And the least desirable 4th option. Stick it out till Oct when eligible for an upgrade and get the samsung facinate
    Thanks you everyone, for trying to help I appreciate it and hopefully we can get something to work
     
  9. scary alien

    scary alien not really so scary
    Moderator

    kamots, read through the posts above where Papadroid and I were discussing your issue.

    Can you test the first part of using root_part1.sh? (as per the guide instructs--you shouldn't have to re-download things, just re-run the root_part1.sh in Gscript, then power off/on and see if you have root (via "su" from the Android Terminal Emulator)). Don't run part 2 (you've already done it and I believe that it removes your root access).

    P.S. you don't have to do this if you are not comfortable...no pressure...just curious. Thanks.

    P.P.S. nevermind...you won't get root access after doing the root_part1.sh--you've got to be able to flash .zips from Amon_RA's custom recovery (which you can't b/c of the trackball). Sorry dude.
     
    kamots likes this.
  10. scary alien

    scary alien not really so scary
    Moderator

    Papadroid rules! You are absolutely correct. I did a little more research and finally figured-out how I think the mid.txt exploit works (devilishly simple, actually). Anyway, I edited my original reply to your post to include the following:

    edit: okay, now that I'm looking at the contents of engtools.zip, I see it contains the superuser.apk and a replacement su command. I guess I don't really understand how the mid.txt link exploit actually gains you root (or rather, what it does to allow you to install the custom recovery image). Still looking...:)

    2nd edit: okay, I got it! Papadroid is absolutely right! You do need to install a custom ROM and/or the engtools.zip in order to get root access. The su command in engtools.zip gives you root and superuser.apk helps you manage access to root.

    The way the mid.txt exploit works is to soft link the recovery partition (/dev/mtd/mtd1) to a file (/data/local/rights/mid.txt) that already has full access ("a=rwx") permissions. This is what allows you to overwrite the recovery partition with a custom recovery and subsequently allow you to install a root (custom) ROM. :D

    I don't think anyone has actually explained how the exploit works before (state secret?) or maybe I just hadn't run across it yet...

    Sorry for the confusion, but I really learned a lot from researching this! :eek::D:)
     
    kamots likes this.
  11. Roush

    Roush Newbie

    How do you put froyo 2.2 on the Eris after root???
     
  12. Asmith1106

    Asmith1106 Member

    AWESOME! Just rooted and running KAOSFroyo! Great work and Many many thanks!!
     
  13. scary alien

    scary alien not really so scary
    Moderator

    There's a Froyo custom ROM that you flash using the custom recovery image. Here's the developer's (punk.kaos) thread: [ROM]KaosFroyo V24 [07/21] [FROYO] - xda-developers
    (its not "official" from Google or VZW, and has a few bugs, but its getting better each day...read through the thread for more information)
     
  14. Asmith1106

    Asmith1106 Member

    ok well Kaosfroyo has been trying to start up for like 15 min now... boot screen loop...

    What can I do to fix this?

    EDIT: Trying a restore and re-wipe and going from there....
     
  15. scary alien

    scary alien not really so scary
    Moderator

    Don't forget to always take a Nandroid backup before flashing anything and do the wipes as required by the developer's ROM thread.
     
  16. Roush

    Roush Newbie

    I'm trying to do my homework before I root my Eris. I'm learning a lot thanks to everyone on this forum! My next question is, if I get v24 kaosFroyo (For Example) Does that mean when v25 comes out, in order to install it I have to wipe my phone, and start all over again?
     
  17. ticklemedaly

    ticklemedaly Newbie


    Got the same problem. Did both steps in Gscript just fine, but can't get the Vol+/End to do anything but start the phone up normally. Vol-/End and Call/End buttons do the same original bootloader, not the one listed in the next step.

    Going to try and start over from the beginning shortly and see what happens.
     
  18. Roush

    Roush Newbie

    What's the easiest way to un-root the phone?
     
  19. Kaseladen

    Kaseladen Lurker

    I decided after having alot of problems with my Eris that I was going to root it. I went through your instructions here, and got up to the point where it said "You now have ROOT". After that, when I went to restart it, it would freeze at the Droid screen when I held Power and Volume+. The alternate way to reach there (holding call and power) doesn't do anything at all.

    Does anyone have any suggestions?
     
  20. ticklemedaly

    ticklemedaly Newbie

    Ran through the steps a second time, same thing. All the way through the second step with it saying " you have root" and reboot. Hold Vol+ and End at the same time and it boots normal.....
     
  21. lambo172

    lambo172 Newbie

    Hi, im new here, and i went through the first of the posts with some trouble getting gscript to create a folder, so i created one on my computer and unzipped gscript too. i got the tools, part one and two in the folder and went ahead to create new scripts. while doing part 2, there was an errors saying i didnt have enough space, but then it said i had rooted. i tried booting up with the vol up and call/end key pushed in at the same time and all i got was the regular booting screen. Can anyone tell me whats wrong? By the way, im running on OTA 2.1.
     
  22. cnp112

    cnp112 Lurker

    Please Help...Thank you so much in advance...

    I am having the same problem as others -

    part1 = OK
    part2 = OK
    REBOOT with volume+ / end = NORMAL STARTUP
    REBOOT with volume- / end = STOCK BOOTLOADER

    I followed the directions exactly as stated. I even went back and executed part1 / rebooted / executed part2 / rebooted and the same results were reached.

    The only difference which should not matter ( at least I dont believe so ) is that I downloaded the files on my computer and transferred them over to their correct directories on the phone through USB.

    ERIS 2.1 OTA
     
  23. Kaseladen

    Kaseladen Lurker

    Managed to get to the recovery screen, but it's the standard white one. And if I try to boot up from there it freezes like before.
     
  24. Kaseladen

    Kaseladen Lurker

    I did the same, and it seems the other person did as well.. could that really be the issue?
     
  25. lambo172

    lambo172 Newbie

HTC Droid Eris Forum

The HTC Droid Eris release date was November 2009. Features and Specs include a 3.2" inch screen, 5MP camera, 288GB RAM, MSM7600 processor, and 1300mAh battery.

November 2009
Release Date
0
Reviews
Loading...

Share This Page

Loading...