1. Are you ready for the Galaxy S20? Here is everything we know so far!

Universal Eris Root for Dummies!

Discussion in 'Android Devices' started by erisuser1, Jul 20, 2010.

  1. duccicucci

    duccicucci Lurker

    i have successfully rooted my droid eris (according to this thread) but when i loaded the terminal emulator onto my phone and did the "su" command, it says permission denied and gives me the "$" sign .. before i decide to wipe my phone and install a custom rom, i want to make sure that i am actually rooted and wiping to install a rom will not completely mess up my phone .. i appreciate any help!
     


  2. Kaseladen

    Kaseladen Lurker

    Just tried it out with being saved and extracted from the phone and all that jazz, ran the scripts again and got nothing new. Back to square one.
     
  3. animanga008

    animanga008 Newbie

    I also have the same problem. Running the scripts went fine. It said "you have root." But I cannot run the next part which is powering on the phone with vol+/End and then flashing. It just loads as normal.

    In addition, I feel as if my phone loads slower if not runs slower overall. I'm a little bit nervous now about what I did to my phone :p.

    Help please?
     
  4. animanga008

    animanga008 Newbie

    Okay, so the way around the vol+/end problem is simply vol-/end and then "recovery."

    From there I just continued to follow the instructed on the front page.

    One thing that popped in my mine was when I made sure that the rom I was using was still in .zip format before doing the clearing. Had I not done that, I don't know what would have happened when attempting to flash.
     
  5. kamots

    kamots Well-Known Member

    Wow I posted a big long response to this last night on my phone, and I now see that it never posted. Nice. Another reason Im looking foreward to root lol. First off thank you Papadroid and Scary alien for all of your efforts and research yesterday. I was afk ( had to put son down for a nap, and of course had to take one with him lol) I believe that I am caught up with the conversation though. If I understand correctly, I need to either flash the engtool.zip from my sd card or a custom rom, and this should fix my problem correct? This is no problem since both are on my sd card. My noob question is this. To flash either one of these I just do it the same as we did when we instaled the leaked versions of 2.1. ( put on root of sd card turn of phone vol down and end the option install from sd card right? I know its probably basic android 101 , but the only experience I have with flashing is lv2 and lv3. as long as it is vol down and end Im golden. vol up and end is where my trackball issue comes into play. also which one would you advise , the engtool.zip, or a rom or both? again thank you both for you efforts
    edit 0715 i tried the vol down and end and it sent me back to recovery which is where the track ball freezes i see the opt install zip from sd card, but cant get to it. looks like the only way to get this to work is to go back to adb commands which suckk cause i was stuck on that too adb command not recognized etc but that is a different thread. oh well might just go with the wait til oct option.:mad::(
     
  6. kamots

    kamots Well-Known Member

    I am noticing this to.my phone is super lagtastic when I type on it now. I dont know if it has anything to do with this, or the ota i got the other day either way ,it sucks. come on root! lol
     
  7. ticklemedaly

    ticklemedaly Newbie

    The only lag I noticed is when it first starts up and needs to get running. But that maybe the way it is. Before doing the prior steps, I had maybe rebooted the phone 3 or 4 times within a couple weeks of having it. So I'm going to go with it being ok for now.
     
  8. kamots

    kamots Well-Known Member

    just confirming that you did the nand back up / wipe/ rom install? cause i had this problem to but that caus eof track ball issued i couldnt select it if your track ball works your should be golden, and I am jealous lol:D read through this thread though , either papadroid or scary alien answered the same question for me short answer if I understood, is your dont really have root until the whole process is completed.

    edit : this makes sence because if you go back and look at both scripts you are instructed to uncheck the super user box. the terminal emulator ask for super user access i believe
     
  9. kamots

    kamots Well-Known Member

    This brings me to a new question. since i cant install from my sd card through recovery, can i send the engtools.zip or custom rom through gscript lite and install them that way? ( please say yes lol):p
     
  10. scary alien

    scary alien not really so scary
    Moderator

    kamots,

    Sorry, but I think you have to flash engtools.zip just like you would have to for a custom ROM :(.

    I wish I could give you my trackball setup, lol. I have very rarely ever used it.
     
  11. varkie

    varkie Android Enthusiast

    Clockwork Mod Recovery doesn't use the track ball to move betweeen selections, it uses the volume up and down buttons. Is there a way to edit the second script to get it to load instead of amon's?
     
    derwyn and kamots like this.
  12. kamots

    kamots Well-Known Member

    hmmm . you must not have gotten the memo. no bad news before 9am. lol j/k well that sucks Ill just stick with it until oct then. I appreciate all your help and advice.:D
     
  13. kamots

    kamots Well-Known Member

    that i dont know but i will check into it thanks!:D
     
  14. kamots

    kamots Well-Known Member

    I wonder if re downloading htc sync and re installing drivers to my phone would help?
     
  15. Papadroid

    Papadroid Android Expert

    I think it would be better to try and get the adb working rather than flashing clockwork recovery. For one it's always a good idea to have a working adb with a rooted phone just in case. And I have heard of other eris users having major problems with clockwork recovery. Clockwork recovery is great with other phones like my Droid but for some reason it has problems on the Eris.
     
    kamots likes this.
  16. kamots

    kamots Well-Known Member

    This would be great is i could get my adb shell to work. comp wont recognize phone when i type adb devices, whoooooollllleeeee nother issue. will have to start that process from scratch on another comp after work today.lol:( have another data cable so im hoping that will solve the issue. out of 50 or so tries i have only seen found new hardware loading adb message twice.
     
  17. Papadroid

    Papadroid Android Expert

    I found this thread over at xda that should be able to help you load roms via adb if you are able to get it running. There are links in thread under Scripts available via adb which gives more details on using the scripts. From looking at it a little it looks as though you may have to partition your sd card to get it to work properly but I'm not positive on that, you could try it first to see if it works then maybe partition it if it didn't.

    xda-developers - View Single Post - [Recovery] [17-Mar-2010] RA-eris-v1.6.2
     
    kamots likes this.
  18. varkie

    varkie Android Enthusiast

    I only suggested it for the people that have trackball issues not for everyone. If the op could edit the file and add Clockwork then edit the script to install it then the problem would be solved for people with trackball problems. You can always flash back to amon's at any time after but of course if you don't have a working trackball you still couldn't use amon's. I see no reason why there couldn't be a second version of script #2 for people with non-functioning trackballs.

    Also in the original (day 1) thread on XDA forums by captainkrtek (tereg) for rooting a leaked eris clockwork was the recovery that was installed. And I've been using it for at least a month without problems now. In fact after re-rooting my phone using this method I switced back to it as I like to using ROM Manager.
     
    kamots likes this.
  19. cnp112

    cnp112 Lurker

    Just wondering if anyone has encountered the issue above and has been able to work around it...Thanks...
     
  20. kamots

    kamots Well-Known Member

    alright , since i am having the worst luck with root , lets weigh options. if I flash clockwork, how much damage can it do to my phone if it goes wrong? or do we know?
     
  21. kamots

    kamots Well-Known Member

    thank you :D i will take a look at this
    edit alright i downloaded it to a thumb drive for later, but now that i look at it , i believe this is the amon ra recovery that i already have on my phone, unless im looking at it wrong should I re flash this? also im not to familiar with partitioning the sd card , i will have to research it
     
  22. Papadroid

    Papadroid Android Expert

    For the record I use and love clockwork recovery on my Droid. And I understand that you are only suggesting it to those with trackball issues but like I said there have been many users with problems on clockword with an Eris. But I will concede that if you're able to use adb and Amon_Ra you should be able to flash clockwork and then back to Amon_Ra if clockwork doesn't work.
     
  23. Papadroid

    Papadroid Android Expert

    The worst that should happen is it won't boot into recovery. If that is the case then you can just flash back to Amon_Ra.
     
  24. varkie

    varkie Android Enthusiast

    Even if he can root his phone through adb and get amon's on it he still wouldn't be able to use it as it requires a trackball. He is stuck using another recovery. There are other recoveries out there besides clockwork and amon's I was just familar with clockwork because that is the ones the devs used on the eris leak root method and I just kept using it.

    I'm not sure if script root_part2 uses fastboot to install amon's but all that may be required is to replace the amon's recovery image in the gscript tools folder with the clockwork image (or other recovery image) making sure it has the same name as the original image file, and see if that works.
     
  25. scary alien

    scary alien not really so scary
    Moderator

    cnp112, are you trying to invoke the custom recovery? (i.e., power-off your phone, then press Volume-UP button AND the End/Power buttons simultaneously)
     

HTC Droid Eris Forum

The HTC Droid Eris release date was November 2009. Features and Specs include a 3.2" inch screen, 5MP camera, 288GB RAM, MSM7600 processor, and 1300mAh battery.

November 2009
Release Date
0
Reviews
Loading...

Share This Page

Loading...