1. Are you ready for the Galaxy S20? Here is everything we know so far!

[UNLOCK] LG L70 Bootloader Unlock

Discussion in 'Android Devices' started by MikeHoncho, Aug 4, 2014.

  1. MikeHoncho

    MikeHoncho Android Enthusiast
    Thread Starter

    You can either search Google and read or you can read part of this post that sums up the unlocking of the bootloader HERE

    1. Download the Forums for Android™ app!


  2. verdooch96

    verdooch96 Well-Known Member

    bootloaders are like a phones bios, it is what tells the phone to load the kernel and recovery and rom, a locked bootloader means it signature checks the kernel and recovery so you cant replace them with custom ones.
    This came to me from Shabbypenguin.
  3. Osniel

    Osniel Lurker

    he folks i'm sorry for my bad english but i am from cuba and i crazy to root my lg l70 ms323 and this part not understand "and you still don't have a backup of the laf partition, hastebin the output of terminal or command prompt and link me to it."

    please explain for my better understanding thk a lot for you great work
  4. MikeHoncho

    MikeHoncho Android Enthusiast
    Thread Starter

    When running part 1 of the unlock, it makes a backup of your laf partition, aka, download mode. I made it to where it sends a copy both to your internal SD of your device and makes another copy to your computer. This copy is needed just so that you will be able to restore your download mode after running the fastboot commands.
  5. heyki

    heyki Newbie

    So ummm..... what exactly should the screen look like?

    I followed all the steps but something just does not seem right
  6. sanderjm

    sanderjm Newbie

    Any chance someone could make a guide for Mac users?
  7. kayser26

    kayser26 Lurker

    hi! i was trying to restore the download mode as it is posted here, but when i choose to restore the backup .img the phone reboot and now it stays in:
    [660] fastboot_init()
    [660] Error: allocating memory for ssd buffer
    [690] USB init ept @0x7ab1000
    [710] udc_start()
    [810] -- reset --
    [810] -- portchange --
    [1070] fastboot: processing commands
    the phone does not boot, just stay there D: what can i do? is there any way to fix it? Thank you all
  8. MikeHoncho

    MikeHoncho Android Enthusiast
    Thread Starter

    There is no option to restore download mode in my script, if you want to restore it then you need to do it manually (look at the bottom of the OP). If you are referring to the script that was made by sammyz then post in his thread so he can help.
  9. macacovei

    macacovei Newbie

    Hey guys, thanks for the instructions.

    I'm having "device offline" issue when I start adb. Anyone can help?
  10. Timeus

    Timeus Lurker

    having the same issue as the previous poster with the device offline error. did you figure out what was wrong?
  11. MikeHoncho

    MikeHoncho Android Enthusiast
    Thread Starter

    your version of adb is probably outdated or you don't have the device drivers installed
  12. sanderjm

    sanderjm Newbie

    When I plug my phone in and go into fastboot I cannot find it on my PC. I have updated the drivers and I still get nothing when I run fastboot devices. Any idea what I can do?
  13. MikeHoncho

    MikeHoncho Android Enthusiast
    Thread Starter

    Do you have the fastboot driver installed?? It is in the original post. Also sometimes adb messes up the fastboot process so you need to enable the fastboot driver in your computer settings, cant guide you through that unfortunately since I don't use windows
  14. sanderjm

    sanderjm Newbie

    I thought I had it installed. I will check again in the morning.
  15. ramimz

    ramimz Newbie

    Hi Mike.

    First let me say thank you for a nice job, but after reading this post, it's look like i'm not the only one having problem unlocking the bootloader and many users have many problem getting it to work.

    I try to find a video on youtube, but without success :(
    can you make a small step by step video ?
    believe me... it will solve 90% of the problems.
  16. MikeHoncho

    MikeHoncho Android Enthusiast
    Thread Starter

    Sorry but I don't plan on making any videos, even if I did, it would be for linux users as I have already stated that I don't use Windows. Linux takes almost no configuration to get this stuff working, windows sucks lol. Too many extra steps to do on windows :D If someone else who knows what they are doing would like to make a video for Windows users, feel free to do so since everyone seems to have a problem with the fastboot part, which is a common problem windows users have.
    ramimz likes this.
  17. ramimz

    ramimz Newbie

    I don't mind install linux on one of my 6 computers ;)
    i'm just wanna pass this with 100% success.

    any suggestion on fast & easy Linux version ?
  18. AndroidJD

    AndroidJD Well-Known Member

    I tried this on my cricket lg l70 D321 it doesn't take me to fastboot when I power on and press the volume up at the same time it just restarts, is it probably because my phone doesn't support this.
  19. DMedina559

    DMedina559 Android Enthusiast

    It has to be plugged in to a charger while you hold vol+
  20. AndroidJD

    AndroidJD Well-Known Member

    I did that but it vibrates and restarts it with LG than the cricket boot animation even when I still hold the buttons does the same thing again.
  21. Spz0

    Spz0 Android Expert

    The D321 supports this, you're just not doing the sequence right. From power off: Plug in your USB cable. Wait til it reads a charge. Then press and hold Power til the phone vibrates. Immediately release Power and press Volume Up until it loads fastboot.

    Mike, you may want to update the OP with this method, as it seems different models (D320, D321, MS323) have slightly different ways of entering laf.
  22. plastered

    plastered Lurker

    Step 1 completed just fine.

    Volume Key+Power Button combo isn't working.
    Partition Zero didn't help... still won't boot into fastboot mode.
  23. DanielReyes

    DanielReyes Lurker

    When i put in the command "laf_script.bat" it says
    Bootloader Unlock For The LG L70 Part 1
    ====================By: Android Addict and junkie2100 ==================

    Make sure that USB Debugging is enabled,
    all drivers are installed
    ECHO is off.
    I am not responsible for anything that may or may not happen to your
    phone. By using this script, you are taking full responsibility of your device.

    =============================Other credits============================
    Android Addict, junkie2100, Cheetopocalypse, biggiephil, bobdamnit, LoneStar,
    and PlayfulGod.
    [*] Moving laf.img to sdcard/Download folder

    1024+0 records in
    1024+0 records out
    23068672 bytes transferred in 1.315 secs (17542716 bytes/sec)

    [*] Moving laf.img to computer just in case

    3540 KB/s (23068672 bytes in 6.363s)

    [*] Now going to zero out the laf partition

    /dev/block/platform/msm_sdcc.1/by-name/laf: write error: No space left on device

    45057+0 records in
    45056+0 records out
    23068672 bytes transferred in 4.533 secs (5089051 bytes/sec)
    [*] laf partition complete!!!

    [*] Proceed to part 2 of my guide now!!!

    laf partition script
    ========By: Android Addict, junkie2100, Cheetopocalypse, biggiephil,
    bobdamnit, LoneStar, and PlayfulGod========
    ECHO is off.
    ECHO is off.

    Hope you enjoyed this! If you would like to
    donate, follow the link in my signature!

    Why does it say this , i have a 32 gb and a partition 20/12 gb so i have enough space, please help:mad::thinking::thinking::thinking:
  24. gregoriio01

    gregoriio01 Lurker


  25. me4oto

    me4oto Lurker

    what this mean:
    zero out the partition

LG L70 Forum

The LG L70 release date was April 2014. Features and Specs include a 4.5" inch screen, 8MP camera, 1GB RAM, Snapdragon 200 processor, and 2100mAh battery.

April 2014
Release Date

Share This Page