1. Are you ready for the Galaxy S20? Here is everything we know so far!

Unlock without touchscreen. Mouse not recognised. xperia z3+

Discussion in 'Android Help' started by GadBeebe, Apr 20, 2020.

  1. GadBeebe

    GadBeebe Lurker
    Thread Starter

    Help!
    I have cracked by phone screen and touch input no longer works. How do I unlock my phone or otherwise access it's juicy contents?

    Specifics:
    The phone: Xperia z3+ with swipe pattern unlock.
    I think the software should be android 7.1 or thereabouts.
    The phone isn't rooted, and I don't remember changing any USB debugging settings.

    Failed solutions:
    Smart unlock devices/networks (none registered)
    Voice unlock (not active)
    Previously paired bluetooth keyboard (connects but has no way to input the swipe pattern)
    USB OTG and (optical) mouse. (mouse doesn't turn on or allow input, though this method worked for another android in the house)

    Any ideas? In particular, I wonder if anyone knows a way to get the mouse working or can clarify whether the z3+ even supports the mouse like the previous xperias did.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    I would expect the mouse + OTG to work - I've used such things with various Android devices in the past. I'm afraid that I don't know why it would not, unless there is a problem with the socket (not turning on makes me wonder about this: that sounds more like it is not powered than a software issue). This is a very generic OTG function that I'd expect any device to support. I don't suppose you've any other mice to try, just in case there's some quirk with that particular one?

    Pattern is annoying: I've unlocked PIN-locked phones using a keyboard, but can't imagine anything other than a mouse working for a pattern (and using a mouse blind is not fun - I have done that with a phone as well...).
     
    GadBeebe and ocnbrze like this.
  3. GadBeebe

    GadBeebe Lurker
    Thread Starter

    A good thought. I'll experiment with other mice the next time I'm at work and see if I can get my hands on a pwered USB hub also.
     
    ocnbrze likes this.
  4. GadBeebe

    GadBeebe Lurker
    Thread Starter

    Just to update.
    I've tried multiple mice with no success.
    I've also tried using a powered USB socket (like this:https://www.ebay.co.uk/itm/264462745639) but no success.

    I can only assume the xperia z3+ doesn't support mouse input, or perhaps just not on the lock screen. Disappointing, as I'm sure this worked for older Xperia phones.
     
Loading...
Similar Threads - Unlock without touchscreen
  1. Adi Inbar
    Replies:
    14
    Views:
    992
  2. mayconz
    Replies:
    13
    Views:
    777
  3. joshkrupinsky
    Replies:
    1
    Views:
    269
  4. Nidheesh
    Replies:
    15
    Views:
    655
  5. wmc999
    Replies:
    7
    Views:
    553
  6. Ryh86
    Replies:
    5
    Views:
    908
  7. joshhumble
    Replies:
    0
    Views:
    414
  8. Doulos Adonai
    Replies:
    4
    Views:
    1,210
  9. zabble
    Replies:
    16
    Views:
    2,784
  10. dontpanicbobby
    Replies:
    25
    Views:
    39,036

Share This Page

Loading...