1. Are you ready for the Galaxy S20? Here is everything we know so far!

Unofficial AOSP Builds

Discussion in 'Android Devices' started by Shabbypenguin, Jul 16, 2014.

  1. Shabbypenguin

    Shabbypenguin Extreme Android User
    Thread Starter

    Ok guys here is where ill be posting the aosp builds ive made for the mogo g 4g. currently all ive got is a CM11 rom, but carbon is compiling and then ill work on slimkat. these are betas and as such should be treated as such.


    Major bugs known:
    • Plug in headphones and some sounds play through headphones and speakers.
    • Miracast isnt working
    • Gyroscope
    • GPS currently requires a lock on stock and then it will work.
    • There may be more but in such limited testing i was focused on the big things :)


    Core features that are working:
    Phone (apparently some people deemed this a "required" feature)
    Camera
    LTE
    Bluetooth
    GPS


    I dont have this phone so im flying blind with the exception of my two awesome testers. Seriously go find some posts by eteles and suhridkhan and give them some thanks otherwise i would have just given up.


    If you would like to donate for my work on porting cwm and aosp to this device you can do so in my signature.

    I would also strongly suggest you send some to Dhacker, as without his work on the moto g this wouldnt have been so easy so seriously shoot him some love as well. he has brought cm and various other roms to just about every modern moto device and without him there wouldnt be this thread. you can do so via this link here http://forum.xda-developers.com/donatetome.php?u=4112553

    Credits:
    Dhacker - msm8226 device tree bringup along with falcon made this a lot easier
    Cybojenix - Work on the Moto E
    Somcom3x - Talking with me on irc and his work on trying to get it all sorted out.
    Caribo & medic - Audio fix
    Nupich - Assistance with fixing sdcard mounting.


    Sources:
    https://github.com/Shabbypenguin/android_device_motorola_peregrine Look at the readme
    https://github.com/Shabbypenguin/android_vendor_motorola
    https://github.com/Shabbypenguin/android_device_motorola_msm8226-common
    https://github.com/Shabbypenguin/android_kernel_motorola_msm8226
     



    1. Download the Forums for Android™ app!


      Download

       
  2. alfick3

    alfick3 Android Expert

    Though I don't have the LTE version, it's nice to see ya working on it, Shabby. I'm loving my original version Moto G.
     
  3. Shabbypenguin

    Shabbypenguin Extreme Android User
    Thread Starter

    well i got a request for recovery and in between waiting on test results i started to work on the device tree buildout, when it was finally done with cwm i had fairly done trees so i figured what the hell and ran a test build. booted right up and had minimal problems, ended up fixing LTE and got the phone to detect there is at least an sdcard but then it broke sound completely so now i found a happy medium for now :p.

    i dont intend to work on this device long term but i figured id help get the ball rolling :)
     
    suhridkhan, rvem, Tesla5 and 2 others like this.
  4. vpnair

    vpnair Lurker

    Will flashing these ROMs affect 4G/LTE? It's my understanding that the LTE bands are different for XT1039/1040/1045. Or is modem unaffected by flashing?

    EDIT: Shabbypenguin: its actually using teh same radio files as the regular moto g, so everything should be universal.
     
    suhridkhan likes this.
  5. USCanthony

    USCanthony Member

  6. Shabbypenguin

    Shabbypenguin Extreme Android User
    Thread Starter

    they use the same files so every aosp build will have the same issues.
     
  7. caribo

    caribo Newbie

    Thanks @ShabbyPenguin, I am rocking the CM11 build and very satisified. Only problem are related to non-functional GPS and external SD (which is not a problem for now). I can do without the external SD, but non-functional GPS is a pain in the ass... I'm using the moto-g XT1039 EU version; not sure that this makes a difference when it comes to GPS though...

    any suggestions as to what I can do to debug / resolve?
     
  8. Shabbypenguin

    Shabbypenguin Extreme Android User
    Thread Starter

    interesting, as far as i knew gps is indeed working, can you describe what you did and how you know its not?
     
  9. caribo

    caribo Newbie

    sorry, should have been more specific. I dont seem to get a gps fix in maps or waze applications; either when using "High Accuracy" or "Device Only" mode. GPS Test application does not locate any satellites even when out in the open. my girlfriends original moto-g gains fix in seconds in same location....
     
  10. derekn13

    derekn13 Lurker

    I'm seeing exactly the same problem -- the "GPS Status and Toolbox" app doesn't find any satellites.

    This is on an XT1045 with your CM11 build #6.

    I'm happy to do some testing, if there's anything I can do.
     
  11. derekn13

    derekn13 Lurker

    I'm also having trouble with the SD card. Settings->Storage gives me the option to mount the SD card -- I get a "preparing SD card" notice, and then... nothing. The "mount SD card" option is still there (instead of "unmount"), so it looks like mounting failed.

    I ran the "erase SD card" option, but that didn't make any difference.

    If I remove the card, I get the "SD card removed", and if I re-insert it, I get "preparing SD card", so it's seeing the card at some level.

    I'm aware that there are problems with certain SD cards on the Moto G LTE. I intentionally bought a crappy slow 16GB card to avoid that issue. Also, this same card worked fine for a CWM backup. I was able to copy the backup off to my computer using a card reader, so I know the phone was able to write to the SD card (in CWM).
     
  12. Shabbypenguin

    Shabbypenguin Extreme Android User
    Thread Starter

    yea sdcard not working is a known issue, there is something preventing it from being mounted and i still need to track down what it is. its an improvement over teh first few builds which didnt even have an sdcard section in the storage though :p
     
  13. derekn13

    derekn13 Lurker

    Oops, now I see that you mentioned the SD card in the list of known bugs way up in the first post - guess I just missed it :)

    Thanks for all your work on this.
     
  14. Shabbypenguin

    Shabbypenguin Extreme Android User
    Thread Starter

    np :). im gunna upload my device trees later today so i can hopefully get some help from some other people on fixing these things :)

    edit:

    Device tree is updated with latest files, commit history and code looks like ass so please dont judge me off that :p

    it needs a modded msm8226-common here is a quick commit of all the work needed to get msm8226-common to where i have it for the aosp builds ive posted. https://github.com/Shabbypenguin/an...mmit/b8f6ebe57217d04ec6b407df068005e4d50e4c9d with those two repos and the rest of teh dependancies file you should be able to build any of the aosp roms with the same level of bugs/issues/features as what i have. i was hoping to clean it up some but then i got hung up on personal stuff, now other people can help contribute :)
     
    Burgersoft, Tesla5 and kwknott like this.
  15. consystor

    consystor Lurker

    Hello Shabbyenguin!

    You've written that we need two repos but I see only the one, you gave us.
    Which second repo do we need and how do we have to combine these two repos?
    And which dependency file do you mean?
    Could you also mention the tools/libraries etc. we need to build the image or do you have another source, we could read to get it built?
    That would be very nice!
     
  16. KnightAzul

    KnightAzul Lurker

    First and foremost, many thanks Shabbyenguin! This is great stuff.

    Like a few of the other users have commented here, I also don't see any GPS fixes either when using "High Accuracy" or "Device Only" mode.

    This is on an XT1039 with your CM11 build #6.

    I'm also very happy to do some testing, if there's any way that I can help.

    KnightAzul
     
  17. Shabbypenguin

    Shabbypenguin Extreme Android User
    Thread Starter

    the first one is in the OP :) its teh device tree and thats where the dependancies file is, you arent looking to combine the two at all.

    basic guide on cm stuff for the non-lte one here How To Build CyanogenMod Android for Motorola Moto G ("falcon") - CyanogenMod
     
    suhridkhan likes this.
  18. KnightAzul

    KnightAzul Lurker

    I have found a fix for the GPS issue! I don't take credit for it as I found it on another forum somewhere while trawling through loads of posts.

    You need to get a GPS fix in the stock ROM first and then install the CM ROM after.

    My "mistake" was going straight to the CM ROM without even starting the stock ROM.

    Hope this helps anyone.

    KnightAzul
     
  19. caribo

    caribo Newbie

    @KnightAzul Thanks for feeding back...

    I've seen this "fix" on other forums, but I must admit it sounds like a bit of hoodoo to me and I don't like to experiment without understanding what I am doing and why...

    Have you tried this? and can you confirm that it works? and if it does , do you know what causes it to work?

    ta
     
  20. KnightAzul

    KnightAzul Lurker

    I have tried it and confirm that it works perfectly! What I can't do is explain why this works. Sorry, I can't be of any more help. The GPS was a showstopper for me, so I took the plunge with little to lose.

    Changing the topic:

    >Apollo causes reboots and g play music has some lag issues but power amp works fine for music playback.

    Anyone noticed that playing MP3 music turns the player interface to treacle and slows it down considerably? I have tried with MX Player and ES File Explorer player. The latter performs better. Playing around it looks like something to do with a hardware decoding issue as software decoding performs much better in MX Player.

    KnightAzul
     
  21. caribo

    caribo Newbie

    @KnightAzul

    I'll be damned ! I was so desperate that I tried the "fix" and it did indeed work. Thanks for sharing your experience. I didn't investigate too much, but the gps.conf file looks to be different so maybe some more fundamental files got changed too..

    I'm using apollo .. it was a little laggy at first but after setting sound up in DSP it works perfectly.

    Hope that helps
     
  22. KnightAzul

    KnightAzul Lurker

    That's great news about your GPS! Where abouts is the gps.conf file? I'll take a look too.

    > I'm using apollo .. it was a little laggy at first but after setting sound up in DSP it works perfectly.

    Did you do specific settings in the DSP app to sort out the music. I actually removed the DSP app in my build try to create a leaner and meaner install. Perhaps time to put it back! My problem isn't actually the music playing poorly it's more that the player interface (MX Player, ES File Explorer, I removed Apollo) becomes very unresponsive.

    KnightAzul
     
  23. caribo

    caribo Newbie

    @KnightAzul

    Gps.conf is in /system/etc but only one of many GPS related files...

    With regard to DSP. I found that tunein would fc whenever it was launched and Apollo would launch and play music, but music controls didn't work. I couldn't pause playback for instance.

    After launching DSP selecting equaliser, both tunein and Apollo work flawlessly.. So something changed, but I don't know what!
     
  24. KnightAzul

    KnightAzul Lurker

    I had a play around with the DSP app after installing it again and it made no difference for me. Music player interface is still very unresponsive when playing music. Music plays ok though. Hope it doesn't drain the battery when playing (if the unresponsiveness is due to CPU spiking or something).

    KnightAzul
     
Loading...
Similar Threads - Unofficial AOSP Builds
  1. bcrichster
    Replies:
    3
    Views:
    4,870
  2. Alexenferman
    Replies:
    0
    Views:
    1,410
  3. Alexenferman
    Replies:
    0
    Views:
    1,844
  4. electimon
    Replies:
    6
    Views:
    5,852
  5. electimon
    Replies:
    0
    Views:
    4,585
  6. bcrichster
    Replies:
    8
    Views:
    8,911
  7. electimon
    Replies:
    1
    Views:
    5,072
  8. bcrichster
    Replies:
    31
    Views:
    12,317
  9. Cao Van Thanh
    Replies:
    0
    Views:
    536
  10. Alexenferman
    Replies:
    0
    Views:
    4,494

Share This Page

Loading...