1. Download our Official Android App: Forums for Android!

Root unrevoked breaks the camera on a new and old evo

Discussion in 'Android Devices' started by Aaron91RS, Apr 15, 2011.

  1. Aaron91RS

    Aaron91RS Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    67
    Joined:
    Mar 24, 2010

    Mar 24, 2010
    67
    5
    16
    Not quit what you're thinking. The camera works fine after a reboot. But close it and open it again and it just goes to a black screen or sometimes a screen where you can see the image on the screen but the red button doesn't actually respond. Also the flash button won't show up. Usually though it just blacks screens until you reboot. Then works fine the first time, then black screens.
    Definitly unrevoked.
    Had a day 1 EVO hboot .79 with Fresh rom since day 1. Worked perfect until I ran unrevoked 3.32 just last week. Then camera issues. Sprint store reset to stock and camera worked again. Ran unrevoked and camera is screwed again.
    So I got a brand new EVO with 2.10 hboot. Right out of the box. Ran unrevoked and installed fresh rom. Exact same thing. Camera works once and then black screen.
    How the heck do I fix this. It sounds like other people are having camera issues where the camera doesn't work at all but it works the first time after a reboot.
    Also other's talk about it only being newer phones but I tested it on a day 1 phone with the same results.

    You also get this pink and blue static right after you hit reboot in recovery before it reboots. I never got that with the old original way I rooted. Does it on both phones.
    Tells me unrevoked does something different then the other rooting method I used back in the day.
     

    Advertisement

  2. youdoofus

    youdoofus Android Expert
    Rank:
    None
    Points:
    213
    Posts:
    2,131
    Joined:
    Feb 26, 2011

    Feb 26, 2011
    2,131
    747
    213
    Tech support rep for Knology
    so dak
    wipe cache and dalvik cache.... i had cam issues when i went to CM7 (i know youre talking about a sense rom) but it couldnt hurt oh, and you might have a bad zip youre installing from. try another rom as well, see what happens, in any case make nandroid b/u's of your fully functioning roms
     
  3. Mr. Ed

    Mr. Ed Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    6,675
    Joined:
    Jun 27, 2010

    Jun 27, 2010
    6,675
    1,464
    313
    Phones
    Over Yonder
    Very odd indeed. I have rooted two dozen or so evos with no camera issues
     
  4. youdoofus

    youdoofus Android Expert
    Rank:
    None
    Points:
    213
    Posts:
    2,131
    Joined:
    Feb 26, 2011

    Feb 26, 2011
    2,131
    747
    213
    Tech support rep for Knology
    so dak
    maybe its your kernel...
     
  5. Aaron91RS

    Aaron91RS Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    67
    Joined:
    Mar 24, 2010

    Mar 24, 2010
    67
    5
    16
    oh i wiped everything a bunch with both recoverys and Calkulin's_FORMAT_ALL.
    nothing helped.

    Here's something interesting that might be a fix. I am literally testing as I type.
    Before even though I was rooted and could flash roms all day I had 's-on'
    unrevoked changes it to s-off.
    i went ahead and ran 'unrevoked-forever-son' to turn it back to s-on.
    We'll on next boot up instead of 720p the camera was set to low res with the black bars on the side. Now why would changing it back to s-on do this I don't know.
    Anyway changed it back to 720p and it seems not to be locking up ...yet.
    Like I said just did this.
     
  6. youdoofus

    youdoofus Android Expert
    Rank:
    None
    Points:
    213
    Posts:
    2,131
    Joined:
    Feb 26, 2011

    Feb 26, 2011
    2,131
    747
    213
    Tech support rep for Knology
    so dak
     
  7. Mr. Ed

    Mr. Ed Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    6,675
    Joined:
    Jun 27, 2010

    Jun 27, 2010
    6,675
    1,464
    313
    Phones
    Over Yonder
    Format all formats system....are you sure this issue isn't rom or kernel specific
     
  8. arnezie

    arnezie Newbie
    Rank:
    None
    Points:
    16
    Posts:
    24
    Joined:
    Jul 12, 2010

    Jul 12, 2010
    24
    2
    16
    Over 30 EVO's rooted with unrevoked zero issues.
     
  9. akazabam

    akazabam Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    4,418
    Joined:
    Jun 7, 2010

    Jun 7, 2010
    4,418
    1,387
    313
    Near Los Angeles
    So, this is with Fresh? From what I've gathered, it sounds like you're doing this on a custom ROM. Have you tried on the stock ROM? What about a different ROM? This sounds like an issue with some ROM/kernel combination.
     
  10. Aaron91RS

    Aaron91RS Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    67
    Joined:
    Mar 24, 2010

    Mar 24, 2010
    67
    5
    16
    i tried fresh and myn2.2.
    You have to understand I've used fresh and had a rooted phone since it came out which has worked perfect for almost a year.
    So possibly at best you could say the combination of fresh or myn2.2 plus unrevoked causes this, but the fact the other root from back in the day didn't cause any problems who do you point the finger at?
     
  11. youdoofus

    youdoofus Android Expert
    Rank:
    None
    Points:
    213
    Posts:
    2,131
    Joined:
    Feb 26, 2011

    Feb 26, 2011
    2,131
    747
    213
    Tech support rep for Knology
    so dak
    perhaps it a physical build / rom-kernel combo incompatability issue. How many kernels have you tried? and have you tried alternate roms since your OP?
     
  12. Aaron91RS

    Aaron91RS Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    67
    Joined:
    Mar 24, 2010

    Mar 24, 2010
    67
    5
    16
    always had the stock kernal with fresh.
    Just now tried 4.3.4 toastmod kernal. No change.
    Missed out being able to videotape the car being dyno'd this weekend due to this video camera being screwed up. :mad:
     
  13. midmadn

    midmadn Member
    Rank:
    None
    Points:
    18
    Posts:
    45
    Joined:
    Mar 18, 2011

    Mar 18, 2011
    45
    12
    18
    I wonder if it's the driver on the PC your using to run unrevoked?

    Was it on the same PC that this happened to all three phones?
     
Tags:

Share This Page

Loading...