1. Are you ready for the Galaxy S20? Here is everything we know so far!

Root Unroot if necessary, like iPhone iTunes restore?

Discussion in 'Android Devices' started by qcom, Feb 23, 2011.

  1. qcom

    qcom Well-Known Member
    Thread Starter

    I'm just a little nervous about rooting my Atrix, so I'm wondering if there's an option for "unrooting" to where there was no evidence of the previous root.

    Or, will there be permanent evidence?

    I'm just concerned only if for some reason my device fails (even not due to root) and I need to see support, and my warranty is now voided.

    Any ideas?

    Or, should I just sack up and do it? xD


  2. Deleted User

    Deleted User Guest

    Short answer yes.

    Long answer, when you run the app that roots your phone, you click the button that say "root" and it roots it. There is also a button to enable sideloading. There is also a button that says "unroot" that will return it to the way it was.

    Check out the video...it is quite easy.

    qcom likes this.
  3. projekt1

    projekt1 Newbie

    Will there still be evidence that it was rooted once its is unrooted?
  4. evilbastard

    evilbastard Well-Known Member

    I am guessing if you do a factory reset, it will overwrite everything, destroying evidence of root.
    qcom likes this.
  5. qcom

    qcom Well-Known Member
    Thread Starter

    Yeah, I'm actually in the process of doing this, just because my battery has been giving me some major trouble.. :(
  6. angelstoy

    angelstoy Lurker

    i rooted my atrix when i first bought it. set it all up and then had a problem where my sync icon wouldn't go away(after freezing/unfreezing some things with titanium backup).

    so i factory restored it, then tried to root again. it failed and i repeated the process. the second time worked.

    after, i noticed a lot of old files still on my phone but i continued to set it up. i installed titanium backup and after it said it failed to grant super user access.

    so here i am again restoring. i have high hopes that this will fix the issue.

    *UPDATE* i just noticed after i restored. before i rooted it. the app "Super User" was already install on my device and i'm unable to uninstall it with the default android task/app manager.

    so i'm going to try to uninstall everything i can. restart. then try to unroot with SuperOneClick. restart. check to see if Super User app is still installed. and try to root again.

    *UPDATE* i unrooted and it uninstalled Superuser.apk.
    i then restarted and rooted. and restarted again.
    it now works. no more problems with titanium backup and super user.

Share This Page