1. Check out our companion app, Forums for Android! Download from Google Play

Unrooting... Did I brick my phone...

Discussion in 'Android Devices' started by helpme, Jan 11, 2010.

  1. helpme

    helpme New Member
    Thread Starter
    5

    Jan 11, 2010
    2
    0
    5
    I tried unrooting my Motorola Droid, performed the steps in the instructions, but think that I may have mistyped the last flash_img command:

    I think I might have typed: flash_img /recovery boot.img

    instead of

    flash_img /boot /boot.img

    Now when I boot the phone it boots up but will not let me enter recovery mode. I get no service or other menu...

    Is there anything I can do?
     

    Advertisement

  2. Redflea

    Redflea Well-Known Member
    163

    Oct 6, 2009
    2,623
    289
    163
    Did you try redoing the command you messed up?

    flash_img /boot /boot.img
     
  3. helpme

    helpme New Member
    Thread Starter
    5

    Jan 11, 2010
    2
    0
    5
    Redflea,

    Thank you for responding... Here is the state of things so far:

    Apparently I over reacted because after a couple of reboots I had cell service, GPS etc, which was not the case when I made this post. However, I was unable to boot to either recovery screen (Triangle or Yellow android).

    I went back expecting not to be able to issue the commands again, figuring that the nandroid restore of virgin oem would have wipped out root, and that I would not be able to run the commands. To my surprise when I entered terminal and typed su, I still had root privledges. I entered both commands again, crossed fingers and restared the system and attempted entering recovery..... sweating and biting my nails... the yellow triangle finally appeared. So that is good.

    So now to the question that puzzels me, my phone still shows the root turtle, and seems to still have superuser permissions, only I am at native 2.01 instead of 2.01 without root privledges. This is not what I expected. Is my understanding of unrooting flawed? Can you help me understand what I am missing I used the steps listed below for unrooting:

    How To Unroot by Speeddymon from AllDroid
    1. Plug Droid into the computer and mount your sdcard
    2. Download AllDroid.org - Information and unzip it
    3. Download http://www.sholes.info/wp-content/uploads/2010/01/virginoem-backup.zip unzip it to your sdcard in the nandroid folder
    4. Copy boot.img and recovery.img from the droidbr.zip file to your sd
    5. Unmount
    6. Reboot into recovery> backup/restore> Advanced Nandroid Restore> Choose Backup> virginoem-backup> Perform restore
    7. Reboot
    8. Open terminal or an ADB shell
    *terminal app can be find in the Android Market
    9. Type in:
    su
    flash_image recovery /sdcard/recovery.img
    flash_image boot /sdcard/boot.img
    10. Reboot into recovery and you should see a triangle with ! in the middle
    *this means your back at stock
    11. Reboot and welcome back
     
  4. Redflea

    Redflea Well-Known Member
    163

    Oct 6, 2009
    2,623
    289
    163
    Glad to hear you're back, mostly. :)

    I've never tried those instructions, but if you followed them it looks like they should work.

    Sorry, I don't have any light to shed on what happened, hopefully someone else will drop in here and comment....
     
  5. baa269

    baa269 Well-Known Member
    36

    Jan 3, 2010
    165
    8
    36
  6. messenger13

    messenger13 Well-Known Member
    163

    Dec 8, 2009
    3,133
    381
    163
    Director of IT
    Cleveland, OH
    Sorry I missed this post, or I could've helped sooner. Sounds like everything is under control.

    Just a curious question though. What's with the erroneous spaces?

    flash_img<space>/boot<space>/boot.img ??? :thinking:
     

Share This Page

Loading...