1. Are you ready for the Galaxy S20? Here is everything we know so far!

Unrooting Phone

Discussion in 'Android Help' started by Android Question, Sep 21, 2014.

  1. Android Question

    Thread Starter

    Okay, I am an idiot who rooted my phone. I never made any changes to it. I did not have an external SD card, so I never backed up anything. My phone worked okay, cycling between the ShabbyPenguin interface and my phone OS.

    But now my charge went down to zero. I have been trying to charge it up but it is cycling between starting up in the phone OS and immediately crashing once it shows the home screen, and then going into the recovery setup. I figure if I can unroot it, it might boot properly and stay on and charge.

    I used motochopper with its adb to root it. Is there a way I can use this adb to with phone hooked up to PC to rid myself of the shabby penguin interface boot?

    Phone is Huawei Premia 4G
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    Are you the same person who posted here: http://androidforums.com/premia-4g-all-things-root/871261-phone-charging-problem.html? The descriptions of the problems seem very similar.

    Personally I doubt it's root that's the problem. Have you tried just pulling the battery out for a few minutes to make sure the silicon is fully discharged? Or the factory reset (though that obviously wipes all data from the phone). And indeed have you tried a different battery?

    I don't know this handset, but usually unrooting involves flashing a set of official software. I'd be wary of doing this until I knew the phone was stable in the mode used to do this, as it shutting down part way through would not be good.
     
  3. mavigozler

    mavigozler Lurker

    The problem is that the Huawei has some feature that when its battery charge is low and it is connected to a power source for charging it, it blinks a red light apparently until the charge is sufficient and then it starts the booting process. It can't be overridden or stopped to allow a charge to build up.

    The boot is cycling between the phone OS, which finished the bootupscreen, shows the phone user lock interface, and then powers out or crashes.

    The red light blinks again until power builds up, and then it boots up the recovery mode (ShabbyPenguin) interface, keeping the display on. Apparently this winds down the charge until that shuts down, and results in a blinking red light.

    The battery is never building up charge probably because of this continued cycling with the recovery mode display never being turned off. If I eliminate the recovery mode with its continually turned on display, I might see the battery build up sufficient charge.

    Even then, it appears that the phone OS is still crashing after its boot. Restoring the original ROM might fix that.

    But it seems I cannot restore it through the phone but rather a USB connection to the computer and using ADB. My problem is that I don't have either a script or command that will flash to original ROM. I am not even sure if the ROM stored somewhere to the internal SD by the rooting system.

    The phone battery is a new replacement only a few months old, so running out to buy another battery is not high on my list. I think I'd just rather buy a new cheap phone if I need to get service back. Thanks anyway
     
Loading...

Share This Page

Loading...