1. Are you ready for the Galaxy S20? Here is everything we know so far!
Thread Status:
Not open for further replies.

Updated: [08/31/2011] Inspire 4G, rooting - Windows/Linux/OSX

Discussion in 'Android Devices' started by Talderon, May 21, 2011.

  1. Talderon

    Talderon Android Expert
    Thread Starter



    odeh86, droidval, Miralcos and 9 others like this.

    1. Download the Forums for Android™ app!


      Download

       
  2. Talderon

    Talderon Android Expert
    Thread Starter

    **UPDATED 08/25/2011**​


    Quick guide on installing:[ROM]LeeDrOiD 4G V3.x.x GB | Official GB | TV Anim - xda-developers

    **ALL ADONS CAN BE DOWLOADED FROM THE LINK ABOVE**

    Gingerbread with Sense 3.0 and some extra's!!!

    Ok, download the following. Just put them on your SDCard. Since CWM will allow you to pick a folder to flash ZIPs from, put them all in a folder. Up to you.

    Download the following:

    REQUIRED/Suggested:
    • The latest ROM
    • Optional FULL WIPE to EXT4 patch (FTP) (for use on First time and Clean-Wipe flashes)
    • Convert DesireHD > Inspire 4G (FTP)

    NEEDED FOR UPDATES:
    EXT4 Cache & Dalvik cache cleaner (FTP) (this is used when upgrading the ROM)

    Completely Optional:

    Anything in the Sense 3.0 Addons! sections.

    Once these files are on your SD Card, then reboot into recovery and flash the files in this order:

    • Optional FULL WIPE to EXT4 patch (FTP) (If this is your first time flashing this ROM, this MUST BE FLASHED FIRST!)
    • The latest ROM
    • Convert DesireHD > Inspire 4G (FTP)

    OPTIONAL:

    • Sense 3.0 add-on of your choice
    • Custom Lock-Ring

    With Rosie and Without Rosie - Honestly, not sure since I always run the one with Rosie. Someone else should chime in here. :)

    Once done, reboot and set your stuff up again.

    Upgrading from previous version of LeeDroid:

    All you have to do is flash:

    • EXT4 Cache & Dalvik cache cleaner
    • The latest ROM
    • Convert DesireHD > Inspire 4G

    (Optional)

    • Sense 3.0 add-on of your choice
    • Custom Lock-Ring

    Enjoy!!

    Change Log:

    --Fixed link in step 5 (Thanks: MmmmBeeeeer)
    --Updated (See date at the top)
     
  3. neslot

    neslot Newbie

    Great Tutorial. Worked great the first time. I'm running Ubuntu linux 64 bit so needed something like this. I flashed the leedroid rom and now have "H" above the signal level bars (HSDPA) on ATT. my D/L speed is 5693kbps and up is 1258k.
    The only problem I have is only my son and grandson think this is cool, the rest say Hunh??
    :D
    thanks again!
    Tony
     
  4. Talderon

    Talderon Android Expert
    Thread Starter

    Glad it worked. I was happy to find a great package and as an added bonus, it gave those OSX and Linux users some lovin'!!

    Keep on going and let us know if you need help with anything! :D
     
  5. pricy333

    pricy333 Lurker

    hi,
    i just rooted my htc inspire with your instructions and now i cant use the internet on it. i really need it so please help me!
     
  6. shaboozies

    shaboozies Lurker

    I too have virtually no internet access after downloading this root. Just to make sure, I re-rooted and the problem is still prevalent. PLEASE help
     
  7. Talderon

    Talderon Android Expert
    Thread Starter

    Are you using the stock ROM that it flashed during this root process or have you flashed a custom ROM?

    If you are using the stock ROM that is flashed at the end of this process, I would suggest you try a new ROM. The one that is done at the end is there just to give you some basic functionality. If you want to stay with a stock ROM, there are plenty out there that are stock with root.

    Let me know the info. :)

    If you need help, let me know.
     
  8. telemore

    telemore Newbie

    I rooted my phone this morning with this and it was so easy! It took maybe half an hour (along with flashing CM7)

    Funny enough after having Sense I feel my phone is plain and boring haha. So I'm downloading a couple Sense roms and will see how they work.

    Great job!

    EDIT: I do feel I've spoken too early, CM7 is gorgeous... A lot of beautiful little touches that make it very nice to use.
     
  9. Nakhon7

    Nakhon7 Newbie

    Rooted last night using this method, and it worked well! It took a while to get everything downloaded and working correctly, but after that it went relatively fast. Thanks Talderon!

    I'd never rooted before, and am still pretty new to all of this, so getting a ROM was a bit trickier. I can see that there are tons of them over at XDA, but it is difficult to tell which are good, stable packages. I went with Android Revolution HD ([ROM] Android Revolution HD 5.1.10 | High Quality & Performance | OC | Sense/no-Sense - xda-developers). It seems good so far, although I don't like how the apps scroll a page at a time. Occasionally it seems laggy. The whole theme thing is a bit confusing - to load a new theme, do you have to re-flash your phone? Also, the authors of ARHD state "After every ROM update please check first, if the theme or mod you used to flash is still compatible with current ROM version." Is there a central site for ROMS, themes, etc where users can easily check these types of things? Right now it all seems pretty disorganized.
     
  10. MmmmBeeeeer

    MmmmBeeeeer Newbie

    Step 5 of your Lee rom instructions has a bad link.

    I'm going to do this soon, thanks for the guide.
     
    Talderon likes this.
  11. Talderon

    Talderon Android Expert
    Thread Starter

    Fixed! Thanks!

    To everyone else.

    Thanks for the response and feedback. I have used this method several times and works great.

    I do agree the preparation can take some time, but it is well worth it in the end with how easy it really is... Also, one of the main reasons I posted this is to give Linux and Mac users an option as well. Just nice that it works so well on PC... :D
     
    MmmmBeeeeer likes this.
  12. MmmmBeeeeer

    MmmmBeeeeer Newbie

    I ended up doing it last night, everything went well. Thanks for the guide
     
  13. somewhatstock

    somewhatstock Lurker

    Hi, I have a question.. What happens if I dont uninstall HTC Sync? Is it REQUIRED to perform the root? It a program that I want to keep.

    First. Prerequisites.

    1. Download HTC Sync and install it. It will install the drivers and get you all set up. Then, you can Uninstall HTC Sync, but do NOT uninstall the drivers.

    ***answered*** was able to root with htc sync installed and off
     
    SatelliteGuy likes this.
  14. MmmmBeeeeer

    MmmmBeeeeer Newbie

    I didn't uninstall, I just made sure it wasn't running. Everything was fine.
     
    somewhatstock likes this.
  15. mburch9595

    mburch9595 Lurker

    this all sounds really cool but i have one big question.... What is rooting?

    sry for my noobiness
     
  16. ajm4481

    ajm4481 Lurker

    hi, i am unable to get the link on part 4 to work
    4. This one greatly improves the I/O performance of the phone: http://leedroid.ftp.rshost.eu/DHD-Addons/GB_IO_Performance_Patch.zip

     
  17. ajm4481

    ajm4481 Lurker

    hi it is actually 3 links. 4 5 and 6 that i can not get to download in the above post
     
  18. NikNik0418

    NikNik0418 Lurker

    Hi,
    I have done everything that the "effin-manual" has told me to do. Its not working from the start... I run hack as administrator and the black window pops up and disappears in a flash...so I'm thinking its running in the background or something but I get to the step with the CID and it says that the little administrator step is supposed to get that for me...and something about a goldkey--goldcard? (IDK)

    I'm really good at following directions especially when it comes to cell phones. This is making me feel really stupid. is there an easier way or Better directions?

    Thanks to anyone who can help me.

    Nikki--HTC Inspire 4G since March 2011
     
  19. Talderon

    Talderon Android Expert
    Thread Starter

    Just go here and look in the first 2 posts for the most current links. :)
     
  20. Talderon

    Talderon Android Expert
    Thread Starter

    If you are stuck here:

    Windows: Right Click on the hack-ace.cmd and Run as Administrator. Failing to perform this step will cause this process to fail!

    Then another way is to open a command prompt as administrator and browse to the folder you have the files in and run the hack-ace.cmd.

    Start > All Programs > Accessories > SHIFT+RIGHT CLICK on Command Prompt icon and click Run As Administrator.

    I have run this on dozens of Inspires as well as running it from multiple computers. I hope this helps. PM me if not.

    Thanks,
     
  21. iDrOid3.0

    iDrOid3.0 Lurker

    Running non-intel mac OS 10.5.8. Trying to root Inspire 4g. It mounts in hard drive mode but its not detected in charge only mode with usb debugging checked. I ran "diskutil list" and its not listed there. So I'm thinking that is the reason why hack-ace.sh (I am using hack kit v11a) script fails to detect the phone. The original thread mentioned that there are usb drivers for Linux/Mac OS systems. Are they part of HTC Sync? If so, isn't HTC Sync just for Windows? Where does MAC users get the drivers from? It's funny how difficult this is becoming when both the phone and the comp is running Linux under the hood. Any suggestions will be greatly appreciated.

    I do however can get the CID for my mmc0 using goldcard helper. Can I proceed ahead to completing the rooting process by simply finish making the goldcard? Or will I need the scripts?
     
  22. woodstorm

    woodstorm Android Enthusiast

    Just wanted to say thanks for the great tutorial. Was able to get a friend rooted and ROMed over the phone. Having some issues with his market but XDA should have an answer.

    It wound up being my fault. Fixed and running. Thanks again.
     
  23. Ghostsarmy

    Ghostsarmy Lurker

    I Changed this Please help with the custom Rom part of this
     
  24. Ghostsarmy

    Ghostsarmy Lurker

    Sorry I'm reading a lot of info andim figuring it out I think. A little more detail on the custom Rom would be appreciated :)
     
  25. Ghostsarmy

    Ghostsarmy Lurker

    okay im getting rather frustrated, ive tried rooting the phone following the steps above i get the cid #get the gold card put it in the gcimg folder press 2 it reboots i dont have to go through setup then onto step 3 i for 1 dont understand the (type exit and enter at the # prompt) 2 once i go through step 3 my phone turns off and all of a sudden my phone stays black only with a picture of a phone with a red triangle and exclamation mark i dont know what im doing wrong. please help??

    EDIT: this is the part when running number 3 it gets to before the phone does its thing

    "please wait booting recovery to patch downgrade romroot/sound/locale
    ECHO is off please wait"
     
Loading...
Similar Threads - Updated 2011 Inspire
  1. Losing My Religions
    Replies:
    3
    Views:
    407
  2. 20GT
    Replies:
    7
    Views:
    511
  3. ironass
    Replies:
    12
    Views:
    724
  4. Jelyob
    Replies:
    12
    Views:
    822
  5. luhazi
    Replies:
    4
    Views:
    658
  6. Thamaraikannan S
    Replies:
    8
    Views:
    555
  7. hannan012
    Replies:
    3
    Views:
    934
  8. Ron Miel
    Replies:
    13
    Views:
    757
  9. gr3g0ree
    Replies:
    6
    Views:
    798
  10. Woodsboom
    Replies:
    2
    Views:
    713

Share This Page

Loading...