1. Download our Official Android App: Forums for Android!

Root Updating a rooted/unbranded phone to Eclair

Discussion in 'Android Devices' started by saywot, Dec 9, 2010.

  1. saywot

    saywot Lurker
    Thread Starter

    Dec 8, 2010
    I'm at my wits end and the XDA forum is keeping it's collective wisdom to itself (well it hasn't replied to any of my questions in the last 3 -4 days so I thought I'd try here.

    I was the happy owner of an X10 Mini Pro, now I'm less happy and getting unhappier by the day.

    SE has said to me " be patient, when your carrier/network has approved the upgrade it will be made available to you" I think that since my carrier is Australia's largest mobile phone network and every other man (and his dog) has upgraded to Android 2.1 I'm going to have to take steps of my own.

    And perhaps I have shot myself in the foot by being impatient, but hells bells this roll-out has proceeded at snails pace and being December I shouldn't be waiting for an OS that was being delivered at the end of October.

    Anyway I have root privileges and have de-branded the phone, there isn't a carrier's splash screen, it's Vanilla Sony, I've dumped Facebook and some other useless apps.

    Following the instructions from the XDA forums
    GUIDE: Mini Pro (U20) change to any firmware (generic\debrand) - xda-developers

    I downloaded a copy of the generic UK U20i build.prop file and edited it - I'm hoping to have my edit corrected here, because as far as that discussion thread goes once this file is copied over to /system/ the SEUS will do all the hard yards

    so the edit was to change line #3 from ...


    to ....



    I changed line #13

    from ....


    to ...



    line #8

    from ....



    (you can see what I've done, wherever U20i_1238-0199 appears in the build.prop file I replaced with U20a_1238-9150)

    I sourced the info for the file edit from here
    The U20a info thread. - xda-developers

    I used the numbers from the Telstra AU/Black

    I first had a go using the string of numbers following the letters CDF
    - that is "1239-5023"

    It didn't work, I did the edit of the file on a PC copied it to the SD card then used Root Explorer to overwrite the existing file., shut down, re-started and installed the latest version of SEUS onto the PC

    I followed the instructions from Sony Ericsson to update (you know turn the phone off, wait 30 seconds and connect to the PC while holdong down the 'back' button) and SEUS says I have the latest software. - I swear I don't, I'm running 1.6

    Tried a repair with PCC - same answer

    so I re-edited and used the numbers AFTER the CDF string

    same response

    So now that I'm at my wits end and getting desperate for 2.1 before everyone else in the world is running 2.3

    What else do I have to edit in order for either SEUS or PCC to update me to Eclair

    The software info screen has some interesting inconsistencies

    Um, it reports

    phone software version


    File System Version

    Boot Version

    xxxx-xxxx R8A029

    Customisation Version


    all the xxxx-xxxx are different numbers and the only thing I can see here that I have done is the '1238-9150_R1A'

    anyway if anyone needs any further info that might help me get the upgrade don't be shy.


  2. saywot

    saywot Lurker
    Thread Starter

    Dec 8, 2010

    OK I cracked a fruity, since there hasn't been a single response from either this forum (or that other one) I decided to just dump the generic UK U20i build.prop file into the system directory and overwrote whatever I had there (the older one was saved as build.prop.bak)

    This still didn't get me any software updates from SEUS - if that's what Sony is calling the next Operating System.

    So apart from copying and pasting the whole build.prop file I want to use and asking what EXACTLY needs to be changed.

    I have a question or two
    -- "VFE-1-8 1.1.A.0.8" how can I get it changed to 'World 1-2-5 ?

    -- and no matter what I do to the customisation version using an edit or two of /system/build.prop the software version stays the same and this is why I think I keep getting a "No New Software For Your Phone - try again later" from both SEUS and PCC

    and the Model Info always reports U20a

    as always any help or suggestions will be gratefully received
  3. saywot

    saywot Lurker
    Thread Starter

    Dec 8, 2010
    I've tried everything, used god-knows-how-many versions of build.prop and gotten nowhere - nowhere I wanted to go anyways (which was to get Android 2.1 installed)

    Now I have the damned thing reporting to me that it's running low on space. The Sony forum says to simply do a repair using PC Companion.

    Sadly for me, no matter how many times I install/un-install/re-install the Sony software it always reports that "there is no new software for your phone' or 'you phone is up-to-date'

    Which is an odd message when taking the PCC 'repair option'

    I don't want an update or an upgrade - I want a repair

    (SEUS seems to have lost the repair option it once had)

    I probably should ask this question in a new thread, but considering the spectacular success and the many kind and helpful hints/tips/suggestions this current discussion thread has provided me I may stick it here whilst I'm on a roll

    so here goes

    If PC Companion and SEUS are unable to repair this phone what other options are available to me ?

    I'm not quite ready for the paid-for omnius route yet, but it has to be getting close
  4. ShiKaiSheng

    ShiKaiSheng Member

    Dec 7, 2010
    Real Time Analyst
    Manila, Philippines
    i had that problem before. what i did was to download the phone updater from the sony ericsson website, installed it in my notebook, connected my MP to the notebook and instructed me to switch my MP off etc. Update successful. For some reason, pc companion was not able to find the update that the phone updater found. hhmmm....

Share This Page