1. Are you ready for the Galaxy S20? Here is everything we know so far!

Upgraded 2.3.5 now no Data connection on O2

Discussion in 'Android Devices' started by davidK4, Dec 21, 2011.

  1. davidK4

    davidK4 Lurker
    Thread Starter

    Hello,

    Upgraded to 2.3.5 yesterday evening on my HTC Desire HD noticed this morning that my data connection wouldn't work.

    Tried powering off/on, no joy...
    Tried a restart, no joy...
    Tried shutting down removing both battery and sim, no joy...

    In the end to resolve I ended up going into

    Press the Menu key
    Tap Settings
    Tap Wireless & networks
    Tap Mobile networks
    Tap Access Point Names
    (This was all empty which it shouldn't be really)
    Press the Menu key
    Tap New APN

    I then pressed backup key and it said must input name so I pressed home key went into same options again and all the settings appeared!

    Now working yey :)
     



    1. Download the Forums for Android™ app!


      Download

       
  2. El Presidente

    El Presidente Beware The Milky Pirate!
    VIP Member

    Thanks David, it seems to be one of the quirks of the new 2.3.5 upgrade unfortunately. As more folk get the update, I'm sure more issues will surface. :rolleyes:

    Thanks for joining and sharing your solution. :)
     
  3. clio197

    clio197 Newbie

    Thanks for the solution davidK4. I had the exact same issue with mine on O2, which is now resolved :D
     
  4. Spooks

    Spooks Lurker

    Thanks David, worked for me too! - I'm also on O2, was wondering if they were the only provider with the issue!
     
  5. lucids

    lucids Well-Known Member

    I had exactly the same thing. I have a generic DHD but on o2 contract, and had no data connection. I was going crazy trying to figure this out.

    I solved it by putting in a pay and go sim and there was data, and when i put my sim back in the data worked again.
     
  6. arthurjach

    arthurjach Lurker

    It's not only O2 - I'm with T-mobile and had the same problem with my Desire HD.

    After going to APN settings it showed two access points ('general.t-mobile.uk' and 'goto.virginmobile.uk') but none of them was selected. As soon as I saw it the system automatically enabled the t-mobile one and all is fine again... weird, but all is now working.
     
  7. partsguy

    partsguy Lurker

    Yep me too. I'm on O2 with an HTC Desire S. Thanks for the fix. I'd never have working it out on my own
     
  8. BigJimBob69

    BigJimBob69 Lurker

    I have updated my desire hd and now I do not get a network signal and I have tried the above but each time I go back the field is still blank, (Help)
     
  9. El Presidente

    El Presidente Beware The Milky Pirate!
    VIP Member

    What network are you on? You may need to enter the APN settings again manually?

    When you're in the APN section and you press menu, do you see a reset to default option?
     
  10. Groundforce2

    Groundforce2 Lurker

    Brilliant advice if u are having issues like I did after upgrading! Big thanks to David!
     

HTC Desire HD Forum

The HTC Desire HD release date was October 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 768GB RAM, Snapdragon S2 processor, and 1230mAh battery.

October 2010
Release Date
0
Reviews
Loading...

Share This Page

Loading...