1. Download our Official Android App: Forums for Android!

Support Upgraded to 2.1 and now GPS doesn't work at all?

Discussion in 'Android Devices' started by warbux, Aug 6, 2010.

  1. warbux

    warbux Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    50
    Joined:
    Aug 6, 2010

    Aug 6, 2010
    50
    5
    16
    So, I was running the leaked 2.1 for a while (which worked perfectly except for youtube fwiw) and finally decided last week to upgrade to the official 2.1 release. Youtube runs smoothly now and my performance seems slightly faster, but my GPS does not work at ALL.

    Neither Sprint nor Google Navigation works. I tried turning off the "Use wireless networks" setting and it didn't help at all. Anybody else having this problem? Is there any way to fix this? Am I going to need to re-install my OS? Do I need a replacement phone?

    Any help would be appreciated.
     

    Advertisement

  2. pastafarian

    pastafarian Pâtes avec votre foie
    Rank:
    None
    Points:
    623
    Posts:
    5,622
    Joined:
    Nov 4, 2009

    Nov 4, 2009
    5,622
    4,625
    623
    Sales
    The Sea of Tranquility
    The gps reciever in this phone is one of its bigest weak points. I had the gps stop functioning back in early December (1.5 pre cl14) and had the unit swapped out. My current Moment is showing the same gps flakyness. Sometimes it's there, sometimes it's not. The only reason I haven't swapped it out is that this phone doesn't suffer badly from cdma lockup. Having experienced Sprints refurb's before, I don't want to swap my bad gps for a refurb that locks up and I don't want a Hero or a Intercept at all. I've given up on the gps function of the phone, even if it works consistently, its reception is weak enough to make it an unreliable navigator. I've played with a least 10 other Moments and all had similar weak gps reception. I's a design choice, not a part failure. Seeing that there are similar gps complaints about all the Galaxy S models already released makes me even less enthusiastic about the Epic.

    I don't know of any issue in the stock 2.1 that causes the gps to stop working. There are a few people that claim the gps performed better under 1.5, but I'm not so sure. You could try re flashing to see if that corrects things, or root and try an alternate rom? Mainly, I suspect it's a hardware problem that you might want to visit a Sprint repair center about. Good luck!
     
  3. Stoney62

    Stoney62 Android Enthusiast
    Rank:
    None
    Points:
    68
    Posts:
    512
    Joined:
    Nov 8, 2009

    Nov 8, 2009
    512
    38
    68
    Lately I've been running GPS Test first-- lock on to a bunch of satellites quickly then run Google Maps. Almost instantaneous My location
     
  4. SoulTerror

    SoulTerror Android Enthusiast
    Rank:
    None
    Points:
    88
    Posts:
    724
    Joined:
    Feb 18, 2010

    Feb 18, 2010
    724
    48
    88
    Male
    Help Desk Manager
    North Carolina
    I just had my Moment replaced due to the GPS not working at all. 2 phones later and I have the best Moment that me or my wife have had. Great battery life, quick booting. These phones are so hit and miss it's sad.
     
  5. warbux

    warbux Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    50
    Joined:
    Aug 6, 2010

    Aug 6, 2010
    50
    5
    16
    Do I need to sign up for "Total Equipment Protection" before I go to Sprint with this problem?
     
  6. SoulTerror

    SoulTerror Android Enthusiast
    Rank:
    None
    Points:
    88
    Posts:
    724
    Joined:
    Feb 18, 2010

    Feb 18, 2010
    724
    48
    88
    Male
    Help Desk Manager
    North Carolina
    No, the insurance is only if you caused damage to the phone.
     
  7. warbux

    warbux Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    50
    Joined:
    Aug 6, 2010

    Aug 6, 2010
    50
    5
    16
    I called Tech Support and they're sending me a new phone, should be here tomorrow. If anybody cares.
     

Samsung Moment

The Samsung Moment was one of the first Android Phones with a slideout keyboard.

Share This Page

Loading...