1. Are you ready for the Galaxy S20? Here is everything we know so far!

Upgraded to Jelly Bean and now I can't open settings

Discussion in 'Android Devices' started by LoganX, Jul 24, 2012.

  1. LoganX

    LoganX Lurker
    Thread Starter

    So today, I upgraded my Nexus S from ICS to Jelly Bean which I installed from the updates my phone received but then after it had upgraded, my power control widget wouldn't work and I was not able to go into my setting app. Whenever I try to click it, it gives me the error message "Unfortunately, Settings has stopped" and closes instantly. I can't factory reset it from the setting menu so I tried to factory reset it using the "Hard" method that was holding the volume up and power > Recovery way. After I had done that, it did reset my phone to as if i just taken it out of a brand new box but I still had the Jelly Bean and both my settings and power control still didn't work. How do I fix this?

    1. Download the Forums for Android™ app!


  2. LoganX

    LoganX Lurker
    Thread Starter

    I just went through my phone testing all the apps and widgets and realized that it was only the settings app, which also were in the power control widget, that wasn't working after the update. I have no idea how to flash, unlock, or do any thing on a android phone but I am a very fast learner. I'd appreciate it if someone could run me through step by step on how I can regain access to my settings. Thanks
  3. Deleted User

    Deleted User Guest

    First off, exactly which widget are you using, the power control widget that is included with Jelly Bean and ICS? Or an app/widget you downloaded?

    Exactly what is the model you're trying to flash I9020a, I9020t, I9023?

    If it's the included power control, then it may have been a bad flash (mine works just fine but Beautiful Widgets gets nuked when I power off my phone - todays update didn't fix that, but it fixed the toggle widgets).

    I'd go into recovery, wipe data/cache, then reset and see again. If it still fails, you will need to find a full ROM online for Jelly Bean, rename it to "update.zip" and reflash from the Recovery menu. I haven't seen a full ROM yet, but it should be available soon. You might have to forget about the power control widget if you can't fix it with a wipe and reset, at least until a full ROM is available.
  4. LoganX

    LoganX Lurker
    Thread Starter

    To answer your first question, it is the power control widget that came with the ICS i believe. Since I got this phone off someone, so i'm not sure if it was already flashed to ICS or if it was Gingerbread before. All I know is that the person factory resetted the phone from settings and it was ICS.

    As for the model, its GT-i19020a. I'm not sure how I could have had a bad flash since the update I downloaded and installed was straight off from a update on the phone. I tried rebooting my phone to see if it would go away but it didn't.

    I have already gone into recovery, wiped data/cache, and restarted the phone and no luck. It remains in JB along with the settings problem. I am a complete noob with android phones currently so I may need some help. I'll try to find a ROM for JB.
  5. LoganX

    LoganX Lurker
    Thread Starter

    where might I find the ROM by the way? I'm having no luck at finding them.
  6. LoganX

    LoganX Lurker
    Thread Starter

    I found one but every time I go into recovery to update it I get:
    -- Install /sdcard ...
    Finding update package...
    Opening update package...
    Verifying update package...
    Installation aborted.
  7. LoganX

    LoganX Lurker
    Thread Starter

    After many hours searching through multiple forums, I managed to solve the problem. Thanks for the help bfksc.
  8. quantumrand

    quantumrand Android Expert

    Glad to hear you were able to fix it. Care to share what you did in case anyone runs into the same problem in the future?
  9. Deleted User

    Deleted User Guest

    Yeah, let us know what the fix was for your issue, so we can help others!

Nexus S Forum

The Nexus S release date was December 2010. Features and Specs include a 4.0" inch screen, 5MP camera, 512GB RAM, Hummingbird processor, and 1500mAh battery.

December 2010
Release Date

Share This Page