1. Are you ready for the Galaxy S20? Here is everything we know so far!

Upload phone contacts/calendar to google account. OOPS MESSED UP, but now solved.

Discussion in 'Android Devices' started by Hawker, Sep 9, 2011.

  1. Hawker

    Hawker Android Expert
    Thread Starter

    Can this be done?

    I can see the merits of keeping all this information in the central google gmail account, but I only created this account due to buying my GS2, and I was stuck in my ways, so I created all contacts/birthdays/calendar events in the phone itself.

    Can everything I've entered be uploaded into my google gmail contacts and calendar?
    I've seen an export function in contacts that creates a .vcf file, but google only allows imports of .csv files.

    What setup do you all use? centrally with google, or phone, or a mix of the 2?


  2. ironass

    ironass Extreme Android User

    Here you go hawker!

    "The Complete Guide to Fixing Google Contacts"

    See here:-

    The Complete Guide to Fixing Google Contacts

    Alternatively there is this thread by RazzMaTazz on the subject:-


    Personally, I sync my on-line Google (Contacts, Calendar and Tasks) to SGSII , MyPhoneExplorer and Office Outlook. See thread here:-


    Should keep you out of mischief for awhile. :D
    Hawker likes this.
  3. Hawker

    Hawker Android Expert
    Thread Starter

    Cheers butty! It most certainly will...
    Hope I can get my calendar and contact's birthday coming through into the calendar app too, as I've had lots of bother with this in the past!
  4. Hawker

    Hawker Android Expert
    Thread Starter

    HELP! I've now managed to lose all my calendar events and accounts!

    Everything seemed to be going well. I added all my contacts/birthdays/events in the google account.
    Synched, and set the display options in the calendar to show google stuff.
    All my events came through except the contact's birthdays, even tho the option was checked in calendar>menu>settings>calendars
    So I went into apps settings and cleared out calendar storage, as I did this a few weeks back to get holidays show.
    Now when I go into calendar>menu>settings>calendars I no longer have ANY of the google calendars there to check, only My Calendar. I've re-synched the account in settings>accounts and sync but no joy.

    How do I get my google calendars re-appear in the calendar apps list of calendars please!
  5. ironass

    ironass Extreme Android User

    I have to say, sync'ing between Google > SGSII > MyPhoneExplorer(MPE) > Office Outlook was, for me, confusing initially.

    Google contacts, SGSII and MPE do not contain all the fields that Outlook has.

    In the end I imported my contacts and calendar to Google and went through each contact individually and placed their birthday, manually, into each contact. This then showed up in Google Calendar, SGSII, MPE and Outlook.

    From my own experience, novice, it paid to pick a starting point for everything and then get the rest to sync with it. Google seemed to be the most logical and so I turned phone sync off and configured everything down the line to work with that.

    Once I had Google sorted I used Delete Contacts, free from the Market, to get rid of everything on my phone contacts and then sync'd with Google. Once that was done I then connected to MPE and "forced" sync'd my phone to it for Contacts and Calendar.

    When that was done I then "force" sync'd MPE to Office Outlook and once that was done I then set MPE settings to "sync both ways" so that I can now change anything in Google on-line, SGSII, MPE or Office Outlook and it will change the others.

    I am not saying for one instance that mine is the correct or easiest way of doing things but after days and weeks of frustration, it works for me.

    Good luck hawker!
  6. Hawker

    Hawker Android Expert
    Thread Starter

    Thanks again ironass for all your help mate.

    Well I tried everything to no avail. Synching, reseting, clearing app data, rebooting.
    Still I could only get "My Calendar" in the list of calendars.

    I downloaded Business Calendar free version. This magically restored the list of calendars, so I am no back up and running again.

    I now have 4 calendars,
    1. My Calendar (unticked)
    2. gmail address (ticked)
    3. contacts birthdays (ticked)
    4. uk holidays (ticked)

    All are coming through as expected

    If I go to create a new event on the phone it pops up with:
    Local calendar cannot sync with Google Calendar. You need a Google Account
    Go to account and sync

    Seems strange as to why does it ask this, when my calendar app is only set for non-local calendars?

    I now have all my contacts on my gmail google account. One thing I have noticed, is that one of my contacts (a hotel in blackpool) automatically came up with a contact photo, which also synced onto my phone. How does this happen? Is it picked up off their email address perhaps?

    Now my contacts are all google contacts, scarily, there is a complete history of all SMS messages sent to each and every contact (first line or so at least) even tho I regularly delete my messages. I discussed this a few weeks back in this thread

    That Business Calendar app has turned out to be very handy, as I added a new calendar in google, and surprise surprise, it didnt show up in the calendar app's list of calendars, but it did in Business Calendar, and when you go back into the stock calendar app the new calendar appears. I'll keep this app just in case.

Share This Page