1. Download our Official Android App: Forums for Android!

Support Uploading big file to internal SD problem

Discussion in 'Android Devices' started by InfernalH, Mar 10, 2010.

  1. InfernalH

    InfernalH Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    15
    Joined:
    Feb 25, 2010

    Feb 25, 2010
    15
    0
    15
    Rails developer
    Lithuania
    Hello,

    I have one issue with my Galaxy - I can't upload big files. It just drops a USB connection. For example I'm trying to upload something like 100-200MB file and it just drops and reconnects in a few minutes without uploading it correctly.

    Currently I'm using linux, but it has the very same issue on windows (tried that already)

    Any ideas? I have usb debugging on, tried without it but no difference

    P.S.: this issue occured in 1.5 and 1.6, just annoyed me enough to start looking for a solution...
     

    Advertisement

  2. Mr.DNA

    Mr.DNA Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    124
    Joined:
    Jul 29, 2009

    Jul 29, 2009
    124
    3
    36
    I have observed this problem as well (also using linux) when attempting to transfer large wav files. Although the transfers are successful sometimes, it usually drops the usb connection as you described.

    The only workaround I have found is to pull out the external sd card and transfer the files directly to that. If you then want them on the internal sd, you might have better luck transferring from one card to another within the phone (thus bypassing the usb connection to pc).
     
  3. InfernalH

    InfernalH Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    15
    Joined:
    Feb 25, 2010

    Feb 25, 2010
    15
    0
    15
    Rails developer
    Lithuania
    I don't have external SD card yet so this workaround won't work for me... Anyway thank you for the tip, maybe it will save few hours for anyone else

    Any other ideas how to fix/workaround this issue?
     
  4. KlaymenDK

    KlaymenDK Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,217
    Joined:
    May 29, 2009

    May 29, 2009
    1,217
    130
    143
    Denmark
    Hmm, I've had no such problems. I even used my phone to move a huge DVD iso between computers without a problem.
    FYI, that was on the K4 firmware, if it matters.
     
  5. InfernalH

    InfernalH Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    15
    Joined:
    Feb 25, 2010

    Feb 25, 2010
    15
    0
    15
    Rails developer
    Lithuania
    Well, never had K4 firmware :)
     
  6. Bomberman

    Bomberman Android Enthusiast
    Rank:
    None
    Points:
    38
    Posts:
    342
    Joined:
    Sep 3, 2009

    Try a different PC. I get this on my desktop (it is Win7 though :p) but my XP laptop is fine.
     
  7. InfernalH

    InfernalH Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    15
    Joined:
    Feb 25, 2010

    Feb 25, 2010
    15
    0
    15
    Rails developer
    Lithuania
    Tried that on my PC and Laptop - it's the same. Will try on the 3rd :) Maybe my USB cable is causing this?
     
  8. Bomberman

    Bomberman Android Enthusiast
    Rank:
    None
    Points:
    38
    Posts:
    342
    Joined:
    Sep 3, 2009

    Hmm. Dont use a USB extender/Hub and see if that helps? I do recall reports of 3rd party cables being iffy, is it the original?
     
  9. damuffinman

    damuffinman Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    203
    Joined:
    Aug 9, 2009

    That's hardly a solution, you're just avoiding the problem :p

    Perhaps it's a Driver issue?
     
  10. Bomberman

    Bomberman Android Enthusiast
    Rank:
    None
    Points:
    38
    Posts:
    342
    Joined:
    Sep 3, 2009

    It's a Samsung Galaxy, you kind of have to get used to that :D
     
  11. InfernalH

    InfernalH Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    15
    Joined:
    Feb 25, 2010

    Feb 25, 2010
    15
    0
    15
    Rails developer
    Lithuania
    Bomberman, it's the original :(

    damuffinman, I guess it's not driver because the same problem occurs on windows and two different versions of Linux. I guess they don't use the same drivers :)
     
  12. mrqs

    mrqs Android Expert
    Rank:
    None
    Points:
    128
    Posts:
    1,446
    Joined:
    Sep 28, 2009

    transfer via wifi instead? slower i know, but if it works...
     
  13. InfernalH

    InfernalH Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    15
    Joined:
    Feb 25, 2010

    Feb 25, 2010
    15
    0
    15
    Rails developer
    Lithuania
    Yeah, doing that almost all the time when this bug appears :)
     
  14. mrqs

    mrqs Android Expert
    Rank:
    None
    Points:
    128
    Posts:
    1,446
    Joined:
    Sep 28, 2009

    i actually rather transfer stuff via wifi because the ringtones always get messed up after mounting the sd
     
  15. InfernalH

    InfernalH Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    15
    Joined:
    Feb 25, 2010

    Feb 25, 2010
    15
    0
    15
    Rails developer
    Lithuania
    Well, at the moment I need to transfer ~2gb file and usual download crashes bacause of some reason
     
  16. Bomberman

    Bomberman Android Enthusiast
    Rank:
    None
    Points:
    38
    Posts:
    342
    Joined:
    Sep 3, 2009

    Goddam that's sooo annoying :mad:
     
  17. Cougar

    Cougar Android Enthusiast
    Rank:
     #577
    Points:
    38
    Posts:
    420
    Joined:
    Aug 28, 2009

    Aug 28, 2009
    420
    16
    38
    Geek
    Lancashire, England
    Are you using a cable direct to the PC, or a poxy USB hub? I've seen issues (not with the phone but with USB generally) when running through a cheap hub that go away when you connect directly.
     
  18. mrqs

    mrqs Android Expert
    Rank:
    None
    Points:
    128
    Posts:
    1,446
    Joined:
    Sep 28, 2009

    [​IMG]
     
  19. Cougar

    Cougar Android Enthusiast
    Rank:
     #577
    Points:
    38
    Posts:
    420
    Joined:
    Aug 28, 2009

    Aug 28, 2009
    420
    16
    38
    Geek
    Lancashire, England
    Note to self: don't post on forums before you've had any coffee of a morning.
     
  20. Cougar

    Cougar Android Enthusiast
    Rank:
     #577
    Points:
    38
    Posts:
    420
    Joined:
    Aug 28, 2009

    Aug 28, 2009
    420
    16
    38
    Geek
    Lancashire, England
    Ok then; how about trying it using EStrong's File Manager, pulling the files over WiFi rather than USB, or pushing them using an Android FTP server perhaps?
     
  21. mrqs

    mrqs Android Expert
    Rank:
    None
    Points:
    128
    Posts:
    1,446
    Joined:
    Sep 28, 2009

    [​IMG]
     
  22. Cougar

    Cougar Android Enthusiast
    Rank:
     #577
    Points:
    38
    Posts:
    420
    Joined:
    Aug 28, 2009

    Aug 28, 2009
    420
    16
    38
    Geek
    Lancashire, England
  23. zaniku1

    zaniku1 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    9
    Joined:
    Dec 7, 2009

    Dec 7, 2009
    9
    0
    5
    Bangkok
    I have transferred 1.47 G file without problem

    Note: 1.6 with Galaxo 1.6.1 and Win7
     

Share This Page

Loading...