1. Download our Official Android App: Forums for Android!

Support Uploading photos to gallery

Discussion in 'Android Devices' started by sid52, Aug 14, 2011.

  1. sid52

    sid52 Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    43
    Joined:
    Mar 30, 2010

    Mar 30, 2010
    43
    1
    36
    I think this problem ocurred after the 3.2 update. When the photos are viewed in the gallery album they are in random order and bear no resemblance to the order in which they were taken. The problem seems to be that each batch of photos all receive the upload date and time, which is the same, rather than the date that is in the camera exif file.
    I'm sure this wasn't a problem prior to the update.

    Any ideas of how to reinstate the correct order, and to view the correct date in the exif file?

    Thanks
    Sid
     

    Advertisement

  2. chimphappyhour

    chimphappyhour Android Enthusiast
    Rank:
    None
    Points:
    78
    Posts:
    545
    Joined:
    Jun 5, 2010

    Jun 5, 2010
    545
    87
    78
    KCMO
    Where are you uploading these photos from? I assume you mean you're loading them to your tablet?
     
  3. sid52

    sid52 Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    43
    Joined:
    Mar 30, 2010

    Mar 30, 2010
    43
    1
    36
    Yes, I'm uploading directly from a Canon 400D using the USB cable to an Asus Transformer. When they have been saved, the photos are in random order, not in the order in which they were taken.

    When I select the i button to look at an individual photo's details, eg shutter speed, aperture etc, I notice that the date and time are that of the upload, not when the photo was taken. Each upload batch all have identical date/time details, hence sorting by date has no effect.

    I can't see an option to sort by file number, which would be a solution.

    Thanks
    Sid
     
  4. bfksc

    bfksc Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,262
    Joined:
    Aug 29, 2010

    Aug 29, 2010
    1,262
    201
    143
    Canada
    I don't see any way to change sort order. But all my photos are named with date/time in them, so they're sorted alphabetically which works well enough for me. Sort by date and time would be better.
    I don't experience that...mine all show the date taken. Perhaps it has something to do with uploading from the camera to the TF. I transfer to my computer first, and then upload to the TF.
     
  5. sid52

    sid52 Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    43
    Joined:
    Mar 30, 2010

    Mar 30, 2010
    43
    1
    36
    OK, looks like I've sorted this problem out. The issue of incorrect date only occurs in the 'Imported' album. All other Gallery albums automatically created by the TF, eg Dropbox, Photos etc, have the capture date as recorded in the camera exif file.
    Using file manager to add a folder under /sdcard/imported and then copying photos into this folder results in the correct capture date being displayed. Therefore I can now resort photos by capture date.

    However there still two problems.
    1. How can I move photos into an album rather than copy and pasting.

    2. In full picture view, the gallery consistently force closes when 'Details' are selected from the top right menu. This occurs for all albums and photos. Other menu items such as 'Rotate' and 'Set Picture As' all work OK.

    Thanks
    Sid
     
  6. bfksc

    bfksc Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,262
    Joined:
    Aug 29, 2010

    Aug 29, 2010
    1,262
    201
    143
    Canada
    I just copy and paste photos into the Picture folder without issue from my PC. I think your issue is related to copying photos from the camera to the TF.
    Same here...I've noticed that since v3.1 and now v3.2 as well. It's a bug in the Gallery app, but I don't know if it's an ASUS or Android app. I haven't reported the bug yet...
     
    sid52 likes this.
  7. sid52

    sid52 Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    43
    Joined:
    Mar 30, 2010

    Mar 30, 2010
    43
    1
    36
    Yes you are correct, I sometimes load from the camera on to the TF as well as the PC. It's the default 'imported 'album that has the date problem. It would be useful to have a 'move' function as well as copy and paste.

    Bty, how does one report a bug?

    Thanks for your replies.
    Sid
     

Share This Page

Loading...