1. Are you ready for the Galaxy S20? Here is everything we know so far!

Urgent - Lava IRIS 455 wont boot - firmware restore did not work..

Discussion in 'Android Lounge' started by AndrIos, Sep 30, 2014.

  1. AndrIos

    AndrIos Lurker
    Thread Starter

    Hello,
    I have a Lava IRIS 455 phone, which needs to be restored but it is not working.
    Phone was working fine till today morning (6 hours ago), battery level was 52% and I kept same on charging, after 20 mins it was showing a black screen..
    I tried to reinsert battery after removing and tried all basic things but nothing worked..

    I tried to restore firmware as well, but its still on same condition.
    I have to move out urgently for a meet and dont have any other phone in hand..

    Please help.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. mikedt

    mikedt 你好

    Chinese phone of unknown manufacturer, that's sold in India? From what you're describing sounds like it's fatal unfortunately. You could try holding down various combinations of power, volume and home, see if it can be reset or revived that way.
     
  3. AndrIos

    AndrIos Lurker
    Thread Starter

    Thanks tried everything.. nothing works.
     
Loading...

Share This Page

Loading...