1. Download our Official Android App: Forums for Android!

Support Urgent: Xperia X10 stuck in airplane mode

Discussion in 'Android Devices' started by rock87in, Jun 27, 2011.

  1. rock87in

    rock87in Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Jun 27, 2011

    Jun 27, 2011
    3
    0
    5
    Hello,

    Yesterday I installed 2.1 android os (because it showed up on my Ericsson PC companion that i needed to update s/w). Everything i did was absolutely legal/original as prompted by sony s/w.

    I followed everything, and the phone worked great for a while. Suddenly I noticed that I was in airplane mode, switching it off, didnt help, because it basically switches on immediately. I tried it a 100 times but still...

    I tried reading a lot of things online, but nothing helped. Restarting, reinstalling, I am completely clueless on what to do. Please can someone help me out !! I am w/o a phone now for a day now ! please !

    Thanks a ton !
     

    Advertisement

  2. beau420

    beau420 Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,104
    Joined:
    Nov 10, 2010

    Nov 10, 2010
    1,104
    173
    143
    Computer Guy
    Ottawa
    Uninstall PC Companion.

    Download SEUS from Sony and reflash the phone.

    When you hold the power button down it should say Airplane mode is off.

    For you it reverts back to ON? How quickly? Does it ever stay on OFF?

    Check what version of Android installed. Goto About Phone and what does it say for Baseband version and build number?
     
    rock87in likes this.
  3. rock87in

    rock87in Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Jun 27, 2011

    Jun 27, 2011
    3
    0
    5
    Ok thanks I'll try SEUS.

    There are 2 ways of reaching airplane mode-> holding power button and through settings.
    Power button mode-> If i turn it off, it shows as off . But i know it is not actually off cause it still behaves as if in airplane mode. Also i can check by going to settings that its still on.

    Settings mode-> Here is the real screwed up part. If i uncheck airplane mode, and i go into another page (or just hit back) and when i hit settings again, i see it is checked again. So basically my unchecking it shows it getting unchecked (reading "enabling wireless connections"), but as soon as i revisit that page its back on (in other words it is literally permanently on).

    Firmware version: 2.1-update1
    Baseband version: 2.1.65
    Build number: 2.1.A.0.492

    I appreciate any ideas on this issue. !!
     
  4. beau420

    beau420 Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,104
    Joined:
    Nov 10, 2010

    Nov 10, 2010
    1,104
    173
    143
    Computer Guy
    Ottawa
    Make sure it says it is OFF and then do the following:

    Settings->Wireless and Network->Mobile Networks->Network Operators.....try and search.

    If Airplane mode says it is off, it shouldn't let you search for any wireless networks.

    Also check Settings->About Phone->Status does it have your phone number and network....what does it have for mbile network type and service state and roaming and mobile network state?
     
    rock87in likes this.
  5. rock87in

    rock87in Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Jun 27, 2011

    Jun 27, 2011
    3
    0
    5
    Hey buddy ! SEUS worked ! i dont know how, and what lol, but my phone seems perfect now and 2.1 looks so much more awesome than 1.6

    I just hope this airplane issue doesnt arise again.

    Thanks for your help mate !
     
  6. beau420

    beau420 Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,104
    Joined:
    Nov 10, 2010

    Nov 10, 2010
    1,104
    173
    143
    Computer Guy
    Ottawa
    Nice. I have never seen or heard of it before, so must have been a fluke.
     

Share This Page

Loading...