1. Check out our companion app, Forums for Android! Download from Google Play

Support USB Charge only keeps mounting SD

Discussion in 'Android Devices' started by pagdodd, Nov 27, 2010.

  1. pagdodd

    pagdodd Well-Known Member
    Thread Starter
    48

    Apr 6, 2010
    221
    23
    48
    Male
    Admin Manager
    Shropshire, UK
    contrary to what the title says , every time I plug my phone into USB it keeps UNmounting the SD card. Despite me having it set to charge only.

    Is there anyway to stop this?
     

    Advertisement

  2. Geordie Ahmed

    Geordie Ahmed Well-Known Member
    16

    Jun 9, 2010
    86
    7
    16
    Maybe I am missing something BUT why do you want it to stop?

    When you select charge only then the SD card is mounted so that way you can continue using it whilst charging
     
  3. pagdodd

    pagdodd Well-Known Member
    Thread Starter
    48

    Apr 6, 2010
    221
    23
    48
    Male
    Admin Manager
    Shropshire, UK
    sorry, what I meant was that it keeps unmounting as if I have chosen disk drive

    Therefore any widgets/apps installed to SD stop working.

    As it is well documented, the battery aint great on these phone so when at work I plug it into USB just to charge.
     
  4. Eris Ed

    Eris Ed Well-Known Member
    93

    Jul 20, 2010
    982
    248
    93
    Manchester, UK
    When you choose Disk Drive as the USB connection, Android unmounts the card so you can access it with your PC through USB. Widgets use the SD card so some widgets and apps won't be running properly while Disk Drive is selected.
     
  5. pagdodd

    pagdodd Well-Known Member
    Thread Starter
    48

    Apr 6, 2010
    221
    23
    48
    Male
    Admin Manager
    Shropshire, UK
    My problem is that I am not selecting disk drive, I am selecting charge only but it keeps unmounting the SD
     
  6. Harry2

    Harry2 Well-Known Member
    323

    Jun 3, 2010
    5,186
    1,347
    323
    Black Forest
    " ... every time I plug my phone into USB ... "

    In PC's USB or charger's USB ?

    Harry
     
  7. pagdodd

    pagdodd Well-Known Member
    Thread Starter
    48

    Apr 6, 2010
    221
    23
    48
    Male
    Admin Manager
    Shropshire, UK
  8. djl208

    djl208 Member
    16

    Oct 6, 2010
    15
    3
    16
    Are you using Winamp? This has a setting on it that automatically makes the sd card visible as a drive when connected via usb which seems to override the usual settings. You can disable the feature via Winamp's settings. If not using Winamp it may be another app that is doing something similar.
     
  9. Harry2

    Harry2 Well-Known Member
    323

    Jun 3, 2010
    5,186
    1,347
    323
    Black Forest
    Yes, I thought of this, too.

    WinAmp, Double Twist or iSincr can do this.

    Harry
     
  10. Gisbourne

    Gisbourne Well-Known Member
    16

    Jun 17, 2010
    55
    5
    16
    Mine's doing this too and I have Winamp installed so will try disabling/uninstalling Winamp as I don't really use it to be honest (still tend to wind up using the stock player).

    Thanks for the heads up,

    G
     
  11. markyboy

    markyboy New Member
    5

    Nov 28, 2010
    2
    0
    5
    :mad:
    Something is definitely not right about the pc link on my phone. I have read other threads and this seems to be a reoccurring problem. I have linked and unlinked my phone to the pc via usb and nothing comes up on the phone. I have ticked the "always ask" in the pc connections menu. I have just installed winamp and am aware of the preset, but the phone was playing up before i installed winamp
    I just recently did a factory reset and the phone linked again, but now it gone back to its old habits; not even notifying me of what mode it is in. Even if it is on disk drive mode it is not recognised on the pc. I suspect an app causing this, but the prospect of going through each one is soul destroying. too much else i need to do without this. Please help
     
  12. ScoobyWRX

    ScoobyWRX Well-Known Member
    58

    Oct 14, 2010
    212
    24
    58
    Poole, Dorset
    This has started doing this to me today :thinking: plug in the pc USB connector and I don't get the disk drive ect. options come up anymore.
    Any ideas guys :(
     
  13. ScoobyWRX

    ScoobyWRX Well-Known Member
    58

    Oct 14, 2010
    212
    24
    58
    Poole, Dorset
    Ok, did a search, took out the battery, sim and sd card, rebooted but no change.
    My phone usb cable is plugged into usb multi plug that is connected in the back of my pc, someone suggested plugging the phone directly into the pc usb port and it worked first time! :thinking:
     
  14. pagdodd

    pagdodd Well-Known Member
    Thread Starter
    48

    Apr 6, 2010
    221
    23
    48
    Male
    Admin Manager
    Shropshire, UK
    That's it!

    Just removed Winamp and problem solved.
     
  15. Deckland

    Deckland New Member
    5

    Sep 21, 2010
    4
    0
    5
    Well bugger me, it was Winamp causing me that grief...I had the original poster's issue, SD card stored stuff not being available no matter what "mode" I picked... checked and yep, that little default of "Enable Auto-Mount" was ticked. Have now disabled, and all of my functions have come back!!! Including tethering, which had stopped. Winamp still installed and working fine...

    Thank you for the solution to my issue.
     
  16. ndycrlr

    ndycrlr New Member
    5

    Nov 29, 2010
    1
    0
    5
    All the things I've fiddled with to try and get CoPilot working and it was Winamp. Thanks for the replies - you've saved me a major headache.

    Andy.
     
  17. Gisbourne

    Gisbourne Well-Known Member
    16

    Jun 17, 2010
    55
    5
    16
    Just a follow up, but this did solve it for me although I didn' uninstall Winamp in the end, I just disabled the auto-mount option.

    For those that are interested, my reason for not uninstalling Winamp is that it now offers wireless music sync with your PC client which is bloody marvellous!

    Cheers,

    G
     
  18. JSR

    JSR New Member
    5

    Dec 7, 2010
    3
    0
    5
    Amazing! This fixed my issue I had been experiencing too!
     
  19. Rastaman-FB

    Rastaman-FB Well-Known Member
    313

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    winamp is a bugger for doing that without warning
    i noticed it straight away months ago when it was released as i always check settings of everything i install and i though "oooh cheeky"

    at this point i removed it for its steve jobs like behaviour.
    it has no reason to need to automount, its android not iphone
    i know you can disable it but because the option is on by default it pissed me off to no end

    bloody AOL (owners of winamp and why its now evil)
     
Tags:

Share This Page

Loading...