1. Download our Official Android App: Forums for Android!

USB connection (drag and drop)

Discussion in 'Android Devices' started by andrewdoane, Nov 11, 2009.

  1. andrewdoane

    andrewdoane Member
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    50
    Joined:
    Nov 6, 2009

    Nov 6, 2009
    50
    0
    15
    I have my Droid connected to my computer via the USB that came in the box. The phone recognizes the cable, chimes, and has the USB icon on the screen. But the computer doesn't recognize the phone at all. It could be a problem with my computer, but I'm checking here in case I just can't find the option on the phone to "allow USB connection" or something.

    Edit to add: I've never had a problem with connecting phones via USB in the past. Just yesterday it was working for my old phone.
     

    Advertisement

  2. Barbara

    Barbara Android Expert
    Rank:
    None
    Points:
    88
    Posts:
    840
    Joined:
    Oct 31, 2009

    Oct 31, 2009
    840
    31
    88
    You didn't mention whether or not you did the step (on the phone) to mount the usb to your computer. Did you do that and it still doesn't work?

    I attach the usb cable to my phone and to the computer
    I get a notification on the phone that the usb is attached
    I drag down the top tab and select usb connection
    I hit the button to mount the usb
    I go to My Computer (on the computer) and open the F: drive
    Now I can drag and drop from my computer to my phone

    I added a few folders to the sd card like Pictures, Ringtones, Music. I put the corresponding files in those folders.
     
  3. andrewdoane

    andrewdoane Member
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    50
    Joined:
    Nov 6, 2009

    Nov 6, 2009
    50
    0
    15
    I did hit "Mount" and it doesn't do anything. It doesn't show up on my computer as a drive or a mobile device or anything. I did try restarting the phone and the computer and it didn't work.
     
  4. theotherjim

    theotherjim Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Nov 11, 2009

    Nov 11, 2009
    3
    0
    5
    El Dorado Hills
    I've tried to mount the Droid with no success, both on 64-bit Vista and, today, on 64-bit Windows 7. The computer sees the Droid, but tells me that there's no card in it and (today) that the directory name is invalid. Any suggestions? It mounts just fine on my XP desktop.
     
  5. theotherjim

    theotherjim Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Nov 11, 2009

    Nov 11, 2009
    3
    0
    5
    El Dorado Hills
    Solved! I put the phone into "USB Debug" mode and the USB connection went off as advertised. This isn't how things should operate, but I'll take what I can get at the moment. Here's how, if anyone else is having the same problem:

    1 - Go into Settings
    2 - Select Applications
    3 - Select Development
    4 - Select USB debugging (and, while you're at it, select "Stay Awake" to keep the Droid awake while connected via USB to the computer or charger.

    I elected to allow mock locations as well. Just in case.

    - Jim
     
  6. andrewdoane

    andrewdoane Member
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    50
    Joined:
    Nov 6, 2009

    Nov 6, 2009
    50
    0
    15
    Thanks for the help. At least the computer recognizes that it exists now. I can't get it to show up as a drive because the computer doesn't know what it is and can't find a driver for it. I can't figure out a way to make Windows just call it USB storage.
     
  7. theotherjim

    theotherjim Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Nov 11, 2009

    Nov 11, 2009
    3
    0
    5
    El Dorado Hills
    Andrew -
    One step I left out was installing a new USB driver from Motorola (click here for the download page); this may or may not help. (I didn't do the required reboot after installing the driver, since I found the USB Debug setting in another thread, so I don't know if debug mode will work independent of that driver.)
    - Jim
     
  8. johninbigd

    johninbigd Android Enthusiast
    Rank:
    None
    Points:
    36
    Posts:
    318
    Joined:
    Jun 3, 2009

    Jun 3, 2009
    318
    7
    36
    Interesting. I connected mine to Vista 64-bit last night with no problems at all.
     
  9. andrewdoane

    andrewdoane Member
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    50
    Joined:
    Nov 6, 2009

    Nov 6, 2009
    50
    0
    15
    Solved! Finally! theotherjim FTW - 3 posts and all of them helping me. Thanks a million.

    For others reading this:
    1. Get the Motorola driver from Jim's link2
    2. Do the "Mount" thing
    3. Go to My Computer and open "Removable Disk"
     

Share This Page

Loading...