1. Are you ready for the Galaxy S20? Here is everything we know so far!

USB Device Unknown.

Discussion in 'Android Devices' started by ecnalb83, Nov 13, 2011.

  1. ecnalb83

    ecnalb83 Lurker
    Thread Starter

    Hi there!

    I am trying to figure out this problem. my I9100 wont connect via the USB ports to my computer. I get an error "Unknown device".

    My computer is Windows 7 x64. When I connect it to USB, the phone starts charging, but wont connect (I got to setting > network > USB, select connect USB, I connect and then nothing happens, the dialog stays up saying connect to usb port"P)

    I have tried uninstalling the Samsung USB drivers, and then reinstalling them, that done nothing. Tried updating the driver via windows updates, that did nothing.

    So I am asking for some help be cause I am at wits end, and I cant seem to fix this issue.

  2. Russell Ng

    Russell Ng Android Expert

    I think you are doing it wrong.

    You need to go to Settings/Wireless & Network/USB Utilities

    Tap the Connect to USB icon, then only connect the USB cable. Tap another icon on the phone, and you should be ready to go.
  3. ecnalb83

    ecnalb83 Lurker
    Thread Starter

    Yeah, thats what I am doing.
  4. Russell Ng

    Russell Ng Android Expert

    Have you tried using another computer? I am not sure what's wrong if you are doing it right. I know Windows 7 64bit and Kies have issues (at least for me when trying to update firmware), but that won't effect the USB connection since you are using it like a hard drive.

    I never needed samsung USB driver to connect since its just a normal USB connection. Where did you get the driver from?

    PS-Did you tap the icon on the phone after you connect the cable?
  5. sleeco

    sleeco Well-Known Member

    Hi, try another USB port, it worked for me.
  6. Sword Fish

    Sword Fish Android Enthusiast

    Have you upgraded Kies? There is a new version out as of yesterday as my computer automatically upgraded. BTW, be carefull because it reboots your computer when done without telling you it is going to do that!

    I have the unknown device also but it doesn't prevent me from connecting to Kies. I am also on Win7 64 bit so I am not sure what your issue is. Kies has always been finicky. The Samsung USB drivers can be found on the Samsung Support web page.
  7. ecnalb83

    ecnalb83 Lurker
    Thread Starter

    Okay, I dont use Kies, because I used Odin to flash any ROM's I choose.

    Now weirdly. I didnt change anything this morning. I plugged the phone in and low and behold, the USB connection was made. All that was different was a PC reboot, and a new battery (upgraded) placed into the phone

    I got no idea what happened. :|
  8. napi1

    napi1 Lurker

    try to key in this in dialer


    it has 4 option there..


    For usb. select the PDA.if it already selected to PDA. reselect it by select MODEM and then PDA again.. Only change the USB setting.. andthen press back. try reconnect to kies again..
    hope it helps..
    samdev likes this.
  9. samdev

    samdev Lurker

    omg it worked...was trying all sorts of stuff since past 2 hours or so and nothing worked, but this simple trick worked....thnx a lot bro
  10. Gurba

    Gurba Android Enthusiast

    Didn't work. My S2 haven't connected to my Win7 64-bit PC for months. It won't even connect in storage mode. I press the buttun on the phone to connect in storage mode but nothing happens when I plug the phone in. I find it strange that a big company like Samsung can live with offering such a crap software solution to their customers.
  11. Russell Ng

    Russell Ng Android Expert

    I am assuming you manage to connect before. And if you cannot now, then perhaps you better get the phone checked. Some mentioned that the USB port needs to be cleaned after some time.

    If you have never connected before, same advice :D
    Just maybe try to follow the steps outlined in the post again. About tapping the icon before connecting the cable and also after connecting the cable.

  12. sisavinash

    sisavinash Lurker

    Thanks! this works.:)
  13. Lemvig

    Lemvig Lurker

    hey guys, i got the same kind of problem with my sgs2 not wanting to connect to my pc... well any pc or mac or linux really, tried em all

    and yes im using the original samsung cable that came with the phone ;)

    what happens is i plug in my phone and my phone says "initializing" ..... "connected"


    windows cant find it, and it does not make the little "ping" sound you usually get when you connect an usb device

    got the latest kies installed and the drivers that came with it... never used kies before tho i only installed it to see if it might help detect my phone... no luck :(

    also tried the *#7284# trick... no luck :(

    also tried the debugging feature and the mass storage feature... again no luck on either option.

    and lastly I have also tried using a toothbrush to clear out grime and dust from the small connection port on the phone and the on the cable.. no luck :(

    oh and when the phone is connected and it shows "connected" on my phone with the picture of the usb cable... if i then press the home button to leave the connection while the cable is still attached windows gives me the following pop up "usb device not recognized" and it goes on the show an "unknown device " in the windows device manager... and yes I've also tried removing the "unknwon device" and pluging in the phone after i have removed the device... which just nets me the exact same result as described above :)

    so... before i go do a factory reset and loose everything (seeing as i cant back anything up before doing it) does anyone have any idead or suggestion to what might be wrong ?
  14. rabben

    rabben Member

    Hi, I have the same issue as above. Have tried all things mentioned!
    I have experienced this before, and managed by changing USB port. This worked for some time until same thing happened. Changed USB port again and everything worked. Now my last port is not working. My computer does not respond when I connect - nothing, and really fed up.

    Running win7, x64

    Please anyone...
  15. Russell Ng

    Russell Ng Android Expert

    Is it a problem with your PC USB port?

    1) Try to download / update Kies at least for any drivers. You don't have to use the program. (Restart the PC after install which might help if it doesn't work straight away)
    2) Try connecting to another PC. At least to make sure where the problem lies.
    3) Try the USB mass storage method for connection without the USB debugging ticked.

    If all does not work, I don't know how to help because it works for me...
  16. TMAce

    TMAce Lurker

    Hey guys, I'm getting same problem trying to get the ICS update onto my S2! Both PC's are Windows 7 x64, one PC says there's a connection error and try debug USB mode (doesn't work) and the other either gets stuck in a loop updating Kies or just launches and says I have the latest phone firmware (the ICs update has been out on my network for over a week). I've tried all the above solutions, wondering if anyone else knows what to do? A friend had a similar problem solved by the dialpad solution but it hasn't worked for me
  17. deViceroy

    deViceroy Lurker

    I have a Galaxy S2, ICS and has been working perfectly well tethering to my PC until today, when the dreaded Unknown Device started occuring. I deleted the Unknown device from the USB list in Device Manager (Win XP 32bit) and re-connected it to different USB ports and eventually it recognised SAMSUNG_Andoid and re-installed the modem, and I'm back up and running.

    No idea why it suddenly decided to delete the previous settings and opt for an Unknown device, however I do regularly simply pull the cable out while tethered without unticking the box on the phone, so maybe that messed it up ??? Just a guess.

    The phone was fine, because it connected perfectly well to my spare PC, so it's something in XP that did it.

Samsung Galaxy S2 Forum

The Samsung Galaxy S2 release date was April 2011. Features and Specs include a 4.3" inch screen, 8MP camera, 1GB RAM, Exynos 4210 Dual processor, and 1650mAh battery.

April 2011
Release Date
Similar Threads - USB Device Unknown
  1. King Mustard
  2. flippindocks
  3. NigelMontezuma
  4. Sumit Mourya
  5. mplayervj
  6. oldun
  7. kenak
  8. Mussharraf Hossen Shoikot
  9. dickthedev
  10. motouser

Share This Page