1. Are you ready for the Galaxy S20? Here is everything we know so far!

USB file transfer not working, "Device Busy"

Discussion in 'Android Devices' started by Cheetawolf EagleHawk, Feb 13, 2016.

  1. Cheetawolf EagleHawk

    Thread Starter

    I do a lot of work with videos, and I use my phone as a video camera as it supports 1080p60 video, and normally it automatically sends its videos to a network drive, where I can edit them on my PC. However, that app (WD My Cloud) has now stopped working, so I decided to pull my videos off via USB so I could edit them and switch back to my proper camcorder, albeit at only 30 FPS.

    However, I ran into this nasty surprise every single time I tried to pull a video off in Media Device (MTP) mode.
    Whenever I open the phone in Windows Explorer, I get this message.
    [​IMG]

    And then when I go to take a video off of my phone or even play it on my computer, I get THIS message.
    [​IMG]
    Images transfer fine, only the videos give me these problems.
    Even if I force-close all non-critical apps or open the device seconds after rebooting it, I still get these errors.

    And in the Camera (PTP) USB mode, the videos simply don't show up at all on the device.
    The images still do, but the videos do not at all.

    Why Google didn't put in just the standard USB drive style mode instead of these useless, defective MTP and PTP modes I have no idea.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. AZgl1500

    AZgl1500 Extreme Android User

    dunno if it will help you, but give this app a try, it transfers to a PC via the WiFi network.

    The PC has to have 'Sharing" setup and I assume yours already does if you have been doing this already.

    * File Manager ASUS - Android Apps on Google Play

    this is my favorite file transfer app to a pc, it finds all of the PCs/Laptops in our house and I send stuff to any of them at will.


    What I really appreciate with it, is the fact that in any of the categories, the Most Recent pix/video/document is always at the top of the page to open and find your file to send.

    click on the category, long press on the folder, find the images you want and long press on one, and then click to attach more if you like....

    then the 3 dot menu to select "copy to" and then choose 'Network" the 1st time, then after that you just choose "Most Recent location" and your networked PC is right there for you, then you drill down to the folder you want to place those files into, and click OK.

    takes 10 times longer to type this, than to just do it.
     
    javamann likes this.
  3. touringhaggis

    touringhaggis Android Enthusiast

    Ok, wild guess here. Since the video files are going to be larger than photos it could be that you are hitting file size limits for the emulated file system that is MTP. Yes, I know this sucks and I too fight with it, but it is the only way to share the storage device with your phone and computer at the same time (since most file systems only allow one OS at a tine to mount them). I remember, on my Nokia N900, having to kill all programs that were using my SD card before I could connect to my PC.

    If the ASUS file manager (above) also has a file size limit, then you may need to copy the files to an SD card and then use that card to transfer the files to your computer. Just make sure that you format the card ExFAT so that Mac, PC and the phone can use the card ;)

    With regards to your WD My Cloud app: You could try resetting the apps cache, and failing that it's saved data, (both via the application manager) to see if this resurrects the connection. It could also be that a new version broke something. Either try to install an older version or contact the app developer for further help. It seems a pity to have to switch video hardware just because of an app problem.

    Oh, one other thought: Make sure you have the latest device drivers for your telephone installed.

    Regards,
    Eric.
     
  4. mikedt

    mikedt 你好

    Basically because Windows can't read or write Linux EXT formatted media, not without a $40 third-party utility. The internal storage on your phone is EXT formatted. Old devices had FAT32 formatted internal storage, but it meant they couldn't store >4GB files and was less secure. And Android is Linux based of course.

    MTP although it's not perfect and is a compromise, it's media format agnostic.
     
    svim likes this.
  5. AZgl1500

    AZgl1500 Extreme Android User

    so far, the ASUS file manager has moved a very huge video to my PC, it was almost 15 minutes long. don't recall how large the file size was though.

    I am just now moving a mp4 file of 625 mB via WiFi and it is going quite well.
    It has copied all of my pictures in one fell swoop last week, over 1,000 pictures and it worked good there also.
     
  6. Cheetawolf EagleHawk

    Thread Starter

    Thanks for the help, everyone, but I think my problem may be a failing SD card or perhaps one of the videos themselves are corrupted.
    I've put it into an adapter as a last resort to get the videos off, and it ground to a halt at the exact same point every time I tried to move all the videos over at once.

    Using the adapter that came with the SD card...
    [​IMG]
    That stopped, but the speeds were unstable, so I tried an older adapter, maybe this one's bad...


    [​IMG]
    Slow and steady, but still lost the race.

    Same exact spot. The video inexplicably stopped at certain points on the device itself, too, saying "Sorry, this video cannot be played".
    I ran the copy again excluding the video that stalled it, and this time it worked fine, so I think just that one video might have been damaged by something, or perhaps the MicroSD card has a bad sector there (Assuming solid-state storage can even get bad sectors).

    Luckily, the video was still in good enough shape to manually duplicate it via SideSync and a screen recorder.
     
    #6 Cheetawolf EagleHawk, Feb 15, 2016
    Last edited: Feb 15, 2016
  7. AZgl1500

    AZgl1500 Extreme Android User

    I think you have the problem in sight.

    the extSDcard has failed. They are only good for so many "writes" and then they are kaput!

    buy the best one you can afford, Class 10 at a minimum.
     

Samsung Galaxy Note 4 Forum

The Samsung Galaxy Note 4 release date was October 2014. Features and Specs include a 5.7" inch screen, 16MP camera, 3GB RAM, Snapdragon 805 processor, and 3220mAh battery.

October 2014
Release Date
0
Reviews
Loading...
Similar Threads - USB file transfer
  1. melani78
    Replies:
    2
    Views:
    247
  2. Kozzm0 McAlister
    Replies:
    6
    Views:
    640
  3. ilus4
    Replies:
    4
    Views:
    574
  4. Chance cook
    Replies:
    9
    Views:
    673
  5. Rebecca Baxter
    Replies:
    3
    Views:
    1,040
  6. MrOldCrypto
    Replies:
    7
    Views:
    673
  7. FeriM
    Replies:
    11
    Views:
    833
  8. David Labrecque
    Replies:
    3
    Views:
    3,128
  9. RhinoCan
    Replies:
    4
    Views:
    2,553
  10. MSTRA
    Replies:
    1
    Views:
    2,718

Share This Page

Loading...