1. Check out our companion app, Forums for Android! Download from Google Play

Root USB Mass Storage, ADB, and Mac OS X

Discussion in 'Android Devices' started by GTSchubert, Apr 18, 2010.

  1. GTSchubert

    GTSchubert Member
    Thread Starter

    Mar 23, 2010
    Pittsburgh, PA
    So I've used Macs as my primary computer for over 5 years now. I love them! However, I refused to go the route of the iPhone. It was just too dumbed down. So I got a Moto Droid.

    So here's my timeline.

    I first tried to mount it as a USB Mass storage. It worked. I could see everything. I tried copying a large file (not DRM'd) and it froze about a minute into the copy. Pulled the battery, reset the computer, tried again. Didn't work. GAVE UP.

    (2.1 OTA)
    Same thing. Didn't work. GAVE UP!

    (2.1 NexTheme ESE81 R1)
    Same thing. Didn't work. Tried using the 'adb push' command. IT WORKED! Why would mass storage screw up my computer, but adb works?

    P.S. I have used the USB mass storage successfully many times on friends' windows machines.

    My mac machine is a 15" Unibody Macbook Pro with 2.66 Intel C2D and running OS X (10.6.3). Any Ideas?

    Thanks in advance!


Share This Page