Help USB / Mass storage problem


Hey all,

I purchased the fascinate back in Oct 2010, and have had no problems with it...until...few days ago.

On the notifications bar, a strange Diamond looking icon with a + sign inside it appeared. I had no idea what it was and didn't really care for it until I realized that when I connected my phone to my computer using the USB cable (that came with the phone) the phone would not be recognized as a mass storage drive but instead it was being recognized as a CD DRIVE.

I was able to access the CD Drive, which had Verizon updates inside it. Anyway, I ran the updates on this "virtual" cd drive, then, I was prompted to install something called "Verizon Atlas" I had no idea what it was, and for no reason decided it was unnecessary....and hence, didn't bother to install it.

The problem persisted, so I got annoyed and started installing the drivers I found on SamSung's website. Furthermore, I also called verizon and asked them what's up, and the rep said that there was an update on the phone that was pushed through, and that a mass storage problem was noted and they were working to fix it

However, the agent sounded inconfident in any of the answers he provided. He wasn't very tech savvy, as I asked questions that he had no idea of, and he didn't seem to understand a lot of the terms that a 1/2 tech geek would know, such as "PCI Simple Communications tools driver" or etc..


Mass storage mode not working still, the same thing is happening with my roomate's phone, who also has the Fascinate. We've both tried everything.

Any ideas or help would be greatly appreciated.


=Luceat Lux Vestra=
Welcome to the forums, Jcx1984.

It looks like you've identified an issue that is being addressed in a few other threads here in the Fascinate area.

The tech did have a bit of a clue, but not enough to elaborate.. that's ok because, well, we're used to this aren't we? :D

Meanwhile, waiting for the next update would not be an option if it were my device with that issue; I'd backup a few things and do a factory data reset.