1. Check out our companion app, Forums for Android! Download from Google Play

USB Mount Notification Not Appearing

Discussion in 'Android Devices' started by shatminer, Feb 4, 2010.

  1. shatminer

    shatminer New Member
    Thread Starter

    Feb 4, 2010
    Searched around for several hours trying to find info on this issue to no avail.
    Someone seemed to have the same problem in this thread but the 'solution' there was no use. link

    I've connected my Hero (T-Mobile G2 Touch) to several different PCs many times before, I'd usually tap the 'Mount' notification and copy over photos and mp3s or whatever, no problem.

    In the last few days though, this notification hasn't been appearing, only the orange charge light comes on. I've tried this on 2 Vista Home Premium machines and a windows XP machine, in all different USB ports, with 2 different official HTC USB cables. Tried rebooting the phone and the computers, nothing works. My GF has the same phone and it works fine with either cable on 2 of the PCs.

    Any suggestions before I ditch this useless piece of crap and get a nexus or an iPhone?



Share This Page