1. Check out our app, Forums for Android! Download and leave feedback here!

Support USB only charges the Milestone BEFORE Windows boots

Discussion in 'Android Devices' started by cdl, May 6, 2010.

  1. cdl

    cdl Well-Known Member
    Thread Starter
    43

    Feb 4, 2010
    399
    35
    43
    I have a Milestone with Android 2.0, bought in the UK and unlocked.
    I have a desktop PC and a laptop, both running Windows 7 Pro 64 bit. If I conenct the Milestone to the desktop, it charges via usb just fine. If I connect it to the laptop, it only charges BEFORE windows boots up: the moment the log in screen appears, it stops charging. I tried installing the drivers from the CD and from the Motorola website, but to no avail. I tried switching off and on the phone several times, but nothing. The only way to charge it with the laptop is to leave the laptop in the bios screen or in the Windows boot up options screen! This seems very weird to me. Any thoughts on how I could fix this?

    Thanks!

    PS I can connect and charge other usb devices (Nokias, Iphones, external drives, etc).
     

    Advertisement

  2. fejker

    fejker Well-Known Member
    73

    Have you tried changing the USB connection type on your phone to "charge only"?
     
  3. MountainDrew

    MountainDrew Member
    16

    Mar 2, 2010
    13
    3
    16
    Might be a power saving feature on your laptop. Check the power settings in the control panel, see if there's a USB power saving mode you can disable. Try mounting the SD card too, it might start charging once there's a mass storage connection to the laptop.
     
  4. cdl

    cdl Well-Known Member
    Thread Starter
    43

    Feb 4, 2010
    399
    35
    43
    The option "charge only" only appeared today, after I updated OTA to Android 2.1, but nothing changed.
     

Share This Page

Loading...